Spezialfrage zu LAYOUT-Gruppencodes / Lisp
autocart 04. Nov. 2005, 12:25

Hallo!
Über (dictsearch (namedobjdict) "ACAD_LAYOUT") habe ich mir den ENAME eines Layouts herausgesucht und dieses dann mit (entget ENAME) abgefragt. Das Ergebnis sah so aus:

((-1 . <Objektname: 7c79b068> ) (0 . "LAYOUT") (5 . "1C10D") (102 . "{ACAD_REACTORS") (330 . <Objektname: 7d951cf0> ) (102 . "}") (330 . <Objektname: 7d951cf0> ) (100 . "AcDbPlotSettings") (1 . "") (2 . "plotter.pc3") (4 . "User257") (40 . 4.99533) (41 . 16.9332) (42 . 4.9953) (43 . 16.9333) (44 . 909.913) (45 . 1499.79) (46 . 0.0) (47 . 0.0) (48 . 0.0) (49 . 0.0) (140 . 0.0) (141 . 0.0) (142 . 1.0) (143 . 1.0) (70 . 688) (72 . 1) (73 . 0) (74 . 1) (7 . "_Farbe M100n.ctb") (75 . 16) (147 . 1.0) (76 . 1) (77 . 2) (78 . 150) (148 . -11.1693) (149 . -42.3913) (100 . "AcDbLayout") (1 . "HT 1OG") (70 . 1) (71 . 2) (10 6.17399 25.4581 0.0) (11 916.087 1525.24 0.0) (12 0.0 0.0 0.0) (14 11.1925 42.4135 0.0) (15 889.507 576.793 0.0) (146 . 0.0) (13 0.0 0.0 0.0) (16 1.0 0.0 0.0) (17 0.0 1.0 0.0) (76 . 0) (330 . <Objektname: 7c79b070> ) (331 . <Objektname: 7c79b078> ))

Es kommen zwei GC 1 vor! Der erste hat den Wert "". Soll das so sein, oder ist das ein Fehler? Beziehen sich die restlichen Daten, z.B. GC 2, dadurch auf "" oder auf "HT 1OG"?

Danke schon mal, bis später

CADmium 04. Nov. 2005, 12:36

Der erste GC1 ist der Name der eingestellten benannten Seiteneinrichtung.. danach folgen die Plotterdaten, der 2. GC1 ist der Layoutname dem die Layoutblockdaten folgen..

mapcar 07. Nov. 2005, 09:04

Richtig, was Cadmium sagt. Das ist auch an den Subklassen-Markierungen zu sehen:

(100 . "AcDbPlotSettings") (1 . "")

(100 . "AcDbLayout") (1 . "HT 1OG")

Diese Dinger werden ja von den meisten sträflich missachtet;-)

Gruß, Axel Strube-Zettler