Probleme mit PDF-export / Inventor
birk-wr 07. Apr. 2021, 15:28

Hallo Kollegen,

vermutlich seit dem letzten großen Windows Update (22.03.21) habe ich das Problem, dass PDF-Dateien, die mit Inventor erzeugt werden nicht mehr über Acrobat Reader gedruckt werden können. Unser ERP-System verwendet die API des CAD-Programms um die PDF zu erzeugen. Jetzt können die automatisch generierten PDF nicht mehr im ERP gedruckt werden.
Hat jemand eine Idee, woran das liegen kann und wie man die PDF-Ausgabe von Inventor und Autocad updaten oder prüfen kann?
Im AutoCAD kommt gleich die Fehlermeldung, dass die Druckeinstellungen nicht stimmen. Ich weiß aber nicht, wo man für den PDF-Export die Druckereinstellungen anpassen muss.
Das PDF-Druckprogramm PDF24 in der normalen Druckfunktion von AUtoCAD funktioniert noch.

Mit Freundlichem Gruß
Birk

Meierjo 07. Apr. 2021, 15:51

Hallo

Was ist denn für ein Programm unter Standard-App ausgewählt?
https://support.microsoft.com/de-de/windows/%C3%A4ndern-der-standardprogramme-in-windows-10-e5d82cad-17d1-c53b-3505-f10a32e1894d

Was war dort vor dem Update eingestellt?

Gruss

RolandD 07. Apr. 2021, 15:55

Zitat:
Original erstellt von birk-wr:
... Jetzt können die automatisch generierten PDF nicht mehr im ERP gedruckt werden...

Kannst du ein PDF, das vom ERP erzeugt wurde, von Hand drucken?

Das Problem wird sicher im ERP liegen.
Die Erstellung des PDF durch Inventor 2019 hat sich ja mit dem Windows Update nicht geändert.
Bei mir geht die Erstellung von PDF aus Inventor 2020.2 (über die API mit PDF-Export) mit Win-10 Version 20H2 Build 19042.867 unverändert.

birk-wr 07. Apr. 2021, 16:04

Hallo,

meinst Du für den Dateityp PDF? Da ist Acrobat Reader von Adobe eingestellt.
Verwendet Inventor dieses Programm für den Export?
Ich denke, vor dem Update war das auch so. Auf den Rechnern, die das Update noch nicht bekommen haben steht es auch so drin.

birk-wr 07. Apr. 2021, 16:09

Hallo,

nein, leider kann man alle PDF, die mit der Inventor Exportfunktion erzeugt wurden nicht mehr drucken. Das geht auch nicht mehr von Hand. Das komische ist ja, dass.
Nur wenn ich das PDF mit PDF24 erzeuge geht es noch.
Ich bin mir ja auch nicht sicher, dass es am Windows Update liegt. Allerdings ist das das einzige, was bewusst gelaufen ist in letzter Zeit.
Blöderweise schweigt sich Acrobat über Details aus. Es kommt nur die Meldung, dass ein Fehler aufgetreten ist.

Kannst Du mir sagen, wo man das im Inventor einstellen kann, womit der Export durchgeführt wird? Ist das eine Routine vom inventor oder verwendet Inventor eine externe Funktion? Dann kann ich da mal nachsehen. 

RolandD 07. Apr. 2021, 16:26

Hallo Birk,

erstell mal ein PDF im Inventor von Hand:
Datei -> Exportieren -> PDF
Unter Optionen kannst du die einstellen, ob alle Blätter, oder nur das aktuelle Blatt ausgegeben werden sollen.

Kannst du dieses PDF danach öffnen?

RolandD 07. Apr. 2021, 22:03

Vielleicht findest du
hier die Lösung

freierfall 08. Apr. 2021, 06:29

du solltest Dir die api Programmierung anschauen und da speziell welchen pdf exporter verwendet wird. Da scheint was nicht mehr zu passen. Denn die pdfs aus Inventor funktionieren, egal ob über die Exportfunktion oder über einen Drucker.

herzlich Sascha

Meierjo 08. Apr. 2021, 06:49


PDF-Translator.JPG

 
Hallo

Zitat:

Kannst Du mir sagen, wo man das im Inventor einstellen kann, womit der Export durchgeführt wird? Ist das eine Routine vom inventor oder verwendet Inventor eine externe Funktion? Dann kann ich da mal nachsehen.

Meines Wissens nach kann man nicht einstellen, womit der Export durchgeführt wird. Inventor verwendet den PDF-Translator (dwfout.dll).

Gruss

birk-wr 08. Apr. 2021, 11:43

Hallo,

vielen Dank für die vielen guten Hinweise. Ist mir fast peinlich es zu sagen. Die Ursache war ein Bitmap im Schriftfeld der Zeichnungen.
Wenn man das rausnimmt, dann funktioniert der Druck wieder.
Ist zwar nicht ganz klar, warum es jahrelang mit dem Schriftfeld ging, aber ein neues Bitmap hat das Problem aus der Welt geschafft.

Mit freundlichem Gruß
Birk

freierfall 08. Apr. 2021, 18:57

oh das Problem hatten wir auch und solange der alte Schriftkopf drinnen ist geht es nicht, ich würde kein Bitmap reinnehmen nur ein Vektordings mit gefüllt.  herzlich sascha