Rules, Aktivieren von Boolean Operationen / CATIA V6
s.bert 17. Jun. 2016, 15:29


Untitled.png

 
Hallo zusammen,

ich bin neue hier im Forum und habe sofort eine kleine Frage.

Ich nutze Catia V6 2013.

Erklärung des Problems, bei der Erstellung eines PartBodys sollen 2 Boolean (Add) hinzugefügt werden. Bei einem Fall die eine bei einem anderen Fall die andere. Die Regel Funktioniert. Das Problem ist jedoch das beide Add-Operationen mit dem dahinter liegendem Shaft über die selben Parameter gespeist werden. Wird nun die eine Add Funktion deaktiviert( über eine Regel), entsteht eine Fehlermeldung da im Shaft der Deaktivierten Add-Funktion eine Skizze nicht korrekt ist.

Ich kann leider nur die bestehenden Parameter benutzen.
Mein Problem ist, wieso gibt Catia mir eine Fehlermeldung obwohl doch im Baum die Add-Operation deaktiviert ist.
Deaktiviere ich den darunter liegenden Shaft , funktioniert es. sind jedoch mehrere Shafts unter der Add-Operation müssten somit alle ausgeschalter werden.

Jemand eine Idee?

Gruß Sven

Gruß Sven

moppesle 17. Jun. 2016, 16:03

Hallo Sven,

willkommen im Forum.

Ordne dir die Shafts separat in den Struckturbaum und erzeuge eine Kopie mit Link.
Diese dann verboolen und aktivieren/deaktivieren. somit brauchst du die Skizzen nicht gesondert aktivieren/deaktivieren.

schönes Wochenende.

s.bert 17. Jun. 2016, 16:24

Hallo Uwe,

danke deiner schnellen Antwort.

Ich versuche es noch etwas genauer zu beschreiben. Es sind wie in dem Bild im ersten Post zu sehen 2 Shafts, beide Shafts bekommen wie in der Skizze zu sehen den selben innen Durchmesser. Nun wird über eine Designtable der Außendurchmesser gesteuert bei Configuration A soll das Modell A mit dem Außendurchmesser erscheinen. Da aber der Parameter im Hintergrund auch an Modell B, das ausgeblendet ist, weiter gegeben wird, wird die Skizze zerschossen und eine Fehler Meldung entsteht. Jedoch ist das Modell B ja aufgrund der Regel deaktiviert, trotzdem kommt die Fehlermeldung hoch das in dem ausgeschalteten Modell ein Fehler vorliegt. Wie umgehe ich dies bzw. wie baue ich das Modell auf das es nicht passiert?

Gruß Sven

moppesle 17. Jun. 2016, 22:54

Hallo Sven,

ich verstehe schon dein Problem.

Die Anwort die ich oben geschrieben habe solltest du umsetzen.
leider kann ich zu V6 nichts sagen, da ich es nicht zur Hand habe.

Also, die Shafts in einem extra Körper verboolen. Diesen dann verdecken.

Jeweils eien Kopie mit Link des Shafts.Diese dann im Parbody verboolen und in deine Rule einbeziehen.

Anderfalls must du alle Kindelemente explizit in deiner Rule aufnehmen und gesondert deaktivieren.

Code:

if String.1 =="0"
{PartBody\Pad.1\Activity =false
PartBody\Sketch.1\Activity =false}

else
{PartBody\Pad.1\Activity =true
PartBody\Sketch.1\Activity =true}



s.bert 23. Jun. 2016, 09:26

Ich danke dir... das sieht sehr gut aus.