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To Using Macros

What are Macros?

Macros are simply a collection of Visual Basic for Applications (VBA, a simplified 
version of Visual Basic) code that allows the application (in this case Inventor) to 
perform complex actions automatically with limited user input.  An example of a macro 
might be a program that inserts multiple parts into an assembly document or even simply 
a toolbar button that accesses a menu command that does not have a default toolbar 
button.

There are two main categories of  custom programs for Inventor.  The first is add-ins (or 
add-ons).  These are more complex programs written in true Visual Basic that often inset 
a new menu item or toolbutton actomatically into Inventor.  Examples of add-ins are 
Animator, Kwik-Sert, iPropWizard, iAssembly Tools etc..  These add-ins need no 
setup as they are often EXEs and install themselves automatically into the Inventor 
application. 

The second is macros (which are by default *.ivb files) which are nothing more than 
ASCI text files that tell Inventor to perform certain actions.  They do not install menu 
items or come with default toolbar buttons but can be assigned to buttons.  This document 
will deal with how to use these types of Macros.

Macros access the Inventor application via a conduit called the Application Programming 
Interface (API).  This tutorial will not discuss how to write macros but rather how to use 
the ones that currently exist.  You can download many macros free of charge at the 
following sites:

http://www.sdotson.com/vba.asp
http://www.kwikmcad.com/
http://www.cbliss.com/inventor/iCode/index.htm
http://hjem.get2net.dk/opad/

How to Use Macros

Let’s first find a macro we want to use.  A good one to have in your arsenal is Kent 
Keller’s Obround (Slot) macro.  It creates a sketch of a slot that can be then cut-extruded 
to form a punched slot.

Go to http://www.kwikmcad.com/icode/macros/obround/nfobround.asp and click on 
the download icon.  Save the file to disk and unzip it into a folder.

TIP:  Many of us who write Add-ins and macros have agreed on a common folder to 
store these files.  It is suggested you store all your macros in the following folder:

C:\Program Files\Autodesk\Macros\

http://www.kwikmcad.com/icode/macros/obround/nfobround.asp
http://hjem.get2net.dk/opad/
http://www.cbliss.com/inventor/iCode/index.htm
http://www.kwikmcad.com/
http://www.sdotson.com/vba.asp
http://www.cbliss.com/inventor/iCode/index.htm
http://www.sdotson.com/ipropwiz.asp
http://www.kwikmcad.com/icode/kwiktools/kwiksert/nfkwiksert.asp
http://www.sdotson.com/animator.asp
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If you have installed any add-ins you likely already have this folder created.  If you 
do not, create it and place the obround.ivb file in this location.

Figure 1 - Common Macros Folder

There are several ways to load and run Macros.  We will look at 3 ways.

Method One:  Loading Individual Macros

Start up Inventor and click on Tools>Macro>Visual Basic Editor
You will be presented with the Visual Basic Editing environment.  Click on  File>Load 
Project  and browse to the folder when you unzipped the obround.ivb file.  (e.g. 
C:\Program Files\Autodesk\Macros\)

The code from the macro will be loaded into the VB editor. (See Figure 2)

Exit the VB Editor (File>Close) and return to the Inventor modeling interface.

Start a new part file and create a simple extruded block.  Now create a new sketch on a 
surface of the block.
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Figure 2 - Code Loaded into the VB Editor

We are now ready to run the macro code.  Select Tools>Macro>Macros.  You will see a 
dialogue like the one below.

Figure 3 - Run Macro Dialogue
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If you do not see the Obround Macro listed in the top textbox, choose the pulldown and 
select All Active Application Projects and Documents.

Find the Obround macro in the top text box, select it and click Run.

Fill in the values you desire in the dialogue and click Create.  The obround sketch has 
been created.  You can now position it by dimensioning to the sketch point at the center 
of the obround.

Figure 4 - Creating the Obround

You can now download, load and run other macros in this fashion.  Keep in mind that the 
macro stays loaded in memory as long as the Inventor session is open.  If you close (or 
crash) Inventor you will need to repeat the loading procedure.

While this procedure is effective for macros you may only use one in a while it is not 
very helpful for macros you want to have available all of the time.  The next method 
shows you an easier way to load and run these macros.
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Method Two:  Using Mr. Macro

Loading Macros via the VBE can be a semi-tedious process.  A much easier way to load 
macros is to use an add-on created by Charles Bliss.  Go to 
http://www.cbliss.com/inventor/iCode/index.htm and download Mr. Macro.

Close Inventor and install it following the supplied directions.  Restart Inventor and you 
will now see a new menu item “Mr. Macro”

Click on Mr. Macro >Load/ Run Macros.  The dialogue will appear (Figure 5)

Figure 5 - Mr. Macro Dialogue

In the top right you set the active directory.  As suggested before, place all of your IVB 
files in the C:\Program Files\Autodesk\Macros\ directory.  Click the browse button and 
set the working directory.  Mr. Macro will remember this directory each time you use the 
program.

In the list box to the right are all of the available IVB files in this directory.

http://www.cbliss.com/inventor/iCode/index.htm
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In the left hand pane is the list of actively loaded macros.  In this example you will see I 
have lots of macros named Module1.*  (we will discuss these later).
To load a macro, select it from the list on the right and click Load IVB Project (or 
simply double click on the macro).  To run the macro, select it in the left-hand pane and 
click Run Macro.  The macro will then run in Inventor and Mr. Macro will close.

From The Mr. Macro dialogue you can also unload macros and open them in the VB 
Editor.

As you can see this is an easier method to run macros that you may need occasionally.  
All the macros are in one convenient spot and you do not have to enter the VB editing 
environment.  However, for macros that you run very frequently you will want to look 
into the third method.

Method Three:  Using the Default.ivb File

The third method is the most complex but once you master it, it allows you to have 
instant access to all of your macros via toolbar buttons.

To begin this process start Inventor and navigate to Tools>Application Options>File

In the Default VBA Project area note the name and location of the IVB file.  By default 
when you install Inventor it should be pointing to 

C:\Program Files\Autodesk\Inventor X\Bin\Macros\Default.ivb where X is your 
Inventor version. (e.g 6, 7, 8)

NOTE:  Once you understand the process you may want to copy the defaut.ivb into 
your C: \Program Files\Autodesk\Macros\ directory and change the Application 
Options to point to this new file.

This is an empty macro file (IVB) that is loaded each time you start Inventor.  Any macro 
placed into this file will be loaded on startup.  

Close the applications options dialogue and open the VB Editor (VBE) as explained 
above.  If you have never used the default.ivb file when you load the VBE you will see 
only one module under the Default.ivb project. (see Figure 6).

At this point you can type in your own code or take code form other macros (the focus of 
this tutorial) and put them into this default IVB.

Load the obround.ivb file as we did in the first part of this tutorial.  You should now see 2 
projects in the left hand pane.  Expand all the + signs.  (see Figure 7)

We now want to take the code from obround.ivb and place it into our default.ivb.  To do 
this simply drag the icon of frmObround on top of the default.ivb project.  A PLUS sign 
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on the cursor should appear indicating that the information is being copied.  Do this for 
the Obround module as well.  If there were other modules or forms we’d copy these in as 
well.

Figure 6 - Default.ivb  in the VB Editor

Figure 7 - Obround.ivb Loaded
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Figure 8 - Obround code copied into Default.ivb

Your default.ivb should now contain 2 modules and one form as shown in Figure 8.

NOTE:  If you come across macros that contain a module named Module 1 you can 
also select the code in the right hand pane then paste it into Module1 in the 
default.ivb.  I find this useful for macros that only contain a small amount of code.

Before closing the VBE, click on the Obround module in the default.ivb (the one circled 
in red above).  Note the name of the subroutine in the right hand pane.  You need to find 
the name of the PUBLIC subroutine.  As we can see this one is named Obround.  The 
module is also named Obround.  You will need to know this info for the next section.

Unload the obround.ivb by selecting it then selecting File/Unload Project.  You do not 
need to save changes.  We do this just so you won’t have two copies of code loaded at the 
same time.

Click save and then close the VBE.  You can run the macro by selecting it in 
Tools>Macro>Macros method or via Mr. Macro.  However there is a much easier method 
of running the macros that exist in your default.ivb.

Creating Macro Toolbuttons

You can make icons for your macros to be used in toolbars.  First you will need to create 
a BMP image of the icon.  MSPaint is a perfect application for this process.  For small 
icons the size is 15 x 16 (high x wide).  For large icons it’s 22 x 24.  If you only use small 
icons you do not have to make a large icon.  
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You can use transparency in the icons by defining the transparent color in the lower right 
pixel.  Anything this color (I suggest using one of the basic colors) will not show up in 
the icon.

I have provided some sample icons you can download and modify.  Download them 
from:

http://www.sdotson.com/tutparts/macro%20icons.zip

There are large and small icons one each illustrating the transparent process and one each 
that is blank with which you can experiment.

Once you have the icons save them to the same directory as the macro (e.g. C:\Program 
Files\Autodesk\Inventor X\Bin\Macros\Default.ivb or C:\Program 
Files\Autodesk\Macros\ ) and name them according to the following formula:

ModuleName.SubName.Size.bmp

Where ModuleName is the name of the module in the macro, SubName is the 
subroutine name and size is either Small or Large.

In our case the name would be:  Obround.Obround.Small.bmp

If you had a sub named Test in the Module1 module then the name would be:
Module1.Test.Small.bmp

Once the icon has been created, the next step is to assign it to a toolbar.

Go to Tools>Customize>Commands.  Select Macros.  In the right pane you should see 
all Macros that are in your default.ivb file. (see Figure 9)

The macro should have the custom icon next to it.  If it shows an infinity symbol (a 
mobius strip looking object, like the one next to Convert) then your BMP is either in the
wrong location, is named incorrectly or you do not have an icon for this macro.  Now 
simply drag the icon onto a toolbar and existing toolbar or one you have created).

I suggest creating a new toolbar specifically for your macros as it makes it’s easy to
export these toolbars via the Export command for making your customization protable.

http://www.sdotson.com/tutparts/macro icons.zip
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Figure 9 - Available Macros

Exit this dialogue and click on your newly created tool button.  It should fire off the 
Macro.

I hope this helps to speed up your workflows and gives you a bit more understanding 
about the benefits and workings of macros.  For more information and macro downloads 
be sure to visit the following links:

http://www.sdotson.com/freetut/tips%20&%20tricks.pdf - includes some of this info 
plus a section on how to create sendkey macros.

http://www.sdotson.com/vba.asp - downloadable macros and add-ons

http://www.kwikmcad.com/ - downloadable macros and add-ons

http://www.cbliss.com/inventor/iCode/index.htm - downloadable macros and add-ons

http://hjem.get2net.dk/opad/ - downloadable macros and add-ons

http://hjem.get2net.dk/opad/
http://www.cbliss.com/inventor/iCode/index.htm
http://www.kwikmcad.com/
http://www.sdotson.com/vba.asp
http://www.sdotson.com/freetut/tips & tricks.pdf
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