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About Animation
Use the Application > Animation command to invoke the Design Animation option.  With Design Animation,

you can coordinate the components of an animation sequence and play back an animation.

When you select this command, a timeline window appears below the graphics window, and a toolbar appears

below the Pro/ENGINEER toolbar.  You can run, create, and manage your animation using the menu

commands, the toolbar buttons, or the timeline window.

You can use Design Animation to do the following:

� Visualize your assembly's operation.  If you have the concept, but have not defined the mechanics, you can

drag bodies to different positions and take snapshots to create an animation.

� Create an assembly or disassembly sequence animation of your model.

� Create a maintenance sequence, a short animation of steps to take to instruct a user in how to repair or build

a product.

For an introduction and overview of the Design Animation module, and for typical steps to take to create an

animation, see the Design Animation Concepts Guide online document.

To Define an Animation
You can create an animation to do many different things.  Depending on your objective, you may use different

steps to create your animation.

Following are the typical steps you might take to create an animation:

1. Open an assembly in Pro/ENGINEER.

2. Open Design Animation by clicking Applications > Animation.

The Design Animation toolbar and timeline appear.  An Animation menu is added to the Pro/ENGINEER

menu bar.  You can create your animation either by selecting commands from the Animation menu or by

clicking the toolbar buttons.

3. Create a new animation by clicking Animation > Animation or click  (Animation) on the Design

Animation toolbar.  The Animation dialog box opens with a default name for your animation.  Use the

Rename command to give your animation a meaningful name.

4. Check your body definitions:

� For a Pro/ENGINEER assembly, you probably want to select One Part per Body and then edit the

body to put the parts into the appropriate moving groups.

� One Part per Body will empty the ground body of parts. You should edit the body named ground and

reassign ground parts to it.

� For a Mechanism Design assembly, you should check that the body definitions are as desired.

5. Define animation components that create movement.

� To specify general movement, create key frame sequences.  To create key frame sequences, take

snapshots of your assembly at specific positions, using the drag functionality to move bodies to new

positions.  Design Animation will interpolate between these key frames to produce a smooth animation.

� To create specific movement between bodies connected by joints or between geometric entities, define

drivers on joints or geometric entities.

6. If not already on the timeline, include the drivers and key frame sequences on the timeline. Any

components included on the timeline form the basis for your animation.  You can edit the timeline length

and increments, the length of the driver or key frame sequence in the animation, and the relative timing of

all components in the timeline.

7. Optional: If you have not already included body locking, events, or connection status in the timeline, you

can add them now.

� If you want a group of bodies to be fixed relative to each other for a part of the animation, you may

want to set up body locking for that time period.

� Changing the connection status is useful for assembling and disassembling your model.  If you are
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working with key frame sequences, you can change the connection status on the Drag dialog box while

dragging bodies to position them in snapshots.  If you are working with drivers, you want to use the

Animation > Connection Status command.

� If you need to have animation components sequenced in a particular order, you can specify a system-

defined or user-defined event as a reference, or you can group them together in a subanimation.

8. Start your animation by clicking Animation > Start.

The Run dialog box opens.  The model moves as specified by the animation components in the timeline,

and the timeline shows the progress of the animation.

If you have problems, try one of the following:

� Make sure your mechanism is not overconstrained.  For example, check that a driver and key frame

sequence are not requiring conflicting positions.

� Increase the number of time steps (Utilities > Time domain).

9. If you want to view the animation again, or to change the speed or direction, click Animation > Playback.

If desired, you can check for interference and other results.

10. Define views along your animation to view orientations and magnification of your model.  You can also

choose an interpolation method for your views.

11. Specify component displays along the animation for your assembly components.

12. Rerun the animation and view results.

13. Save your animation and results.  You save your results using the Save button on the Results Playback

dialog box. Design Animation saves your playback results to a .pba file. You can also export to a .fra file

for use in Pro/FLY-THROUGH. Save your animation using the File > Save command.  Design Animation

saves your animation to the .asm file with your model.

Design Animation Toolbar Buttons
When you click Application > Animation, the Design Animation toolbar opens with a set of default buttons.

You can select which buttons appear on your toolbar by using the Utilities > Customize Screen command.  For

more information on this command, search for information on customizing screen commands in the Core area

of the PTC Help system.

Button Action/Name Comments

Control the display of icons on your

model.

The Display Entities Dialog Box opens.

Create a new animation. The Animate dialog box opens.

Define bodies in your assembly. The Body Definition dialog box opens.

Drag model and create snapshots. The Drag dialog box opens.

Create a key frame sequence. The Key Frame Sequence dialog box opens.

Create body–body locking. The Lock Bodies dialog box opens.

Create a driver. The Driver Editor dialog box opens.

Create a new view at time. The View @ Time dialog box opens.

Define component display at time. The Display @ Time dialog box opens.

Edit the selected entity in the timeline. A dialog box opens that corresponds to the

selected entity.

Undo.
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Redo.

Remove the selected entity from the

animation timeline.

Generate the animation. The Run dialog box opens and the animation

starts.

Play back the animation. The Animate dialog box opens.

Export the animation. The current animation is exported as a .fra

file.

Change the connection status. The Connection Status dialog box opens.

Create an event. The Event Definition dialog box opens.

Include a subanimation. The About Subanimations dialog box

opens.

Define the interpolation settings. The View Interpolation dialog box opens.

Zoom in on time scale. The time scale decreases to the selected size.

Click and drag a rectangle around the part of

the time scale you want to see.

Zoom out time scale. The time scale increases incrementally until

it reaches the original setting.

Zoom to refit time scale. The time scale returns to the original setting.

Change the animation time domain. The Animation Time Domain dialog box

opens.

Change the animation tolerance setting. The Assembly Setting dialog box opens.

You can set the tolerance level for the

assembly.

Animation Dialog Box
Use this dialog box to create a new animation, or to open or delete an existing animation.  When you click

Animation > Animation, or the Animation button, this dialog box opens.

This dialog box contains the following items:

� New—Create a new animation. Design Animation gives it a default name. You can now define the

components that make up your animation, including key frame sequences and drivers.

Warning:  This command clears the current animation from the timeline.  If you do not save your model

before selecting this command, you will lose your animation data.

� Open—Select an animation from the list.

� Delete—Remove the selected animation from the list.

� Rename—Rename an animation. Select one of the animations from the list.  Edit the name in the entry box.

Click Rename.  The new name appears in the list.

About Connection Status
If you created your assembly in Mechanism Design, use connection status to manage the connections defined

for your assembly.

When you click Animation > Connection Status, the Connection Status dialog box opens.  You can also

change the status of a connection within the Drag dialog box for use when you are taking snapshots to use in a
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key frame sequence.

Note: If you define a connection status using this dialog box, an icon will appear in the timeline.  This

connection status takes precedence over any defined in the Drag dialog box and included in a key frame

sequence.

After you select a connection, you need to specify the following:

� Time

� Value—Set the time value.  The connection state and locking status will take effect by the specified

amount of time after the selected event.

� After—Select the event after which you want the connection to take effect.

� State

� Enable—Enable the connection.  When you click Apply, a connection icon on the timeline will reflect

the connection status.

� Disable—Disable the connection. When you click Apply, a connection icon on the timeline will reflect

the connection status.

� Lock/Unlock

� Lock—Lock the connection.  This has the effect of gluing the two bodies together, allowing no

movement between the bodies.

� Unlock—Unlock the connection.  This is only available after you have locked the body.

� Reset — Reset the dialog box information to its original state.

To Define Connection Status
You can specify that any of your connections remain inactive, or become disabled, during a period of time in

the animation.  Use the Connection Status command command when you define motion using drivers rather

than key frame sequences.  Use this command, for example, to illustrate disassembly of your model, or to focus

on the movement of one connection at the expense of others.

1. Click Animation > Connection Status or click  (Create new connection status) on the toolbar.

The Connection Status dialog box opens.

2. Select a connection.

3. Enter a time and select a reference event from the After list.

The connection status begins after the reference event and entered time.  The time you enter can be negative

with respect to the selected event, but cannot occur before the start time of the animation.

4. Select State Enable or State Disable.

5. Select Unlock or Lock.

6. Click Apply.

The appropriate connection icon appears in the timeline.

Connection Icons
When you change the status of a connection, the timeline reflects the change with an icon.  Following are the

connection icons and what they represent:

Icon Connection Status

Disabled connection

Enabled, unlocked connection

Enabled, locked connection
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About Events
Use events to maintain an associative relationship between animation elements.

For example, if you tie one timeline component to start when another one ends, then if the end time of one

component in the animation changes, any subsequent elements that are defined to start after that end time are

shifted automatically.

Design Animation automatically creates events for the beginning and end of any animation component included

in the current animation.  In most cases, you will be able to use one of these system-defined events and not have

to create one yourself.

When you click Animation > Event, the Event Definition dialog box opens.  In this dialog box, you can do the

following:

� Name the event.

� Specify the time after your reference event that you want this event to start.

� Select a reference event.  Select the down arrow to display the list of available reference events.

The event you are creating will take place by the specified amount of time after the reference event.

When you create a new event, a symbol with the name of the event appears in the timeline.

When you define an animation element to start after an event, Design Animation defines a relationship between

the element and event and draws a dashed line between them.  To control the visibility of this dashed line, use

the View > Display Settings > Animation Display command.

To Define an Event
Use events as markers in the timeline to order the timing of animation components.  The default event, which

specifies the time at the beginning of the animation, is Start, and is always listed.  Use these steps to define

other events.

1. Click Animation > Event or click  (Create new event) on the toolbar.

The Event Definition dialog box opens.

2. Enter a name for the event in the Name entry box.

3. Enter a time and select a reference event from the After list.

The new event begins after the reference event and time. The time you enter can be negative with respect to

the selected event, but cannot occur before the start time of the animation.

4. Click OK.

An event symbol, with the name of the new event, appears in the animation timeline.  If the event is

referenced to an existing component in the timeline, a dotted line leads from the reference event to the new

event.

About Subanimations
Use the Subanimation command to include an animation created with your assembly or any of its

subassemblies in the current animation.  This included animation becomes a subanimation.  By default, a

subanimation references Ground.  If your subanimation moves relative to another body, you must reference the

other body.  You can specify the reference body through the Subanimation dialog box.

You should note the following points about subanimations:

� Make sure that the reference body is not part of the subanimation.  If the reference body movement is

defined in the subanimation, the animation may be erratic due to the conflicting body specifications.

� When inserting a key frame sequence in a subanimation, make sure that only the bodies you want to move

are defined with Desired (the default) or Required.  Any bodies defined with Unspecified will not move

with the reference body. You can change how the bodies are defined through the Key Frame Sequence

dialog box.
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� Only those bodies that are actively defined in a subanimation will move with reference to the specified

body.  As soon as a body is not specified, it will not move.  For example, a door that is opening on a moving

car will stop moving with the car if it is specified for only half of the animation.

When you click this command, a dialog box opens, listing the animations for the current assembly.  Select the

animation you want to include in the current animation and click Include. By default, the included animation

starts at time 0.0 in the current animation.

This subanimation will appear on the timeline with no details of its animation elements. To view details of the

subanimation, click + , which appears at the start of the subanimation in the timeline.

Subanimation Dialog Box
When you create a subanimation, it references Ground by default.  If you need to change the reference body, or

the timeframe for the subanimation, use the Subanimation dialog box.  You can access this dialog box by

selecting the subanimation in the timeline window and doing the following:

� Click Edit > Selected.

� Right-click on the subanimation in the timeline and click Edit from the pop-up menu.

� Click the Edit The Selected Animation Object button on the Design Animation toolbar.

You can choose from the following items:

� Reference Body—Select the new reference body.

� Start Time—Enter the relative time you want the animation to start after the event you select. The time you

enter can be negative with respect to the selected event, but cannot occur before the start time of the

animation.

� End Time—Displays how long the subanimation will run.  If you want to change the duration of a

subanimation, you must open that animation and edit its timeframe.

To Run the Animation
1. Click Animation > Start to start running the animation.  The Run dialog box opens.

2. If the animation runs into any problems, you can use the dialog box to specify how to proceed.  You can

use the following items:

� Failure Options

Pause—Click to pause the animation.  You can then choose to continue or cancel the animation.  If

you continue, Design Animation will skip to the next frame and try to continue.

Continue—Click to continue running.

� Graphical Feedback—Click to have the assembly move on the screen as it runs the animation.

3. After you run your animation, you can use Animation > Playback to view the results.

About Playback
After you run your animation (using Animation > Start), use the Playback command to review, save, remove,

or export the information.

Click Animation > Playback to display the Results Playback dialog box with these items:

� Result Set — Select the animation you want to play back.

� Description—View or update a description for your animation.

� Play—Play back the animation.  The Animate dialog box opens, enabling you to rewind, fast-forward, play,

and repeat the animation.  Design Animation plays the animation on the display screen and scrolls across the

timeline.  If you play an animation, then select another animation and click Play, Design Animation plays

the animation on the display screen but does not update or change the information in the timeline window.

� Save—Save the current animation results to disk with a .pba extension.  Each animation can save only one

file.
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� Restore—Restore animation results.  This option enables you to select a results file from disk.  You can

then select it from the Results Set scroll box and click Play to view the animation.  You can restore

animation results only for the current assembly.

� Remove—Remove the current animation results from the current session.

� Export—Export the animation playback to a .fra file.  You can use this file in Pro/FLY-THROUGH.

� Interference Mode

� No Interference—Will not check your assembly for interference.

� Quick Check—Do a low-level check for interference.  Automatically selects Stop Playback as an

option.

� Two Parts—Specify two parts for which to check the interference.  Design Animation highlights the

area on the model where interference occurs.

� Global Interference—Check for any kind of interference in the entire assembly. Design Animation

highlights the area on the model where interference occurs.

� Interference Options

� Include Quilts—Include surfaces as part of the interference check.

� Stop Playback—Stop the playback if any interference is detected.

� Movie Generation Schedule

To Play Back the Animation
Use the Playback command to change the rate or beginning frame of your animation easily. You can also set up

the animation to run in a continuous loop, or to reverse and run backwards.  This is a convenient way to control

your animation for a presentation.

You must run your animation at least once using the Animation > Start command before using the Playback

command.

1. Click Animation > Playback.

The Results Playback dialog box opens.

2. Select an animation from the Result Set list.

3. If you want to change the description, type your text in the entry box and click Update.

4. Select an Interference Mode.

5. Select an Option.

6. If you want to specify which portions of the results to view during playback, click Movie Generation

Schedule.

7. Click Play.

The Animate dialog box opens.

Movie Generation Schedule
When you play back the results of your animation, you can specify which portion of the run you would like to

view.  If you want to see the entire run, click Default on the Results Playback dialog box.

If you want to see a specific portion of the run, clear the Default check box.  You can now choose from the

following options:

� Start Time—Specify the start time of the segment you want to view.

� End Time—Specify the end time of the segment you want to view.

Note: If the start time is greater than the end time, the movie will run in reverse.

�  (Add a movie segment)—After you specify a start and end time, click this button to add the segment

to the list for playback.  You can replay this segment multiple times by adding it to the list multiple times.

�  (Update a movie segment)—To change the start or end time of a playback segment, highlight that

segment and click this button.  You can now update the start and end time.
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�  (Delete a movie segment)—To delete the movie segment, highlight that segment and click this button.

Animate Dialog Box
Use this dialog box to play back the results of your animation.  The dialog box contains the following items:

Button Function

Frame sliding bar List the frame that is currently displayed.

Play backwards.

Stop.

Play.

Reset the animation to the beginning.

Display the previous frame.

Display the next frame.

Advance the animation to the end.

Repeat the animation.

Reverse directions at ends.

Speed sliding bar Change the speed of the animation.

Capture Record the animation to JPEG or MPEG.

When you play back the animation, Design Animation plays the animation results on the display screen while

scrolling across the timeline window.

Capture Dialog Box
When you click Capture on the Animate dialog box, the Capture dialog box opens.  You can record your

animation as a series of JPEG files or an MPEG file, and use the recorded animation for your presentation.

Use the following items to record your animation:

� Output filename—Enter a name.  The file will be saved in the current working directory.  If you want to

select an existing file, click Browse and select a directory and file.

� MPEG or JPEG—Select the format you want.

� Photorender frame—Select this option if you want to use Pro/ENGINEER's PHOTORENDER to record

your animation.  Set the options for the photorendering before capturing the animation.  Use the

Pro/ENGINEER View > Advanced > Photorendering command.  For more information, search for

photorender in the Visualization area of the PTC Help system.

� Image size—Enter the width and height of the output file in pixels.

When you click OK, the animation begins and runs for 100 frames.  If you select JPEG, the program records

one file per frame.
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About Time Domain
Use the Time Domain command to create a timeframe for the current animation.

When you click Utilities > Time Domain, the Animation Time Domain dialog box opens.  You supply

different information for the dialog box, depending on which of the following you select for the time domain:

� Length and Rate—Enter the end time (in seconds) and the frame rate (the number of frames per second)

for the animation. The system calculates the total number of frames and the length of the run.

� Length and Frame Count—Enter the end time (in seconds) and total frame count for the animation. The

system calculates the frame rate and the length of the run.

� Rate and Frame Count—Enter the total frame count and the frame rate or interval of the animation. The

system calculates the end time.

After you select one of these time options, fill in the appropriate fields on the rest of the dialog box.

To Change the Time Domain
Follow these steps to alter the rate and duration of your animation.  You can use time domain factors to alter

your time scale, or to increase or decrease the smoothness of the interpolation between frames.

1. Click Utilities > Time Domain or click  (Animation time domain).

The Animation Time Domain dialog box opens with the name of your animation.

2. Select one of the methods to control the animation.  Change the duration to fit your animation.  To have a

smoother transition between key frames, you may want to increase your frame count.

3. If you want to change the timeline scale, deselect the Display Interval Default box, and enter a new value

for the interval.  When you click Apply, the timeline displays your changes.

Note: A smaller display interval results in more divisions on the timeline scale, and allows you to make

finer movements when using the mouse to move timeline elements.

Time Domain Rate and Frame Count
Use this method to control the number of frames and the interval between them in your animation.  Enter

information in any of these fields.  The default time unit is seconds.  Increase the frame count to make the

transition between frames smoother, or to see more details in the animation movement.

When you click Apply, the program updates other fields. Click OK to accept the values and exit the dialog box.

� Start Time—Enter the time you want the animation to start running.  The animation starts at the time you

enter, but the timeline does not display the new start time.

� Frame Count—Enter the total number of frames for the entire animation.  The program updates the end

time on the dialog box and on the timeline.

� Rate—Enter the rate in frames per second.  The program updates the frame interval and end time.

� Interval—Enter the interval between frames.  The program updates the end time and frame rate.  The

timeline displays the new duration.

Change either the frame rate or interval.  The frame count, interval, frame rate, start, and end times are related

by the following formulas:

Frame Rate = 1/Interval

Frames Used = [Frame Rate * (End Time – Start Time)] + 1

Note: The Frame Count value on the dialog box does not change if you increase the Start Time.  This is the

number of frames available for the entire animation, and is used to calculate the Frame Rate and Interval.

When you run or play back the animation, however, the number of frames is that determined by Frames Used.
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For example:

Start Time
0 5

End Time
10 10

Frame Count
101 101

Frames Used
101 51

Time Domain Length and Frame Count
Use this method to control the number of frames in your animation, and the length of the animation run.

Decrease the length if your animation is shorter than the default value.  Increase it to make room for more

components in the animation.  Increase the frame count to make the transition between key frames smoother, or

to see more details.

Enter information in any of these fields.  The default time unit is seconds.

When you click Apply, the program updates other fields. Click OK to accept the values and exit the dialog box.

� Start Time—Enter the time that you want the animation to start running.  The animation starts at the time

you enter, but the timeline does not display the new start time.

� End Time—Enter the time that the animation ends.  The timeline displays the new duration, and the

program updates the interval and frame rate in the dialog box.

� Frame Count—Enter the total number of frames for the animation.  The program updates the interval and

frame rate in the dialog box.

The frame count, interval, frame rate, start, and end times are related by the following formulas:

Frame Rate = 1/Interval

Frames Used = [Frame Rate * (End Time – Start Time)] + 1

Note: The Frame Count value on the dialog box does not change if you increase the Start Time.  This is the

number of frames available for the entire animation, and is used to calculate the Frame Rate and Interval.

When you run or play back the animation, however, the number of frames is that determined by Frames Used.

For example:

Start Time
0 5

End Time
10 10

Frame Count
101 101

Frames Used
101 51

Time Domain Length and Rate
Use this method to control the duration of your animation and the time between frames.  Enter information in

any of these fields.  The default time unit is seconds.  Decrease the duration if your animation is shorter than the

default value.  Increase it if your animation is greater than the default value, for example, to follow the

animation with a new component.  Decrease the frame rate to see more details in the animation.

When you click Apply, the program updates other fields.  Click OK to accept the values and exit the dialog

box.
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� Start Time—Enter the time that you want the animation to start running.  The animation starts at the time

you enter, but the timeline does not display the new start time.

� End Time—Enter the time that you want the animation to end.  The program updates the frame count.

� Rate—Enter a frame rate in frames per second. The program updates the interval and the frame count.

� Interval—Enter the interval between frames.  The program updates the frame count and rate.

Change either the frame rate or interval.  The start time, end time, frame count, interval, and frame rate are

related by the following formulas:

Frame Rate = 1/Interval

Frames Used = [Frame Rate * (End Time – Start Time)] + 1

Note:  The Frame Count value on the dialog box does not change if you increase the Start Time.  This is the

number of frames available for the entire animation, and is used to calculate the Frame Rate and Interval.

When you run or play back the animation, however, the number of frames is that determined by Frames Used.

For example:

Start Time
0 5

End Time
10 10

Frame Count
101 101

Frames Used
101 51

About View @ Time
Use the view-at-time functionality to view different orientations of your model at specific times. Used in

conjunction with the Utilities > Animation Interpolation command, you can view your animation smoothly

transitioning between different orientations during the animation.

When you click Animation > View @ Time, the View @ Time dialog box opens, listing the following items:

� Name—Select one of the named views.  You can create additional views using the Pro/ENGINEER View >

Saved Views command or the View > Orientation command.

� Value—Enter the time value you want this view to take effect after the named event.

� After—Select the event after which you want the view to take effect.

� Apply—Adds a view at the selected time with the given name.

Note:  The view saved is the one in the graphics window when you click Apply (including orientation and

zoom level).  This may not match the saved view in the name field if you have moved the model on the

screen.

To Define Views for an Animation
You can use views you have saved within Pro/ENGINEER to change the orientation of your model during the

animation.  For example, you can change the view from the front to the side while putting your assembly

together.

This procedure assumes you have previously saved views of your model using the Pro/ENGINEER View >

Saved Views command. For more information, search for views in the Core area of the PTC Help system.

1. Click Animation > View @ Time or click  (New view at time) on the toolbar.

The View @ Time dialog box opens with a list of previously created views.

2. Select a view.

3. Enter a time and select a reference event from the After list.  As the animation progresses, it will change to
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the view after the time and reference event.

Design Animation interpolates between views, so there are no abrupt changes.  The current settings for the

interpolation are listed in the dialog box.

4. If you want to change the current settings for view interpolation, see interpolation method.

5. Click Apply.  The View @ Time event appears in the timeline.

The view saved is the one in the graphics window when you click Apply, including orientation and zoom

level.  This may not match the saved view in the name field if you have moved the model on the screen.  An

event marker appears in the timeline.

View Interpolation
When you select Utilities > Animation Interpolation, the View Interpolation dialog box opens.  Use this

dialog box to specify how you want Design Animation to change between views you have specified using the

Animation > View @ Time command.  This dialog box contains the following items:

� Interpolate—Click to have Design Animation use your settings under Translation and Rotation when

transitioning between two views.  The assembly will move toward the next view during the animation.  If

you do not select this check box, Design Animation jumps to the next view without any transition.

Tip:  There may be times when you want Design Animation to stay on a view for a specific length of time

and then start moving toward another view.  Because you cannot select Interpolate for only part of the

animation, you will need to apply two instances of the same view, one at the beginning and one at the end of

a time period to make the view constant.  You can then apply a third view that Design Animation will

transition to.

� Translation—Select either Smooth or Linear Interpolation.

� Rotation—Select either Smooth or Linear Interpolation.

A linear interpolation changes linearly between views, retaining each view exactly as saved at a given time

point.

A smooth interpolation will vary according to a cubic spline fit between views, which results in a smoother

movement but may not use the exact views as defined at each time point.

To Define a Display for an Animation
This procedure assumes you have previously saved display states of your model using the Pro/ENGINEER

View > Model Setup > Component Display command. For more information, search for display status in the

Assembly area of the PTC Help system.

1. Click Animation > Display @ Time, or click  (Blanking-unblanking components at time) on the

toolbar.  The Component Display dialog box opens with the list of previously defined component displays.

2. Select a display.

3. Enter a value for the time, and select a reference event from the list.  As the animation progresses, it will

change to the display after the time and reference event.  Design Animation does not interpolate between

displays.

4. Click Apply.  The Display @ Time event appears in the timeline.

About Display @ Time
Use this command to control the display of your assembly components during an animation or playback.  You

can define an event during which some of the components are invisible, or in which the display modes, such as

Wireframe or Hidden Line, are different for different components.

You can create several Display @ Time events for your animation.  Only one event can be active at a given

time.  Design Animation moves from one Display @ Time event to another with no interpolation.

Use the View > Model Setup > Component Display command to define a display representation.  For more

information, search for information on display modes in the Assembly area of PTC Help system.
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When you click Animation > Display @ Time, a dialog box opens with the following items:

� Rep Name—Select the name of a component display from the list.

� Time

� Value—Define the starting time for the display event.

� After—Select the event after which the display representation will be active.  The list includes all

elements in your animation, including the start, end, and any user-defined events.

� Apply—Click Apply to add your Display @ Time event to the Design Animation timeline. Design

Animation will append an extension number to each instance of the event.

Editing the Animation
Use the following commands on the Edit menu to manipulate components of your animation.  You can also

access these commands from the buttons on the toolbar.

� Selected—Edit the component you have selected on your timeline. The appropriate dialog box opens.

� Undo—Undo the previous command in the animation timeline.  You can click Undo multiple times to take

you back to when you started the animation or last saved your model.

Note:  Editing a driver, key frame sequence, view at time, or snapshot cannot be undone.  You can undo

only modifications to instances in the animation timeline.

� Redo—Perform the previous command in the animation timeline that was undone.

� Remove—Remove the selected element from the timeline.

About the Animation Timeline
Use the timeline window to view and manipulate the items that make up your animation.  After defining

animation components, you must include them on the timeline in order for them to be part of the animation.

You can create or edit the elements using the commands on the Animation menu.  In addition, you can use

mouse shortcuts to edit all of the timeline's components.

You can display a list of commands related to a selected animation component by selecting the component and

clicking the right mouse button.

� If you select a key frame sequence instance, you can edit the instance's start and end time, edit the key frame

sequence, copy, or remove it.

� If you select a driver instance, you can edit the instance's start and end time, edit the driver, copy or remove

it.

� You can also select an event in the animation to reference a key frame or driver instance to.

� If you select a Display @ Time or View @ Time event, you can edit, copy, or remove it.  You can also

select another event in the animation to reference the event to.

� If you select a subanimation, you can edit, copy, or remove it.

For a new animation, the timeline is set by default to show 10 seconds, and the animation duration is set to 10

seconds.  You can change either or both of these default times.  To see more details of your animation, select

View >Timescale Zoom in, then draw a rectangular box around the area you want to view more closely.  To

change the animation duration, double-click on the time scale and change the animation time domain.

Following is an example of a timeline, with 3 key frame sequences, a body lock, an event, a connection status

change, and a subanimation, left to right respectively.
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Animation Timeline Shortcuts
You can use shortcuts on the timeline window to perform many of the commands in the Design Animation

toolbar and some additional ones.

Operation in Timeline Window Mouse Shortcut

Single select Click the left mouse button.

Multiple select Hold down CTRL and click the left mouse button.

Edit component time Select a component and double-click the left mouse

button.  You can also drag the component to the

desired time.

Edit time Hold down the left mouse button and drag.

Edit vertical position Select a component, hold down the middle mouse

button, and drag.

Undo previous operations Hold down SHIFT and click the left mouse button.

Redo previous undo operations Hold down SHIFT and click the middle mouse

button.

Access a pop-up menu for a selected timeline

component.

Select the component with the left mouse button,

then click the right mouse button.

Edit the animation time domain Double-click on the timeline.

Expand the display of subanimation information Click the circle at the beginning or end of a

subanimation

Display the component display at time Click the Display @ Time button.

Display the saved view at time Click the View @ Time button.

Changing the Timeline Display
Use the following commands on the View menu to change the visible scale on the timeline.

� Timescale Zoom in—Zoom in on the timeline to view details.  After you select this command, drag a

rectangular box around the timeline area you want to view more closely.

� Timescale Zoom out—Zoom out on the timeline.  Use this after you use Zoom In to incrementally see

more of your timeline.  Using this command repeatedly will return you to your original setting.

� Timescale Refit—Return the animation timeline to its original setting.

About Tolerance
The absolute assembly tolerance is the maximum amount that any mechanism position constraint can deviate

from a perfectly assembled state.  The absolute tolerance is calculated from the relative tolerance and the
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characteristic length.

The relative tolerance is the multiplier Design Animation uses to scale the characteristic length to derive the

absolute tolerance. The default value is 0.001, which represents 0.1% of the characteristic length of your model.

The characteristic length is the sum of all the part lengths divided by the number of parts. A part's length (or

size) is the length of the diagonal of the bounding box that contains the part completely.

The formula for absolute tolerance is:

absolute tolerance = relative tolerance � characteristic length

To Change the Tolerance Settings
You can change the absolute tolerance by changing the relative tolerance or the characteristic length, or both.

1. Click Utilities > Assembly Tolerance. The Animation Settings dialog box opens.

2. If you want to change the Relative Tolerance setting for your assembly, deselect the check box and enter a

value between 1e–10 and 0.1. The default value of 0.001 is usually satisfactory.

3. If you want to change the Characteristic Length setting, deselect the check box and enter a different

value. You should consider changing this setting when the largest part is much larger than the smallest part.

4. Deselect the Assembly Failure check box if you want Mechanism Design not to warn you should the

assembly fail.

5. Click OK.

About Icon Visibilities
You can use View > Display Settings > Animation Display to open the Display Entities dialog box. The

Display Entities data form has the following selections that you can toggle. The default is that all icons are

visible.

Drivers

Joints

Slots

Cams

LCS

Dependency

After you toggle a visibility off, that icon is still visible under the following conditions:

� Driver icons are visible when you open the Drivers dialog box.

� All joint icons are visible while Joint Axis is selected as a Driven Entity on the Driver Editor dialog box.

� All connection icons are visible while you are setting the connection status during dragging operation.

� The current local coordinate system (LCS) is visible during dragging operation. This LCS is used as a

reference for each component during dragging operation.

� Body LCS icons are visible while you are editing a body.

� The Dependency selection adds a dotted line on the timeline between an animation element, such as a

keyframe sequence, and an event that it references.

To Set Icon Visibilities
The following steps outline the process of turning the Mechanism Design icons on and off for viewing.
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1. Use View > Display Settings > Animation Display or click  (icon visibilities) to open the Display

Entities dialog box.

2. Toggle on the icons you want to be visible. Your choices are the following:

� Drivers

� Joints

� Slots

� Cams

� LCS

� Dependency

You can toggle off icon visibilities that have been toggled on previously.

About Drivers
You use drivers to impose a particular motion on your model.  Drivers behave like motors, by forcing a specific

type of motion to occur between two bodies in a single degree of freedom.  You can add a driver to a joint axis

or a geometric entity, such as part planes, datum planes, and points.

When you select the Animation > Driver command, the Drivers dialog box appears.  You can select from the

following items:

� Add—Create a driver. The Driver Editor dialog box appears.  After you create a driver, you need to

include it in your animation.

� Edit—Edit the selected driver.  The Driver Editor dialog box appears so you can change defined

information for your driver.

� Remove—Delete the selected driver.

� Copy—Make a copy of the selected driver.  The new driver is named copyofname, where name is the

selected driver's name.

You cannot copy an incomplete driver.

If a copied driver is used at the same time as the driver it was copied from, and the difference between the

two is not significant, the model may lock up during the animation due to conflicts between the drivers.

� Include—Include a copy of the selected driver in the animation.  Design Animation places the instance in

the timeline for the entire duration of the animation.  If you created drivers for your mechanism using

Mechanism Design, those drivers are available to include in the animation.  Each inclusion of a driver will

be named with a .n extension, where n is the next available number for the driver.

To Define a New Driver
To make your model move during the animation, you can add a driver to a joint axis or a geometric entity.

1. Select Animation > Driver or click on  (Create new driver) on the Animation toolbar.  The Drivers

dialog box appears.

2. Click Add.  The Driver Editor dialog box appears.

3. Enter a name for the driver.

The default name in the entry box is Driver#, where # represents a number that increments as drivers are

added.

4. Fill in the information on the tabs of the form.

� Entities

� Profile

For more information on these terms, search for drivers in the Assembly area of the PTC Help system.

5. If you want to see the profile of the driver with your current settings, click Graph.

You can then go back and change your data to change the profile.  When you see the profile you are

interested in, accept the driver, make sure it is included in the appropriate motion run, and run the motion

analysis.
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6. Click OK when you have completed the form.

The Drivers dialog box appears.  The driver and its status are now listed.  There are three possible status

conditions indicated.  If your driver is fine, the status column displays a blank.  If one or more of the entities

associated with the driver is suppressed, the status is Suppressed.  If one or more of the entities associated

with the driver has been deleted, the status is Incomplete.

Also, a driver icon, displaying the motion direction, appears on your mechanism.

After you create a driver, select Animation > Drivers to include it in your animation.

Driver Editor Dialog Box
You use drivers to impose a particular motion on your model.  Drivers behave like motors, by forcing a specific

type of motion to occur between two bodies.  You can add a driver to a joint axis or a geometric entity, such as

part planes, datum planes, and points.

After you select Add on the Drivers dialog box or click the Create A Driver button on the toolbar, the Driver

Editor dialog box appears.  This dialog box contains the following tabs:

� Entities—Select the entities that you want the driver to control.

� Profile—Select the profile of the driver.

To Specify the Entities for a Driver
This procedure assumes you are on the Entities tab of the Driver Editor dialog box.  Fill in the information on

this tab to define which entity is driven and which entity is the reference for the driver.

You can define as many drivers on an entity as you like.  However, to avoid overconstraining your model, do

not allow conflicting or redundant drivers to run simultaneously in your animation.  For example, if you create

both a joint axis rotation driver and a plane–plane rotation angle driver in the same direction, do not include

both of these drivers in the same time period in your animation.

1. Select either Translation or Rotation (in degrees) to determine the type of motion.  If you select an entity,

such as a joint type, which can have only rotational or translational freedom, the radio button may be

changed automatically if it is not set correctly.

Note: The positive rotation direction is assumed using the right-hand rule, with your thumb aligned with the

joint axis in the direction of the joint axis arrow.

2. From the Driven Entity drop-down menu, select one of the three entity types:

� Joint Axis

� Point

� Plane

Use a joint axis driver for well-defined motion in one direction.

If you select points or planes to define the driver, you are creating a geometric driver.

3. Select an entity from the model.  This entity will move when you activate the driver.

4. If you selected a point or plane as the driven entity, select a reference entity.  The driven entity will move

relative to the reference entity according to the driver profile.

Note: For drivers on a point or plane, the reference entity may also move if it is not on a locked body.  The

driver simply specifies the relative motion of the driven entity with respect to the reference entity.

5. If you selected a point as the reference entity, select a motion direction.  A magenta arrow appears, pointing

in the direction the driven entity will move relative to the reference entity.  You can use the Flip button to

change the direction.

Return to To Define a New Driver.

To Specify the Driver Profile
This procedure assumes you are on the Profile tab of the Driver Editor dialog box.  Use this tab to specify

your driver's motion.  The motion can be specified as a time-dependent change in position, velocity, or

acceleration.
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1. Select one of the following choices for Specification:

� Position—This type specifies the position of the selected entity.

� Velocity—If you select this type, you can select an initial position, which by default is set to Current.

You can deselect Current and type in another setting to change the initial position.  You can view your

new setting by clicking Show.

� Acceleration—If you select this type, you can select an initial position and an initial velocity, which by

default are set to Current and 0.0, respectively.

If you set an initial position for velocity or acceleration, Design Animation uses this initial position when

running the motion analysis.

2. If you want to specify a reference position for the driver, click Set Zero and fill in the reference portion of

the Joint Axis Settings dialog box.

3. Select one of the choices for Magnitude and fill in the appropriate fields.

4. If you want to view the profile for your driver with the current settings, click Graph.

Return to To Define a New Driver.

Driver Profiles
There are eight kinds of driver profiles.  Each type has its own input requirements.  The following table lists

each driver profile, its description, and its required settings.

Profile Type Description Required Settings

Constant Use if you want a constant motion. y = A

where

A = Constant for all time

Ramp Use if you want a constant motion or a motion

that changes linearly over time.

y = A + B*t

where

A = Constant

B = Slope

Cosine Use if you want to make the mechanism

oscillate.

y = A*cos(2*Pi*t/T + B) + C

where

A = Amplitude

T = Period

B = Phase

C = Offset

SCCA Use to simulate a cam profile output. See Driver Profile for SCCA.

Cycloidal Use to simulate a cam profile output. y = L*t/T – L*sin (2*Pi*t/T)/2*Pi

where

L = Total rise

T = Period

Parabolic Can be used to simulate a trajectory (graph

A=5, B=–1)

y = A*t + 1/2 B(t*t)

where

A = Linear coefficient

B = Quadratic coefficient

Polynomial Use for generic driver profiles. y = A +  B*t + C*t2 + D*t3

where

A = Constant term coefficient

B = Linear term coefficient
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C = Quadratic term coefficient

D = Cubic term coefficient

Table Use for more complex motion profiles that

you cannot specify with the other functions. If

you have output measure results to a table, you

can use that table here.

Name of Input file with tabular input in two-

column format. The first column contains

time, listed in ascending order, and the second

contains value of the Driver. An error is

generated if the driver value is not specified

for the entire time domain of the motion run.

See Driver Profile Table.

Use a single function if possible. But you can use a combination of functions to generate certain types of

motion. For example, a combination of ramp and cosine generates a sinusoidal motion that ramps up over time.

For more information on these options, search for information on drivers in the Assembly area of the PTC Help

system.

Ramp

SCCA

Constant

Parabolic

Cosine

Polynomial

Cycloidal
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Following are the values from the formulas that were used to generate the profiles in this graphic:

Constant Ramp Cosine SCCA Cycloidal Parabolic Polynomial

A = 8 A = 18 A = 6 0.4 L = 12 A = 4 A = –0.1

B = –1.2 B = 40 0.3 T = 8 B = –0.6 B = 1

C = 3 5 C = –1.5

T = 5 10 D = 7

Driver Profile for SCCA
This profile is only available for acceleration drivers.

The profile changes over the time period as follows:

q = H*sin[(t*�)/(2*A)] for 0 � t < A

q = H for A � t < (1 – C)

q = H*cos[(t + C – 1)*�/(2*C)] for (1 – C) � t < (C + 1)

q = –H for (C + 1) � t < (2 – A)

q = –H*cos[(t + A – 2)*�/(2*A)] for (2 – A) � t � 2

You must input values for A, B, H, and T (the program calculates a value for C).

A — Fraction of normalized time for increasing acceleration

B — Fraction of normalized time for constant acceleration

C — Fraction of normalized time for decreasing acceleration, where

A + B + C = 1

H — Amplitude of the profile

T — Period of the profile

t — Normalized time, where

 t = actual_time*2/T

The SCCA profile stops when actual_time = T.  If the actual time is longer than the period, the profile will

repeat itself.

Driver Profile Table
You can specify your own driver profile using a table file.  Table driver files enable you to specify a series of

time and magnitude settings for the driver.  The files have a .tab extension, and a two-column format.  The first

column contains time values, listed in ascending order, and the second column contains the value of the driver.

You can create and edit the table using any text editor.

Select Table on the Profile tab of the Driver Editor dialog box.  The following fields are available on this

form:

� File Name—Enter a file name or select Browse to search for one.  The data from the table appears in the

Time and Magnitude columns.  The table data is kept in the .asm file and the assembly no longer refers to

the .tab file for the information.

� Read Table—Select to update the Time and Magnitude columns from the .tab file.

� Write Table—Select to save the table information to the current working directory under the file name.
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� Linear Fit or Spline Fit—Select one of these interpolation methods:

� Linear fit will connect the table points with a straight line.

� Spline fit will fit a cubic spline to each set of points.  Using spline fit prevents sharp changes in the

motion of the driver quantity, yet can lead to correct but unexpected behavior.

For more information on these options, search for information on drivers in the Assembly area of the PTC Help

system.

Graph
You can graphically view the profile of a driver to see the motion your mechanism will take during the motion

run.

When you have entered data on the Driver Editor dialog box, you can click Graph to view the profile of the

motion for the current settings. You can then go back and change your data to change the profile. When you see

the profile you are interested in, accept the driver, make sure it is turned on, and run the motion analysis.

When you click Graph, a dialog box appears with graphing options. You can select from the following:

Graph Types

� Polyline—Connects the values with a straight line, capturing the essential information.

� Spline—Connects the values with a spline, allowing more flexibility and capturing all of the high and low

points.

Time Range

� Max/Min—Specifies the starting and ending values of the time range for graphing purposes.

� Step—Indicates how many increments Design Animation will take within the min/max range.

Measure Range

� Max/Min—Specifies the starting and ending values of the measure range for graphing purposes.

� Step—Indicates how many plot points Design Animation will use on the graph. Be sure to add enough plot

points to view an accurate profile.

Use the min/max ranges to change the scale of your graph.

When you click Default, the values on the form reset to their original settings.

To Include a Driver in the Animation
After you create or edit a driver, you must include it in your animation.

This procedure assumes that you have opened an assembly with existing drivers.

1. Click Animation > Driver.

The Drivers dialog box appears with a list of previously created drivers.

2. If you want to define a new driver, click Add.

3. Select a driver in the list.

4. Click Include.

The driver appears in the animation timeline.  The default start and end times are the start and end times of

the animation.  For information on changing these times, see Animation Timeline Shortcuts.

Driver Time Domain
When you select a driver on your timeline, right-click to bring up the pop-up menu, and select Edit Time, the

Driver Time Domain dialog box appears.

Use this dialog box to change the start and end times of your driver.  You can also drag the starting or ending

points on the timeline to change these times, but you cannot change events using drag.
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You can change the following items for the start and end of the driver:

� Time—Enter the time you want the driver to start or end after the selected event.  You can enter a time that

is negative with respect to the selected event.  However, the time cannot be negative with respect to the

animation time domain.

� After—Select the event after which you want the driver to start or end.

For example, if you want a driver to start 4 seconds after the start of the animation and end 2 seconds after

Driver1.1 ends, enter the following:

Start Driver

� Time: 4.00

� After: Start

End Driver

� Time: 2.00

� After: Driver1.1End

Geometric Drivers
If you select points or planes to define the driver, you are creating a geometric driver.  Use geometric drivers to

create complex 3D motions such as a helix.

If you select Point or Plane, you must also select a point or plane as a reference.

If you select a point for the reference entity, you must also select a motion direction.

You can create the following geometric drivers:

� plane-plane translation driver

� plane-plane rotation driver

� point-plane translation driver

� plane-point translation driver

� point-point translation driver

Plane–Plane Rotation Driver
A plane–plane rotation driver moves a plane in one body at an angle to a plane in another body.  During a

motion run, the driven plane rotates about a reference direction, with the zero position defined when the driven

and reference planes are coincident.

Because the axis of rotation on the driven body remains unspecified, a plane–plane rotation driver is less

restrictive than a driver on a pin joint or cylinder joint.  Thus, the axis of rotation in the driven body may change

as a function of time.

Note:  Plane–plane rotation drivers can be used to define rotations around a ball joint.  Another application of a

plane–plane rotation driver would be to define a rotation between the last body of an open-loop mechanism and

ground, such as a front loader.

Plane–Plane Translation Driver
A plane–plane translation driver moves a plane in one body with respect to a plane on another body, keeping

one plane parallel to the other.  The shortest distance between the two planes measures the position value of the

driver.  The zero position occurs when the driven and reference planes are coincident.

In addition to the prescribed motion, the driven plane is free to rotate or translate in the reference plane.  Thus, a

plane–plane driver is less restrictive than a driver on a slider or a cylinder joint.  If you want to explicitly tie

down the remaining degrees of freedom, specify additional constraints such as a connection or another

geometric driver.
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Note:  One application of a plane–plane translation driver is to define a translation between the last link of an

open-loop mechanism and Ground.

Plane–Point Translation Driver
A plane–point translation driver is the same as a point–plane translation driver, except that you define the

direction in which a plane will move relative to a point.  During a motion run, the driven plane moves in the

specified motion direction, while staying perpendicular to it.  The shortest distance from the point to the plane

measures the position value of the driver.  At a zero position, the point lies on the plane.

Note:  You cannot define the orientation of one body with respect to the other using only a plane–point driver.

Also note that the driven plane is free to move perpendicularly to the specified direction.  Lock these degrees of

freedom using another driver or connection.  By defining x, y, and z components of motion on a point with

respect to a plane, you can make a point follow a complex 3D curve.

Point–Plane Translation Driver
A point–plane translation driver moves a point in one body along the normal of a plane in another body.  The

shortest distance from the point to the plane measures the position value of the driver.

Note:  You cannot define the orientation of one body with respect to the other using only a point–plane driver.

Also note that the driven point is free to move parallel to the reference plane, and may thus move in a direction

unspecified by the driver.  Lock these degrees of freedom using another driver or connection.  By defining x, y,

and z components of motion on a point with respect to a plane, you can make a point follow a complex 3D

curve.

Point–Point Translation Driver
A point–point translation driver moves a point in one body in a direction specified in another body.  The

shortest distance measures the position of a driven point to a plane that contains the reference point and is

perpendicular to the motion direction.  The zero position of a point–point driver occurs when both the reference

and driven point lie in a plane whose normal is the motion direction.

Note:  The point–point translation driver is a very loose constraint that must be used carefully to get a

predictable motion.  You cannot define the orientation of one body with respect to the other using only one

point–point driver.  In reality, you would need six point–point drivers for this.

Also note that the driven point is free to move perpendicularly to the specified direction, and may do so if you

do not specify otherwise.  Lock these degrees of freedom using another driver or connection.  By defining x, y,

and z components of motion on a point with respect to a plane, you can make a point follow a complex 3D

curve.

About Joint Axis Settings
You can specify the relative orientation or location of the two parts connected by a joint axis.  A joint axis will

read zero when, for rotational joint axes, the zero reference lines on the two parts are aligned, or for

translational axes, the zero reference planes are aligned.  The zero reference line for each part lies in the plane

that is perpendicular to a rotational joint axis and passes through the joint point.  A zero reference plane is the

plane that is perpendicular to the translational joint axis and passes through the joint point.

A joint axis zero reference can only be set for a joint axis driver.  You cannot create more than one joint axis

zero on any joint.  Joint axis zeros are not required for any driver, but if they are not set, Design Animation

chooses an arbitrary reference on each body, with unpredictable results.

Joint axis zeros and joint axis range limits can be set for all joint types except a ball joint.

To Specify Joint Axis Settings
This procedure assumes you are in the Driver Editor dialog box in Design Animation.
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1. Select the Profile tab.

2. Click Set Zero.  The Joint Axis Settings dialog box appears.

3. Select a joint axis.  Design Animation highlights the selected axis and colors the two bodies attached to the

joint in cyan and green.  The cyan body is the component reference and the green body is the assembly

reference.

For rotational or translational joint axes, the dialog box displays in the Joint Axis Position field the current

angle or distance, respectively, between the two bodies.

4. If you want to use the current orientation of the mechanism as the zero reference position, clear the By

Reference check box and click Make Zero.  Design Animation resets the Joint Axis Position field to zero

and inactivates the reference portion of the dialog box.

5. If you want to select different reference locations on the bodies, select the By Reference check box and

complete the following steps:

a. For Component Reference, select a point or plane on the cyan body as the zero reference for that body.

b. For Assembly Reference, select a point or plane on the green body as the zero reference for that body.

6. If you want to set zeros at a specific offset from the current configuration, complete the following steps:

a. Clear the By Reference check box.

b. Click Make Zero.

c. Enter a value for angle or distance in the Joint Axis Position field.  For angles, you can enter any

number between –180 and 180.

d. Press ENTER.  The cyan body moves to show the configuration with the new position value.

e. Click Make Zero again to reset the Joint Axis Position field to zero.  The current configuration of the

bodies is now considered to be the zero reference configuration.

7. If you want to set a range limit on the joint axis, clear the By Reference check box and select the Limits

check box.

8. To specify limits for a rotational joint axis, enter a value for an angle between –180 and 180 degrees in a

counter-clockwise direction in each of the following fields:

� Minimum Angle

� Maximum Angle

The maximum angle should be greater than the minimum angle.

9. To specify limits for a translational joint axis, enter values in each of the following fields:

� Lower Translation Limit

� Upper Translation Limit

The upper translation limit should be greater than the lower translation limit.

10. Click OK.  The assembly appears in its original orientation.

11. If you want to check whether the limits you specified for the joint axis provide the range of movement you

expected, use the Drag dialog box and drag the cyan body.

Defining Joint Zero References
Be aware of the following when defining a rotational axis:

� Point–Point Zero Reference—Design Animation draws a vector from each of the two points in a direction

normal to the rotational axis. These two vectors should coincide for the joint zero. The points cannot lie on

the joint axis

� Point–Plane Zero Reference—The plane containing the point and the rotational joint axis should be

parallel to the selected plane for the joint zero. The point cannot lie on the joint axis.

� Plane–Plane Zero Reference—The two planes are parallel at the joint zero. Both planes must be parallel to

the axis of rotation.

Be aware of the following when defining a translational axis:

� Point–Point Zero Reference—The distance between the two points in the direction of the translation joint

axis will be zero at joint zero.
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� Point–Plane Zero Reference—The distance between the plane and the point in the direction of the

translation joint axis will be zero at joint zero. The plane must be perpendicular to the joint axis.

� Plane–Plane Zero Reference—The distance between the planes is zero at joint zero. Both planes must be

perpendicular to the joint axis.

Be aware of the following restrictions when defining zero references:

� Planar Connection—For planar connections, you can define point–point zero references only for planar

translation axes. Also, you can define plane–plane zero references only for planar rotation axes.

� Bearing Connection—You must select a point or plane on the body that contains the direction definition of

the bearing joint—in other words, the line in the point–line constraint.  Design Animation aligns this

reference to the point defining the bearing joint.

About Bodies
A body is made up of one or more parts that do not move relative to each other.  By default, bodies in Design

Animation are created following the Mechanism Design body rules—parts with a Pro/ENGINEER constraint

between them are placed in a single body.

Bodies defined in Design Animation will not transfer to Mechanism Design.

If you created your assembly without mechanism connections or packaging but simply with Pro/ENGINEER

constraints, you will want to redefine the model using One Part Per Body or Add.

Note:  If a body definition has been edited and saved in a subassembly, you cannot edit the body in a higher

level assembly.  You must edit the body in the subassembly, then save it.

If a subassembly body configuration has not been saved, you get the default body definition and you can edit it.

When you select Animation > Body Definition, the Bodies dialog box appears:

� Add—Create a new body and add parts to it.  The Body Definition dialog box opens.

� Edit—Edit a selected body.  The Body Definition dialog box appears, enabling you to add parts to your

body.  Any parts added to a body are removed from any other bodies that previously contained them. All

parts belong to the ground body if they were added to the assembly using Pro/ENGINEER constraints.

� Remove—Remove a selected body.  The parts contained in that body are moved to the ground body.

� One Part per Body—Create bodies using the one part per body rule.  Design Animation keeps connections

during this operation.

Note:  Use this with caution with large assemblies because every part in the assembly will become an

individual body.  You will also have to redefine Ground.

� Default Bodies—Revert to the bodies defined by Pro/ENGINEER constraints.  When you select this option,

the program carries out a Pro/ENGINEER regeneration.  Any body definitions created prior to selecting this

button will be ignored.  This gives you a chance to start over, creating bodies as when you first entered

Design Animation.

Note:  If you do not use default bodies in your animation, the Pro/ENGINEER regeneration may fail when

you leave Design Animation, or Pro/ENGINEER may place parts in a different location than they were

during your animation.

Body Definition Dialog Box
Use this dialog box to add parts to a new body.

You can select from the following choices on the Body Definition dialog box:

� Name—Name the new body.

� Add Parts—Select the parts you want to add to the new body.  Note that on the Get Select menu, there are

three extra commands available.  You can choose one of the following actions:

� Pick Many—Drag a rectangular box around all of the parts you want to select.

� Unselect Last—Repeatedly unselect the last part you selected.



Design Animation32

� Unselect Item—Remove a part from the body by picking it.

You can choose to add a subassembly to the body by selecting the subassembly on the model tree or using

Sel By Menu command on the Get Select menu.

The Number Of Parts display box incrementally updates as you add parts to the body.

To Create a Body
A body is a part or group of parts that do not move with respect to each other.  Use these steps to define which

part of your assembly will move independently during the animation.

1. Select Animation > Body Definition or click  (Body definition) on the toolbar.

The Bodies dialog box opens with a list of the bodies in the assembly.

2. Click Add.

The Body Definition dialog box opens.

3. Enter a Name for the new body.

4. Select parts to add to the body.

The Number Of Parts count is updated as bodies are added.

5. Click OK.

The Bodies dialog box opens with the new body included in the list.

About Lock Bodies
Lock bodies to fix bodies relative to one lead body over a specific time period during an animation.  The bodies

will act as if they are glued together, allowing no movement between them.  The body locking does not take

effect until the start time you define for the body lock event.  If you or the animation drags or moves your

mechanism into a different configuration before the body locking takes effect, you may have unexpected

results.

Note:  Body positions at each key frame are specified by a snapshot.  However, a locked body can override the

key frame position if that body is Unspecified or Desired in the key frame sequence definition.  If the body

lock ends before the key frame sequence, the snapshots then determine the body position.  This can result in

bodies jumping to a new position if they were marked as Desired.

When you click Animation > Lock Bodies, the Lock Bodies dialog box appears with the following items:

� Name—Design Animation supplies a default name.  Accept the default, or change to another name.

� Lead Body—Select a lead body, or select Ground.  This body dictates the relative position and orientation

of the follower bodies.

� Follower Bodies—Select the bodies you want locked to the lead body. The follower bodies will latch onto

the lead body in the configuration they happen to be in when the body lock takes effect and follow it in the

same relative orientation while the lead moves, until the end of the body lock.  They will then be allowed to

move on their own.

� Remove—Select a body and remove it from the locked configuration.

� Start Time

� Value—Set the time value.  The body locking will take effect by the specified amount of time after the

selected event.

� After—Select the event after which you want the body locking to start.

� End Time

� Value—Set the time value.  The body locking will turn off after the specified amount of time after the

selected event.

� After—Select the event after which you want the body locking to end.



Design Animation 33

To Lock Bodies
Use this command to keep one or more follower bodies stationary with respect to a lead body during a specific

time period in the animation.

1. Click Animation > Lock Bodies.

The Lock Bodies dialog box appears.

2. If you want to change the name of the Lock Bodies event, enter a new name.  The default name is

BodyLock#, where # represents a number that is incremented as events are added.

3. If you want to specify the Ground body as the lead body, click the middle mouse button.

4. If you want to specify one of the bodies in your assembly as the lead body, select the body.

5. Select the follower bodies.

The bodies are outlined in red.

6. Enter a Start Time in the Value entry box.

7. Select a reference event from the Start Time After list.

8. Enter an End Time in the Value entry box.

9. Select a reference event from the End Time After list.

10. Click Apply.

The locking event is added to the timeline.  If you want to change the start or end times, see Animation

Timeline Shortcuts.

Example: Reference Body
When creating a key frame sequence (kfs2), you may want one body to move as defined by another driver or

key frame sequence (kfs1), but other bodies to move as defined in kfs2.  An example is a window rolling down

on a car door that is opening.  The door is referenced in kfs2, although the car is Ground.  The window slides

down relative to the door in kfs2.  The car door body is Unspecified in kfs2.  The car door is Required or

Desired in kfs1 and is closing relative to the car (Ground).

About Key Frame Sequences
Use the Animation > Key Frame Sequence command to create a key frame sequence.  When you create a new

key frame sequence, Design Animation automatically includes it on the timeline.

A key frame sequence is made up of a series of snapshots of your assembly in a succession of positions and at

specific times.  Design Animation will interpolate between the snapshots to create a smooth animation.

You can include a key frame sequence in an animation multiple times in different locations.  A key frame

sequence included in an animation is called a key frame sequence instance.  When you edit a key frame

sequence, all instances of that sequence are updated.  If you want to make a change to a key frame sequence,

without changing the original sequence, make a copy of the original and edit the copy.  Then you can include an

instance of the copy in the timeline.

When you select this command, the Key Frame Sequence dialog box appears, from which you can select your

reference body, take snapshots, and arrange them into a sequence.

To Define a Key Frame Sequence
Every animation must have at least one driver or one key frame sequence in order to move bodies in the

animation.  To create a key frame sequence, follow these steps:

1. Select Animation > Key Frame Sequence.

The Key Frame Sequences dialog box opens.

2. Click Add.  The Key Frame Sequence dialog box opens.

3. Enter a name for the sequence.

The default name is KFS#, where # is a number that increments as you add sequences.

4. If you want to use a reference other than the Ground body, select a body on your assembly.
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5. Click  (Edit or create a snapshot) to create a new snapshot or select a snapshot from the list.

6. If you want to see your model in the selected snapshot, click  (Preview).

7. Enter a time for the snapshot and press ENTER.

If you want to change the initial snapshot in a sequence (time = 0), you must remove it before defining a

new snapshot with time = 0.  For any other snapshot time, you can simply select the snapshot and change

the time.

8. Click   (Add).

The snapshot is listed according to time.

9. Select linear or smooth as an interpolation method.

This specifies the way Design Animation combines the snapshots into an animation.

10. Click the Bodies tab to define how the bodies in your model are used in the key frame sequence.

Remember to include your sequence in an animation.

To Control Bodies in a Key Frame Sequence
This procedure assumes that you are in the Key Frame Sequence dialog box, and have filled out the Sequence

tab.  Use these steps to control how Design Animation moves the bodies in your model during the animation.  In

some cases, a key frame sequence and a driver may try to move a body in conflict with each other.  You can

change the body’s status to avoid the conflict.

1. Click the Bodies tab.

2. Select the reference body.

3. Select the bodies to be controlled by the key frame sequence.

4. Select Required, Desired, or Unspecified for each body.

The default status is Desired for all bodies.  The bodies defined as Required or Desired move relative to

the reference body during the animation.  The bodies defined as Unspecified may move in an unpredictable

way, if not controlled by another key frame sequence or by a driver.

5. Click OK to accept the key frame sequence definition.

The new key frame sequence appears in the timeline.

About Drag Operations
Use dragging to place bodies in position for a snapshot.  You can drag a point or body.  You can choose free-

form movement, or movement along a coordinate system axis.  Design Animation attempts to position the

selected entity as close as possible to the current cursor location.  When the desired orientation is reached, click

Snapshot to capture the current position and orientation of each body in the model.

If there are connections between the bodies in your models, you can choose to leave the connections active, or

to disconnect them during the drag operation.  You can also apply two types of temporary constraints to the

model—align and mate.  The constraints are in effect only during the dragging operation.

You can specify that one or more bodies remain stationary relative to ground during a dragging operation by

locking them.  You can also lock or disable a connection, so it does not move or is ignored, respectively.

Design Animation saves the body locking and connection status information with the snapshot, so if you edit a

snapshot those features will be active.

If you are creating a new key frame sequence or editing an existing key frame sequence, the snapshots you take

are automatically added to the key frame sequence.  However, if you click the Snapshot button on the toolbar to

create snapshots, Design Animation will not automatically add the snapshots to any key frame sequence in the

animation.

To Create a Snapshot
In order to create a key frame sequence, you take snapshots of your assembly in various positions and

configurations.  Design Animation interpolates between the snapshots to create a smooth animation.  Follow



Design Animation 35

these steps to create a snapshot:

1. Select the Animation > Snapshot command or click  (Drag model and create snapshots) on the toolbar.

The Drag dialog box appears.

2. If you want to apply constraints during your drag operation, select the Constraints tab.

3. Select the Snapshots tab.

4. Select a drag method.

� Point

� Body

� X,Y,Z translation — You can specify which coordinate system the translation takes place in by

clicking   (Select current coordinate system).

� X,Y,Z rotation — You can specify which coordinate system the rotation takes place in by clicking

 (Select current coordinate system).

5. When you are satisfied with the position of your model, click  (Take a snapshot) to record.

The snapshot is listed in the Drag dialog box with the default name Snapshot#, where # is a number

incremented as snapshots are added to the list.

After you create your snapshots, you need to include them in a key frame sequence.  When you create a key

frame sequence, the Key Frame Sequences dialog box will also list the new snapshot.

Note:  After you record a snapshot, click   (Display snapshot) and select the Constraints tab to review

the constraint settings for that snapshot.

6. Repeat this procedure to create all of the snapshots for your sequence.

Drag Dialog Box
Use this dialog box to move components of the assembly and take snapshots. You can also use this dialog box

to apply or remove constraints and to turn the constraints on and off.

You can choose from the following options:

Button Action/Name Function

Snapshot Click to take a picture of your mechanism. The

Snapshots list will update. The snapshot includes the

orientation, location, connection status, and body

locks that were defined at the time you took the

snapshot.

Previous configuration When you use the left mouse button to accept a

dragged configuration, the configuration is saved to a

buffer. This button acts as an undo command,

displaying the part positions as of the start of the last

drag sequence.

Next configuration Displays the next configuration in the buffer. This

button acts as a redo command.

Package move Displays the Move dialog box, allowing you to

perform a package move.

Design Animation does not honor drag constraints in

package move.

For more information, see the help for the Component

Assemble dialog box in the Assembly area of the PTC

Help system.

On the Snapshots tab:
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Point drag Select a point to drag. A circle is drawn on the part

around the location chosen and follows the cursor

movement in such a way as to maintain the

connectivity of connections and bodies, if any.

Body drag Select a body to drag. The body highlights and follows

the cursor movement in such a way as to maintain the

connectivity of connections and bodies, if any, and the

current orientation of the body with respect to the

assembly coordinate system.

X, Y, Z translation Select a body, then click one of these buttons. Your

selection reduces the movement of the body to the

selected direction of the current coordinate system for

drag operations. Translation in other directions, as

well as rotation of the body, is locked.

X, Y, Z rotation Select a body, then click one of these buttons. Your

selection reduces the movement of the body to

rotation about the x, y, or z axis of the current

coordinate system for drag operations.

Current coordinate system Select a coordinate system by choosing the body

whose default coordinate system is the one you want

to use. X, y, or z translation or rotation will be in this

direction.

Name You can rename a snapshot by highlighting it, typing

in a new name, and pressing ENTER.

If you enter a new name and press ENTER, Design

Animation automatically takes a snapshot of your

assembly and adds it to the snapshot list.

Show Display the selected snapshot.

Borrow part positions from other

snapshots

Display the Snapshot Construction dialog box, from

which you can select part positions from other

snapshots to use in a new snapshot.

Assembly state Makes the selected snapshots available as

Pro/ENGINEER explode states.

Copy Copy a list of selected constraints.  This allows you to

select only those constraints from one snapshot that

you want to use in another snapshot.

Paste Add the list of copied constraints to a new snapshot.

Update Change the name of the selected snapshot to that in

the Name entry box. Also, update the snapshot with

the current onscreen configuration.
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Delete Delete the selected snapshot from the list.

On the Constraints tab:

Align two entities Select points, lines, and planes to create a temporary

constraint to align the entities. This constraint is valid

only during the drag operation, but is associated to a

snapshot and is enforced when the snapshot is shown

or updated.

Mate two entities Select planes to create a temporary constraint to mate

them. This constraint is valid only during the drag

operation, but is associated to a snapshot and is

enforced when the snapshot is shown or updated.

Orient two surfaces Select planes to orient two surfaces at an angle or

parallel to each other.  You can use this in conjunction

with the Offset button.

Body–body locking Lock or unlock a body in its current position.  The

selected bodies will be locked relative to ground or

another selected body.

Enable/disable connections Select connections to temporarily disable from the

mechanism. This status is saved with the snapshot. If

you use this setting on the last snapshot in the list and

do not change the status later, the rest of the snapshots

will have the connection disabled.

Constraints View the list of constraints and their status.

Offset Enter the value for an offset if you are creating a mate

or align constraint.  If you are creating an orientation

constraint, you can enter a value for angle or distance.

Apply Re-apply the selected mate or align constraint to

regenerate a snapshot.

Use this option before dragging if your assembly has

slot or cam connections.

On/Off Change the status of a selected constraint. Select the

constraint whose status you want to change and click

this toggle button. The status will change from on to

off, as appropriate.

Delete Delete the selected constraints from the list.

New Drag Dialog Box
Use this dialog box to move components of the assembly and take snapshots.  You can also use this dialog box

to apply or remove constraints and to turn the constraints on and off.

You can choose from the following options:

Button Action/Name Function

Snapshot Click to take a picture of your

mechanism.  The Snapshots list

will update.  The snapshot

includes the orientation,

location, connection status, and

body locks that are defined at
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the time you took the snapshot.

Previous configuration When you use the left mouse

button to accept a

configuration, the

configuration is saved to a

buffer.  This button acts as an

undo command, displaying the

relative positions as of the start

of the last drag sequence.

Next configuration Displays the next configuration

in the buffer.  This acts as a

redo command.

Package move Displays the Move dialog box,

allowing you to previous

package move.

Design Animation does not

honor drag constraints in

package move.

On the Snapshots tab:

Point drag Select a point to drag.  A circle

is drawn on the part around the

location chosen and follows

the cursor movement in such a

way as to maintain the

connectivity of connections

and bodies, if any.

Body drag Select a body to drag.  The

body highlight and follows the

cursor movement in such a

way as to maintain the

connectivity of connections

and bodies, if any, and the

current orientation of the body

with respect to the assembly

coordinate system.

X, Y, Z translation Select a body, then click one of

these buttons.  Your selection

reduces the movement of the

body to the selected direction

of the current coordinate

system for drag operations.

Translation in other directions,

as well as rotation of the body,

is locked.

X, Y, Z rotation Select a body, then click one of

these buttons.  Your selection

reduces the movement of the

body to rotation about the x, y,

or z axis of the current

coordinate system for drag

operations.
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Current coordinate system Select a coordinate system by

choosing the body whose

default coordinate system is

the one you want to use.  X, Y,

or z translation or rotation will

be in this direction.

Name You can rename a snapshot by

highlighting it, typing in a new

name, and pressing ENTER.

If you enter a new name and

press ENTER, Design

Animation automatically takes

a snapshot of your assembly

and adds it to the snapshot list.

Show Display the selected snapshot.

Borrow part positions from other

snapshots

Display the snapshot

Construction dialog box, from

which you can select part

positions from other snapshots

to use in a new snapshot.

Assembly state Makes the selected snapshots

available as Pro/ENGINEER

explode states.

Copy Copy a list of selected

constraints.  This allows you to

select only those constraints

from on snapshot that you want

to sue in another snapshot.

Paste Add the list of copied

constraints to a new snapshot.

Update Change the name of the

selected snapshot to that in the

Name entry box.  Also, update

the snapshot with the current

onscreen configuration.

Delete Delete the selected snapshot

from the list.

On the Constraints tab:

Align two entities Select points, lines, and planes

to create a temporary

constraint to align the entities.

This constraint is valid only

during the drag operation, but

is associated to a snapshot and

is enforced when the snapshot

is shown or updated.

Mate two entities Select points, lines, and planes

to create a temporary

constraint to align the entities.

This constraint is valid only
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during the drag operation, but

is associated to a snapshot and

is enforced when the snapshot

is shown or updated.

Orient two surfaces Select planes to orient two

surfaces at an angle or parallel

to each other.  You can use this

in conjunction with the Offset

button.

Body-body locking Lock or unlock a body in its

current position.  The selected

bodies will be locked relative

to ground or another selected

body.

Enable/disable connections Select connections to

temporarily disable from the

mechanism.  This status is

saved with the snapshot.  If

you use this setting on the last

snapshot in the list and do not

change the status later, the rest

of the snapshots will have the

connection disabled.

Constraints View the list of constraints and

their status.

Offset Enter the value for an offset if

you are creating a mate or

align constraint.  If you are

creating an orientation

constraint, you can enter a

value for angle or distance.

Apply Re-apply the selected mate or

align constraint to regenerate a

snapshot.

Use this option before

dragging if your assembly has

slot or cam connections.

On/Off Change the status of a selected

constraint.  Select the

constraint whose status you

want to change and click this

toggle button.  The status will

change from on to off, as

appropriate.

Delete Delete the selected constraints

from the list.

Using Assembly States
You can use the Assembly State button on the Drag dialog box to make snapshots available as explode states

in Assembly and Detail.
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To make the snapshots available, select one or more snapshots, then click the Assembly States button.  The

Asm State column on the Drag dialog box displays "On" next to the snapshot's name, indicating it is available.

If you want to turn off the availability of a snapshot state later, you can highlight the snapshot and click

Assembly States to toggle the availability off.

These assembly states (snapshots) will be available in Assembly and Detail as explode states.

Note: The snapshot and the explode state are linked together.  If you change the snapshot, the explode state

changes.  When modifying or deleting a snapshot in which the explode state is in use, be aware of the

following:

� Any changes you make to the snapshot will be reflected in the explode state.

� Deleting the snapshot causes the exploded state to become unlinked.  The explode state is still available, but

is independent of any snapshot. If you then create a snapshot with the same name as the deleted snapshot,

the explode state associates itself with the new snapshot.

For more information about explode states, see the Explode State online help in the Assembly module.

To Use Snapshot Construction
Use the Snapshot Construction dialog box when you are creating a snapshot that can use the configuration of

some parts from other, previously saved snapshots.

For example, you may have a part that repeatedly performs the same motion.  If you do not want to drag the part

to its different positions for every snapshot, you can borrow its position from a previous snapshot using the

following procedure:

1. Select Animation > Snapshot or click  (Create snapshots and drag model) on the toolbar. The Drag

dialog box appears.

2. Select one of the snapshots in the list.

3. Click  (Borrow part positions from other snapshots). The Snapshot Construction dialog box opens.

4. In the Snapshots list, select the snapshot you want to borrow from. The configuration of parts from the

selected snapshot appears in the display window.

5. Select the parts whose configuration you want to borrow.

6. Click OK.  The model display returns to the original snapshot you selected.  The parts you selected in the

Snapshot Construction dialog box will be in the borrowed configuration.

7. If you want to return to the configuration of the snapshot you selected in step 4, click  (previous model

configuration).

8. If you want to repeat the configuration you undid in step 7, click  (next model configuration).

To Drag a Body
When you drag a body, its position onscreen will change but its orientation will remain fixed.  If the mechanism

requires the body to be reoriented in some way in conjunction with a change in position, then the body will not

move at all since the mechanism would not be able to be reassembled in the new position.  Should this happen,

try using point dragging instead.

1. Select Animation > Snapshot.  The Drag dialog box appears.

2. Click  (Body drag).

3. Select a body within the current model.

4. Move the cursor, and the selected body will follow the location of the cursor.

5. To complete the operation, click on one of the following mouse buttons:

� Left mouse button — to accept the current body positions and begin dragging another body.  Move the

cursor away from the dragged body before clicking.
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� Middle mouse button — to cancel the drag just performed

� Right mouse button — to terminate the drag operation, leaving the bodies where you have just dragged

them

To Define Constraints for a Drag Operation
This procedure assumes that you have selected the Constraints tab on the Drag dialog box.  You can specify

various kinds of constraints, and turn them on or off for a drag operation.

1. If you want to align two entities, click  (Align two entities).  You can align points, axes, edges, or

planes.

2. Select two entities on your model.  The constraint is added to the list with a name describing the entities

included in the constraint.

3. If you want to mate two planes or surfaces, click  (Mate two entities), and follow Step 2.

4. If you want to change the distance between the selected planes, enter a value in the Offset entry box and

press ENTER.

5. If you want to orient two planes, click  (Orient two surfaces) and follow Step 2.

6. If you do not want to orient the planes to be parallel, enter a value for the angle in degrees between the

planes in the Offset entry box.

7. If you want to fix one or more bodies relative to a lead body, see To Lock a Body Prior to the Dragging

Operation.

8. If you want to disable or enable a connection, see To Change Connection Status.

9. If you want to assemble your model using the applied constraints, click  (Assemble model).  Use this

option if your assembly has cams and slots.

10. If you want to toggle the on/off status of any constraints, select the constraint from the list and click 

(Turn constraints on/off).

Return to To Create a Snapshot.

To Lock a Body Prior to a Dragging Operation
Lock bodies to fix bodies relative to a lead body. The reference may be one of the bodies in your assembly or

Ground.  The bodies do not need to be touching or adjacent to be locked together.

The bodies will act as if they are glued together, allowing no movement between them.  In many cases, body

locking can improve the dragging performance.

This procedure assumes you have selected the Constraints tab on the Drag dialog box.

1. Click  (Lock/Unlock Bodies).

2. Specify a reference body by doing one of the following:

� If you want to specify one of the bodies on your assembly as the reference, use the left mouse button to

select the body.

� If you want to specify Ground as the reference body, click the middle mouse button.

3. Select the bodies to be locked during the dragging operation.  Design Animation highlights each body as it

is selected.  Unselect any bodies you do not want to be locked if they are highlighted. These bodies will stay

fixed relative to the reference body.

Note: Selecting Close from the Drag dialog box without taking a snapshot will remove all locks.  When

you begin a new dragging session, no bodies will be locked.

4. If you want to turn off a body lock constraint, select it from the Constraint list and click  (On/Off).

Note: You cannot edit a body lock constraint.  You must delete the existing constraint and define a new one.

To delete a constraint, select it from the Constraint list and click  (Delete).
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Return to To Define Constraints for a Drag Operation.

To Change Connection Status for a Snapshot
This procedure assumes you are on the Constraints tab of the Drag dialog box.  Disable connections if you

want to move apart connected parts during a drag operation, for example to simulate assembling and

disassembling your model.  Be aware that the connections will remain disabled in subsequent snapshots.

1. Click  (Enable/disable connections).

2. Select the connections you want to enable or disable during the dragging operation.  Design Animation

highlights each connection as it is selected.  Unselect any connections you do not want to disable.

3. If you want to turn off a connection status for a snapshot, select it from the Constraint list and click 

(On/Off).

Note: You cannot edit a connection status constraint.  You must delete the existing constraint and define a

new one.  To delete a constraint, select it from the Constraint list and click  (Delete).

Return to To Define Constraints for a Drag Operation.

To Drag with a Selected Coordinate System
You can drag a body along the axes of one of the coordinate systems in your assembly.  This method gives you

more control over the dragging operation.  This is useful, for example, if you want to disassemble a model and

reverse the procedure to simulate putting it together.  This procedure assumes you are in the Drag dialog box.

1. Click  (Select current coordinate system).

2. Select the body and its associated coordinate system to move.

3. If you want to translate the body along one of the axes of the coordinate system of the selected body, click

the following buttons:

�  (Translate along X axis)

�  (Translate along Y axis)

�  (Translate along Z axis)

4. If you want to rotate the body around one of the axes of the coordinate system of the selected body, click the

following buttons:

�  (Rotate around X axis)

�  (Rotate around Y axis)

�  (Rotate around Z axis)

5. Select the body on your model that you want to move.

6. Move the cursor, and the selected body will follow the location of the cursor.

7. To complete the operation, click on one of the following mouse buttons:

� Left mouse button — to accept the current body positions and begin dragging another body.  Move the

cursor away from the body you are dragging before clicking the button.

� Middle mouse button — to cancel the drag just performed

� Right mouse button — to terminate the drag operation, leaving the bodies where you have just dragged

them

To Drag a Point
1. Select Animation > Snapshot.  The Drag dialog box opens.
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2. Click  (Point drag).

3. Select a location on a body within the current model.  The body will highlight as you move your cursor over

it.

4. Click the left mouse button on this location, and a circle will appear.  This is the exact location on the body

that you will drag.

5. Move the cursor, and the selected point will follow the location of the cursor.

6. To complete the operation, click on one of the following mouse buttons:

� Left mouse button — to accept the current body positions and begin dragging another body.  Move the

cursor away from the body you are dragging before you click.

� Middle mouse button — to cancel the drag just performed

� Right mouse button — to terminate the drag operation, leaving the bodies where you have just dragged

them

Note: You cannot select Ground or locked bodies for point dragging.

To Edit a Snapshot
This procedure assumes you are in the Drag dialog box, which lists previously created snapshots.

1. Select a snapshot from the list.

2. Click  (Display snapshot) to review the selected snapshot. The configuration depicted in that snapshot

appears in the model window. You can also double-click the name of the snapshot in the list of open the

snapshot.

3. If you want to rename the snapshot, enter the new name in the Name entry box and click  (Update).

4. If you want to update the positions of the bodies, drag the bodies to the new locations and click 

(Update).

5. If you want to delete the selected snapshot, click  (Delete).

Key Frame Sequence Finder Form
When you select Animation > Key Frame Sequence, the Key Frame Sequences dialog box opens.  You can

select from the following choices:

� Add—Create a new key frame sequence.  The Key Frame Sequence dialog box opens.

� Edit—Edit the selected key frame sequence.  The Key Frame Sequence dialog box opens.  You can

change the reference body, the status of the individual bodies included in the sequence, and the order or the

timing of the snapshots included in the sequence.  Any changes you make to a key frame sequence affect all

instances of that sequence used in the current animation.

� Delete—Delete the selected key frame sequence.  If you want to remove an instance from the animation

without deleting the master sequence, select the instance from the timeline and click the Remove button on

the toolbar.

� Copy—Make a copy of the selected key frame sequence.  The new key frame sequence is named

copyofname, where name is the name of the selected key frame sequence. For example, if your key frame

sequence is named open, the copy is called copyofopen.

� Include—Include a copy of the selected key frame sequence in the animation.  You can have multiple

occurrences of a key frame sequence in an animation at different times.  A key frame sequence included in

an animation is called a key frame sequence instance.  Each inclusion of a key frame sequence will be

named with a .n extension, where n is the next available number for that key frame sequence.  For example,

if you include open2 in the animation, it will be called open2.1.

Key Frame Sequence Dialog Box
Use this dialog box to create or edit a key frame sequence.  You can add or remove key frames, change the
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times and locations of bodies in snapshots, and change the reference body and body status for the entire

sequence.

This dialog box contains the following items:

� Reference Body—Select the Reference Body arrow, then a body on your assembly.  All bodies whose

status is desired or required in the sequence (specified under the Bodies tab) will be located relative to this

body.  When the reference body moves, the other bodies will move relative to it as specified by the key

frame locations.

By default, the reference body is Ground.  Most key frame sequences should keep Ground as the reference

body.  You may want to change the reference body from Ground if the reference body will be used in two

places.  Click See Also for an example.

� Sequence—Create the sequence by selecting or creating the snapshots to include.  You can also preview the

snapshot and change the time of the snapshot in the sequence.

� Bodies—Specify the status of the location of the bodies that are included in the key frame sequence.

� Regenerate—Select to regenerate the key frame sequence.  If you changed any constraints on parts that are

included in a key frame sequence, you should regenerate the sequence so Design Animation can update

locations based on these changes.

Bodies Tab
Use this tab to specify the status of the location of the bodies that are included in the key frame sequence.

The status is valid for the entire sequence.  You can change the status individually or for multiple bodies all at

once.  Select multiple bodies with CTRL and the left mouse button

Use this status to tell Design Animation how important the key frame sequence's control of the body is.  For

example, if there is a conflict between where a driver wants to place a body and where a key frame sequence

wants the same body, the driver has precedence if the body's status is Desired.

Following are the options on this tab:

� Unspecified—The body's position is arbitrary and may be controlled by other drivers or key frame

sequences.

� Desired/Required—Design Animation will keep the body as close to this position as possible, but it may

move based on the movement of any driver or other key frame sequence.

When you run your animation, if the bodies do not move to the correct position, especially at key frames, you

should try using Desired.

Sequence Tab
Use this tab to build the sequence of key frames that defines your animation.

This tab contains the following items:

Item Function

Opens the Drag dialog box so you can edit or create a snapshot.

Time Enables you to edit the time of a key frame in a sequence.  Time "0" for the first key

frame is relative to the beginning of the key frame sequence, not for the time in the

timeline.  Press ENTER to update the time of the highlighted key frame.

Displays the selected key frame.

Adds the selected key frame to the sequence in chronological order.

Reverse Reverses the time sequence of all frames in the sequence.  Design Animation mirrors
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the time values for each frame.  This is useful for creating an assembly sequence by

first starting with the assembled model, and creating a sequence showing its

disassembly.  If you reverse this sequence it will simulate assembling the model.

Remove Removes the selected key frame(s) from the sequence.

Interpolation Sets either a linear or smooth interpolation for translation and rotation.

� A linear interpolation varies body position and orientation linearly between key

frames, exactly following your assembly's placement at each key frame.

� A smooth interpolation will vary according to a cubic spline fit between key

frames, which results in a smoother movement, but may not have the exact

placement of each body position as defined key frame to key frame.

KFS Instance
When you select a key frame sequence instance on the timeline, right-click to bring up the pop-up menu, and

select Edit Time, the KFS Instance dialog box appears.

Use this dialog box to change the start time of your key frame sequence instance. You can also drag the starting

point on the timeline to change this time, but you cannot change events using drag.

You can select the following items for the start time:

� Time—Enter the time you want the instance to start after the selected event.

� After—Select the event after which you want the instance to start.

For example, if you want Kfs2.2 to start 3 seconds after the end of Kfs1.1, enter the following:

� Time: 3.00

� After: Kfs1.1End
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