Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Teamcenter
  Fehlermeldung beim Import

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Fehlermeldung beim Import (321 mal gelesen)
felixheimrich
Mitglied
wissenschaftlicher Mitarbeiter


Sehen Sie sich das Profil von felixheimrich an!   Senden Sie eine Private Message an felixheimrich  Schreiben Sie einen Gästebucheintrag für felixheimrich

Beiträge: 49
Registriert: 25.07.2011

Teamcenter 11

erstellt am: 20. Feb. 2017 17:53    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Liebe CAD-Gemeinde,

ich versuche gerade verschiedene Bauteile über tcin_import zu importieren.
C:\UGS\NX110\UGMANAGER>tcin_import.exe -u=uebung_et -p=**** -g=CAD_Admin_Accounts -p=C:\Parts\BtMappingTest.prt -mapping=C:\Parts\mapping.txt -dryrun
Dabei ensteht leider die Fehlermeldung: Error: Need to have NX running in Teamcenter Integration mode.

Öffne ich NX aus Teamcenter heraus und führe dort einen Import durch, funktioniert alles tadellos.
Habt ihr eine Idee, an welcher Stelle ich einen Fehler mache?

PS: Ich habe auch schon den Import über ug_import (was bei TC10 noch funktioniert hat) versucht, doch wird dann darauf hingewiesen, dass dieser Befehl veraltet ist und tcin_import verwendet werden soll.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Big King
Mitglied
NX/Tc Admin


Sehen Sie sich das Profil von Big King an!   Senden Sie eine Private Message an Big King  Schreiben Sie einen Gästebucheintrag für Big King

Beiträge: 1011
Registriert: 06.12.2010

TC10.1.6.1
(Testing .....)
NX10.0.3 MP8
(Testing NX11.1.0 MP-)
BCT 16.1
(Testing 16.1.9 Products & Inspector)
(Testing 17.0.0 Products & Inspector)
Win7 Enterprice
HP Workstation z620
Intel Xeon E5-1620v2 3.7GHz 10M 1866 4C CPU
NVIDA Quatro 4000 3GB
32GB DDR3-1866 RAM
Samsung Enterprise 240GB SSD

erstellt am: 21. Feb. 2017 07:32    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für felixheimrich 10 Unities + Antwort hilfreich

Hast du deine Varibaeln im Script gesetzt?

SET TC_ROOT=c:\...\tc101

SET TC_DATA=\\share\...


Edit: siehe auch http://ww3.cad.de/foren/ubb/Forum4/HTML/013929.shtml

------------------
“Vision without action is a daydream. Action without vision is a nightmare.”

[Diese Nachricht wurde von Big King am 21. Feb. 2017 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

felixheimrich
Mitglied
wissenschaftlicher Mitarbeiter


Sehen Sie sich das Profil von felixheimrich an!   Senden Sie eine Private Message an felixheimrich  Schreiben Sie einen Gästebucheintrag für felixheimrich

Beiträge: 49
Registriert: 25.07.2011

Teamcenter 11

erstellt am: 21. Feb. 2017 08:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Ja, die Variablen sind gesetzt. Das ist ja was mich stutzig macht.

SET TC_ROOT=C:\...\Teamcenter11
SET TC_DATA=C:\...\tcdata_ss17
SET FMS_HOME=C:\...\tccs
C:\ugs\Teamcenter11\tc_menu>C:\ugs\tcdata_ss17\tc_profilevars

[Diese Nachricht wurde von felixheimrich am 21. Feb. 2017 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Big King
Mitglied
NX/Tc Admin


Sehen Sie sich das Profil von Big King an!   Senden Sie eine Private Message an Big King  Schreiben Sie einen Gästebucheintrag für Big King

Beiträge: 1011
Registriert: 06.12.2010

TC10.1.6.1
(Testing .....)
NX10.0.3 MP8
(Testing NX11.1.0 MP-)
BCT 16.1
(Testing 16.1.9 Products & Inspector)
(Testing 17.0.0 Products & Inspector)
Win7 Enterprice
HP Workstation z620
Intel Xeon E5-1620v2 3.7GHz 10M 1866 4C CPU
NVIDA Quatro 4000 3GB
32GB DDR3-1866 RAM
Samsung Enterprise 240GB SSD

erstellt am: 21. Feb. 2017 17:55    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für felixheimrich 10 Unities + Antwort hilfreich

siehe http://ww3.cad.de/foren/ubb/Forum4/HTML/013929.shtml

dort habe ich bereits alles beschrieben....

------------------
“Vision without action is a daydream. Action without vision is a nightmare.”

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

georgstaudter
Mitglied


Sehen Sie sich das Profil von georgstaudter an!   Senden Sie eine Private Message an georgstaudter  Schreiben Sie einen Gästebucheintrag für georgstaudter

Beiträge: 3
Registriert: 22.02.2017

Teamcenter11
NX11

erstellt am: 22. Feb. 2017 13:18    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für felixheimrich 10 Unities + Antwort hilfreich

Ich habe bisher den Account meines Kollegen genutzt, mich jetzt aber registriert und möchte den Forumsbeitrag gerne unter meinem Namen fortführen   

@Big King: Vielen Dank für den guten Tipp..hat mir schon mal sehr weitergeholfen. Die Fehlermeldung " Need to have NX running in Teamcenter Integration mode" erscheint nun nicht mehr und der Importvorgang startet wie gewünscht. Die Umgebungsvariablen sollten nun also passen.
 
Allerdings bricht der Import dann ab: "Invalid log file provided for import". Irgendwas muss also mit dem log file nicht stimmen.

Ich starte tcin_import.exe mit folgender Syntax:
tcin_import -u=uebung_et -p=**** -g=CAD_Admin_Accounts -p=C:\Parts\BtMappingTest.prt -l=C:\Parts\mapping.txt -dryrun
Laut der Hilfe gibt man unter -l[oad_log_file] den Namen des "ug_import mapping files" an.

Diese habe ich mit Mapping_Filer.class erstellt und die txt enthält folgenden Inhalt:

[Defaults]
existing_data=$USE_EXISTING
import_folder="MappingTest"
[BtMappingTest.prt]
db_part_no = 100001
db_part_name = "BtMappingTest"
db_part_rev=A

[Diese Nachricht wurde von georgstaudter am 22. Feb. 2017 editiert.]

[Diese Nachricht wurde von georgstaudter am 22. Feb. 2017 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Big King
Mitglied
NX/Tc Admin


Sehen Sie sich das Profil von Big King an!   Senden Sie eine Private Message an Big King  Schreiben Sie einen Gästebucheintrag für Big King

Beiträge: 1011
Registriert: 06.12.2010

TC10.1.6.1
(Testing .....)
NX10.0.3 MP8
(Testing NX11.1.0 MP-)
BCT 16.1
(Testing 16.1.9 Products & Inspector)
(Testing 17.0.0 Products & Inspector)
Win7 Enterprice
HP Workstation z620
Intel Xeon E5-1620v2 3.7GHz 10M 1866 4C CPU
NVIDA Quatro 4000 3GB
32GB DDR3-1866 RAM
Samsung Enterprise 240GB SSD

erstellt am: 22. Feb. 2017 13:51    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für felixheimrich 10 Unities + Antwort hilfreich


gib doch das Logfile so an :

Code:
>c:\temp\import_%jahr%-%monat%-%tag%-%mytime%.log

-u=uebung_et -p=**** -g=CAD_Admin_Accounts

ich füre den Import mit dem -u=infodba -p=xxx -g=dba
aus

bitte so probieren....

------------------
“Vision without action is a daydream. Action without vision is a nightmare.”

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

georgstaudter
Mitglied


Sehen Sie sich das Profil von georgstaudter an!   Senden Sie eine Private Message an georgstaudter  Schreiben Sie einen Gästebucheintrag für georgstaudter

Beiträge: 3
Registriert: 22.02.2017

Teamcenter11
NX11

erstellt am: 22. Feb. 2017 15:31    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für felixheimrich 10 Unities + Antwort hilfreich

Ok super, der import bzw dryrun läuft durch. Vielen Dank!

tcin_import -u=uebung_et -p=**** -g=CAD_Admin_Accounts -p=CAD_Admin_Accounts>C:\temp\import_%jahr%-%monat%-%tag%-%mytime%.log -dir=C:\Parts -dryrun

Die Sache ist nur, dass ich Baugruppen mit sehr vielen Bauteilen importieren und jedem Bauteil bzw. Unterbaugruppe eine eigene definierte db_part_no, den db_part_name und die db_part_rev zuweisen sowie den Import-Zielordner in TC definieren muss.

Bei früheren TC Versionen, bei denen ug_import noch funktionierte, habe ich dazu eine mapping.txt benutzt.
ug_import -u=uebung_et p=**** -g=CAD_Admin_Accounts -p=C:\...\name.prt -mapping=C\...\mapping.txt

In eben dieser .txt waren folgende Infos hinterlegt:

[Defaults]
existing_data=$USE_EXISTING
import_folder="...."
[NameBaugruppe.prt]
db_part_no = 100001
db_part_name = "NameBaugruppe"
db_part_rev=A
[NameBauteil1.prt]
db_part_no = 100002
db_part_name = "NameBauteil1"
db_part_rev=A
USW...

Diese Datei habe ich über MappingFiler.class erstellt, der ich den Ordner mit den Parts, die Soll-Item-Nummer des ersten Items der Baugruppe (hier 100001) und den TC-Import-Zielordner übergeben habe. Hierdurch wurde die mapping.txt erstellt, in der die Item-IDs fortlaufend mit +1 nummeriert waren.

Habt ihr eine Idee wie ich dies auch mit tcin_import realisieren kann? 

[Diese Nachricht wurde von georgstaudter am 22. Feb. 2017 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Big King
Mitglied
NX/Tc Admin


Sehen Sie sich das Profil von Big King an!   Senden Sie eine Private Message an Big King  Schreiben Sie einen Gästebucheintrag für Big King

Beiträge: 1011
Registriert: 06.12.2010

TC10.1.6.1
(Testing .....)
NX10.0.3 MP8
(Testing NX11.1.0 MP-)
BCT 16.1
(Testing 16.1.9 Products & Inspector)
(Testing 17.0.0 Products & Inspector)
Win7 Enterprice
HP Workstation z620
Intel Xeon E5-1620v2 3.7GHz 10M 1866 4C CPU
NVIDA Quatro 4000 3GB
32GB DDR3-1866 RAM
Samsung Enterprise 240GB SSD

erstellt am: 22. Feb. 2017 18:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für felixheimrich 10 Unities + Antwort hilfreich


ist anscheinend zu viel verlangt in der NX Hilfe zu schauen ?

https://docs.plm.automation.siemens.com/tdoc/nx/10.0.3/nx_help/#uid:xid907082


Zitat:
–default_n[aming]

Legt fest, wie importierte Teile benannt werden. Mögliche Werte:

•automatisch erzeugen
•automatisch umsetzen
•os_filename
•Attribut

Der Standardwert ist autogen.



alles super beschrieben.

Danke vorab für die unities

------------------
“Vision without action is a daydream. Action without vision is a nightmare.”

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

georgstaudter
Mitglied


Sehen Sie sich das Profil von georgstaudter an!   Senden Sie eine Private Message an georgstaudter  Schreiben Sie einen Gästebucheintrag für georgstaudter

Beiträge: 3
Registriert: 22.02.2017

Teamcenter11
NX11

erstellt am: 23. Feb. 2017 09:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für felixheimrich 10 Unities + Antwort hilfreich

Vielen Dank für die Hilfe @Big King

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2017 CAD.de