Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  PTC Creo Allgemein
  Anpassung Menüleist

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
  
Gut zu wissen: Hilfreiche Tipps und Tricks aus der Praxis prägnant, und auf den Punkt gebracht für PTC CREO
Autor Thema:   Anpassung Menüleist (7907 mal gelesen)
hhr
Mitglied


Sehen Sie sich das Profil von hhr an!   Senden Sie eine Private Message an hhr  Schreiben Sie einen Gästebucheintrag für hhr

Beiträge: 9
Registriert: 06.11.2012

Software: Creo 2.0 mit StartUpTools 2013
Hardware: Fujitsu Celsius M720 - 16GB RAM, ATI FirePro v7900, SpaceExplorer USB von 3dconnexion

erstellt am: 23. Nov. 2012 16:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

ich habe ein paar eigene Mapkeys in die Schnellstartleiste
aufgenommen. Dann die Menüleiste über

Datei->Optionen->Symbolleiste für Schnellzugriff->Import/Export

als creo_parametric_cutomization.ui gespeichert und damit die
creo_parametric_admin_customization.ui in <loadpoint>/text
überschrieben. Hat soweit funktioniert.

Nun wollte ich weitere Änderungen vornehmen, doch jetzt werden
nur die neuen Änderungen in creo_parametric_cutomization.ui
gespeichert, alle alten sind verloren, d.h. nach dem Übeerschreiben
der creo_parametric_admin_customization.ui funktionieren nur
die neuen Einträge.

Programm: Creo 2.0 mit StartUpTools 2013

Was mache ich falsch?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Rudi2
Mitglied
Konstrukteur; CAD Admin

Sehen Sie sich das Profil von Rudi2 an!   Senden Sie eine Private Message an Rudi2  Schreiben Sie einen Gästebucheintrag für Rudi2

Beiträge: 6
Registriert: 17.09.2009

Core I5 3,33GHz; 8GB; FX580; Win7-64
Creo2-M030
PDMLink 10.1-M010
STools2013

erstellt am: 26. Nov. 2012 14:29    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hhr 10 Unities + Antwort hilfreich

Hallo hhr,

beim Export werden scheinbar nur die Änderungen exportiert.
Abhilfe: einfach alle *.ui-Dateien aus dem Zugriff von Creo bringen, dann zuerst die Original-*.ui-Datei importieren,
jetzt die Änderungen vornehmen und jetzt alles gemeinsam exportieren. Durch dieses Vorgehen werden alle Einstellungen
als Änderungen in eine Datei exportiert.

Gruß
Rudi2

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

hhr
Mitglied


Sehen Sie sich das Profil von hhr an!   Senden Sie eine Private Message an hhr  Schreiben Sie einen Gästebucheintrag für hhr

Beiträge: 9
Registriert: 06.11.2012

Software: Creo 2.0 mit StartUpTools 2013
Hardware: Fujitsu Celsius M720 - 16GB RAM, ATI FirePro v7900, SpaceExplorer USB von 3dconnexion

erstellt am: 26. Nov. 2012 16:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Genau so habe ich es dann ca. 2h vor Deiner Antwort
getan und es hat funktioniert. Trotzdem danke.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

KB-BLUST
Mitglied
Konstruktionsdienstleister/Consulting


Sehen Sie sich das Profil von KB-BLUST an!   Senden Sie eine Private Message an KB-BLUST  Schreiben Sie einen Gästebucheintrag für KB-BLUST

Beiträge: 299
Registriert: 21.05.2003

V 2001 / WFII / Creo3.0
INTRALINK 3.2 / 3.4
WindChill 9.x /10.x
Solidworks 2013-17
Keyshot Rendering
Keytech PLM
Sivas ERP

erstellt am: 05. Feb. 2013 10:51    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hhr 10 Unities + Antwort hilfreich

Ich haette da auch noch ne Frage zu:

Irgendwie muss man die Schnell-Zugriffleiste fuer jedes Modul separat machen, da wenn ich zu Blech oder Baugruppe wechsle, die Leiste wieder nur als fas leeres Original erscheint. --> Macht nix hab ich dann gemacht, funzt auch.

Aber:

selbst wenn fuer Einzelteile die angelegte Leiste dann passt, und man dann aber "innerhalb einer Baugruppe" ein Einzelteil "aktiviert", verschwindet die Baugruppensymbolleiste, und statt der definierten Einzelteil-Leiste kommt wieder eine leere Standardleiste...

dat geht ja gar nich!!** Oder gibts ne Moeglichkeit die Symbolleiste auf alle Auftritt-Variationen eines Objektyps " durchzuballern" - ne Kopierfunktion, nen Haken setzen irgendwo, ne Option schalten,.. irgendwas...??

(Selbst beim Einzelteil unterscheidet creo noch Blech und Teil--> 2 mal die gleiche Symbolleiste neu anlegen-.. was soll man da sagen?!)

Gruss

------------------
   KB-BLUST   

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

KB-BLUST
Mitglied
Konstruktionsdienstleister/Consulting


Sehen Sie sich das Profil von KB-BLUST an!   Senden Sie eine Private Message an KB-BLUST  Schreiben Sie einen Gästebucheintrag für KB-BLUST

Beiträge: 299
Registriert: 21.05.2003

V 2001 / WFII / Creo3.0
INTRALINK 3.2 / 3.4
WindChill 9.x /10.x
Solidworks 2013-17
Keyshot Rendering
Keytech PLM
Sivas ERP

erstellt am: 05. Feb. 2013 10:54    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hhr 10 Unities + Antwort hilfreich

... ach ja.. und wenn ich eine Unterbaugruppe in einer Oberbaugruppe aktiviere, passiert das Gleiche!

Dann hab ich auch keine Schnellzugriffsleiste mit den Baugruppendefinitionen mehr!

AuaAuaAua...

Gruss

------------------
   KB-BLUST   

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

KB-BLUST
Mitglied
Konstruktionsdienstleister/Consulting


Sehen Sie sich das Profil von KB-BLUST an!   Senden Sie eine Private Message an KB-BLUST  Schreiben Sie einen Gästebucheintrag für KB-BLUST

Beiträge: 299
Registriert: 21.05.2003

V 2001 / WFII / Creo3.0
INTRALINK 3.2 / 3.4
WindChill 9.x /10.x
Solidworks 2013-17
Keyshot Rendering
Keytech PLM
Sivas ERP

erstellt am: 05. Feb. 2013 11:48    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hhr 10 Unities + Antwort hilfreich


schnellzugriff.jpg

 
So sieht das in etwa aus, grade auch noch festgestellt dass auch innerhalb der Multifunktionsleiste die Anpassungen nicht durchschlagen auf Unterbaugruppe oder Teileebene wenn aktiviert

   

------------------
   KB-BLUST   

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

frank08
Mitglied
Konstrukteur


Sehen Sie sich das Profil von frank08 an!   Senden Sie eine Private Message an frank08  Schreiben Sie einen Gästebucheintrag für frank08

Beiträge: 1467
Registriert: 22.01.2004

Creo 4.0 M030
Windchill PDMLink 10.2
Windows 7x64, Dell Prec. T7810
NVIDIA Quadro M2000
2.66 GHz, 16 GB RAM
SUT 2017

erstellt am: 05. Feb. 2013 16:43    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hhr 10 Unities + Antwort hilfreich

Das Gegenteil von "Gut" ist "Gut gemeint". PTC hat es mit der Schnellstartleiste bei Creo eindeutig gut gemeint...  

------------------
Gruß Frank

[Diese Nachricht wurde von frank08 am 05. Feb. 2013 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

KB-BLUST
Mitglied
Konstruktionsdienstleister/Consulting


Sehen Sie sich das Profil von KB-BLUST an!   Senden Sie eine Private Message an KB-BLUST  Schreiben Sie einen Gästebucheintrag für KB-BLUST

Beiträge: 299
Registriert: 21.05.2003

V 2001 / WFII / Creo3.0
INTRALINK 3.2 / 3.4
WindChill 9.x /10.x
Solidworks 2013-17
Keyshot Rendering
Keytech PLM
Sivas ERP

erstellt am: 05. Feb. 2013 19:18    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hhr 10 Unities + Antwort hilfreich

Wie wahr....

Sollen mir nur mal begegnen bei Nacht, mein Optiker hats mit meiner
Nachtblindheitsbrille auch extrem gut gemeint    

------------------
   KB-BLUST   

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nixdesign
Mitglied
Dipl.-Ing. MB/CAD-Admin


Sehen Sie sich das Profil von nixdesign an!   Senden Sie eine Private Message an nixdesign  Schreiben Sie einen Gästebucheintrag für nixdesign

Beiträge: 103
Registriert: 20.06.2012

Creo 4.0 Parametric M060
Win 10 64-bit

erstellt am: 07. Feb. 2013 08:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hhr 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von Rudi2:
Hallo hhr,

beim Export werden scheinbar nur die Änderungen exportiert.
Abhilfe: einfach alle *.ui-Dateien aus dem Zugriff von Creo bringen, dann zuerst die Original-*.ui-Datei importieren,
jetzt die Änderungen vornehmen und jetzt alles gemeinsam exportieren. Durch dieses Vorgehen werden alle Einstellungen
als Änderungen in eine Datei exportiert.

Gruß
Rudi2


Hallo Rudi2,

die Idee ist schon mal gut. Jedoch wächst die angepasste Menüleiste ja mit der Zeit. Dann müsste man die ganzen vorher gemachten Anpassungen immer wieder neu mit in die Menüleiste aufnehmen. Oder gibt es da auch eine praktikable Lösung dafür?

Vielleicht liest ja auch ein Entwickler von Creo diese Sätze. Die Anpassung der Menü-/Schnellstartleiste umfasst bei uns 7 Module, für die jeweils, teils absolut identische Firmenspez. Anpassungen in jedem Modul separat gemacht werden müssen.
Bei uns in diesem Fall:
Bauteil (BT)
Baugruppe (BG)
Blechteil (SM)
Zeichnung
aktiviertes BT
aktivierte BG
aktiviertes SM

Hier wäre ein Menü-/Schnellstartleisten-Manager mit Kopierfunktion und eine ganzheitliche Speichermöglichkeit der *.ui dringend notwendig.

------------------
Gruß
Nick
____________________________

Hast du vortrefflich nachgedacht,
ist die Konstruktion ganz leicht gemacht.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Rudi2
Mitglied
Konstrukteur; CAD Admin

Sehen Sie sich das Profil von Rudi2 an!   Senden Sie eine Private Message an Rudi2  Schreiben Sie einen Gästebucheintrag für Rudi2

Beiträge: 6
Registriert: 17.09.2009

Core I5 3,33GHz; 8GB; FX580; Win7-64
Creo2-M030
PDMLink 10.1-M010
STools2013

erstellt am: 07. Feb. 2013 08:53    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hhr 10 Unities + Antwort hilfreich

Hallo Nick,

wenn man Creo ohne ui startet, und dann die angepasste ui nachlädt, hat man ja alle bis dahin gemachten Änderungen in allen Modulen. Dann können die Änderungen komplett gespeichert werden. Komfortabel ist es allerdings wirklich nicht.
Mir ist auch nicht klar, warum ein in einer Baugruppe aktiviertes Part eine andere Oberfläche benötigt, als ein direkt geöffnetes Part.
Zum Glück kann man die Fenster verschieben, dass man im Hintergrund eine Vorlage sehen kann, um eine einheitliche Oberfläche zu bekommen.

Gruß
Rudi2

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nixdesign
Mitglied
Dipl.-Ing. MB/CAD-Admin


Sehen Sie sich das Profil von nixdesign an!   Senden Sie eine Private Message an nixdesign  Schreiben Sie einen Gästebucheintrag für nixdesign

Beiträge: 103
Registriert: 20.06.2012

Creo 4.0 Parametric M060
Win 10 64-bit

erstellt am: 07. Feb. 2013 10:04    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hhr 10 Unities + Antwort hilfreich

Hallo Rudi2,

danke zunächst für die Antwort.
Ich habe allerdings das Problem, dass nach dem Deaktivieren der *.ui (Verzeichnis \.Settings -lokal- und \projects -Server-) und dem anschließenden importieren der bereits angepassten *.ui die Icons nicht richtig dargestellt werden. Hat was damit zu tun, dass in Creo die Größe der Icons von 16 x 16 Pixel verwendet wird, aber alte Icons aus WF3 mit 20 x 20 Pixel dargestellt wurden. Mühsam neu erstellte Icon werden aber in der *.ui aus dem Verzeichnis \.Settings geladen, die aber deaktiviert ist.
In WF3 war die config.win für die Darstellung zuständig. Da war das eindeutig. Nun gibt es die config.win eigentlich nicht mehr, denkt man. Aber wenn man mal in Creo unter "Datei=>Hilfe=>Systeminformationen" nachschaut, sieht man, dass unter "Konfigurationsinfo" sehr wohl noch eine config.win geladen wird.
Die Vorgehensweise der Abspeicherung und wie die Darstellung in der Menüleiste funktioniert ist sehr schleierhaft.

------------------
Gruß
Nick
____________________________

Hast du vortrefflich nachgedacht,
ist die Konstruktion ganz leicht gemacht.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Rudi2
Mitglied
Konstrukteur; CAD Admin

Sehen Sie sich das Profil von Rudi2 an!   Senden Sie eine Private Message an Rudi2  Schreiben Sie einen Gästebucheintrag für Rudi2

Beiträge: 6
Registriert: 17.09.2009

Core I5 3,33GHz; 8GB; FX580; Win7-64
Creo2-M030
PDMLink 10.1-M010
STools2013

erstellt am: 07. Feb. 2013 10:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hhr 10 Unities + Antwort hilfreich

Hallo Nick,

vor der Konfiguration hatte ich alle lokalen *.win und *.ui-Dateien aus .Settings, aus dem Arbeitsverzeichnis und aus dem Text-Verzeichnis gelöscht. Jetzt wird bei jedem Creo-Start genau eine *.ui vom Server kopiert. In dieser sind auch die Symbole für Mapkeys gespeichert.
Dadurch ist die Konfiguration einmal zwar mühselig aber beherrschbar.

Gruß
Rudi2

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

binichnich
Mitglied
Manager Technical Design / CAD Admin


Sehen Sie sich das Profil von binichnich an!   Senden Sie eine Private Message an binichnich  Schreiben Sie einen Gästebucheintrag für binichnich

Beiträge: 129
Registriert: 30.08.2010

erstellt am: 12. Apr. 2013 08:46    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hhr 10 Unities + Antwort hilfreich


VORDEMSPEICHERN1.png


MITLADEN1.png

 
Hallo miteinander,

Ich möchte mich gern einklinken:
Ich versuche mal wieder, die Menüleiste (oder wie die oberste Leiste auch immer heißt) anzupassen.

Nun muss ich feststellen, dass noch immer das Phänomen auftritt, dass meine Symbole beim mit-laden der ui Datei durcheinander gewirbelt werden.

Was ich bereits heraus gefunden habe: Wenn ich alle Symbole lösche und nur mapkeys und symbole, die standardmäßig nicht dort angezeigt werden, platziere, passt alles und die Reihenfolge wird wiederhergestellt.

Sobald ich zB das ÖFFNEN Symbol irgendwo in der Mitte der Leiste platziere, wird das Öffnen Symbol wieder an die 2. Stelle gerückt und die anderen Symbole dureinander gewirbelt    

Ich hab 2 Bilder angehängt, Anordnung vor dem Speichern <--> Anordnung nach dem Mitladen

Ist das nur bei mir so?
Oder ein generelles PRO-BLEM?

Dank
mfg

[Diese Nachricht wurde von binichnich am 12. Apr. 2013 editiert.]

[Diese Nachricht wurde von binichnich am 12. Apr. 2013 editiert.]

[Diese Nachricht wurde von binichnich am 12. Apr. 2013 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

nixdesign
Mitglied
Dipl.-Ing. MB/CAD-Admin


Sehen Sie sich das Profil von nixdesign an!   Senden Sie eine Private Message an nixdesign  Schreiben Sie einen Gästebucheintrag für nixdesign

Beiträge: 103
Registriert: 20.06.2012

Creo 4.0 Parametric M060
Win 10 64-bit

erstellt am: 15. Apr. 2013 08:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für hhr 10 Unities + Antwort hilfreich

Hallo binichnich,

die Leiste die du meinst heißt "Symbolleiste für Schnellzugriff". Die darunter mit den verschiedenen Reitern ist die "Multifunktionsleiste".
Dein Pro/blem mit den Leisten könnte vielleicht durch den Einsatz einer bestimmten Version oder Zusatzmodulen hervorgerufen werden (vermute ich), da wir momentan mit Creo 1 (M040) und Stools 2012 arbeiten und ich kein Problem mit einer gespeicherten Symbolleiste habe (Speicherort für die ui. C:\Users\"username"\AppData\Roaming\PTC\ProENGINEER\Wildfire\.wf\.Settings).

------------------
Gruß
Nick
____________________________

Hast du vortrefflich nachgedacht,
ist die Konstruktion ganz leicht gemacht.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz