Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Rund um AutoCAD
  Probleme beim Ausführen eines Scripts

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Probleme beim Ausführen eines Scripts (318 mal gelesen)
WolfgangSCH
Mitglied
Student


Sehen Sie sich das Profil von WolfgangSCH an!   Senden Sie eine Private Message an WolfgangSCH  Schreiben Sie einen Gästebucheintrag für WolfgangSCH

Beiträge: 139
Registriert: 01.10.2002

AutoCAD 2020
Windows 10 64-bit

erstellt am: 07. Feb. 2020 15:45    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo,

ich versuche schon seit geraumer Zeit ein Script unter AutoCAD 2020 zum Laufen zu bringen. Leider ohne Erfolg. Dieses Script funktioniert unter AutoCAD 2014 problemlos.
Wenn ich das Script in der Befehlszeile von AutoCAD 2020 mit dem Befehl "Script" aufrufe und die entsprechende Datei im Fenster auswähle, ruft mir das Script die DWG "Test.dwg" einwandfrei auf. Danach sollte eigenntlich der Befehl "Bereinig" ausgeführt werden, AutoCAD fragt aber in der Befehlszeile nach einem Makronamen und bekommt vom Script den "Bereinig"-Befehl, was dann halt nicht funktioniert. Hat jemand einen Tipp für mich? Was mache ich falsch?

Die AutoCAD-Befehlszeile zeigt nach dem Aufruf der DWG:
Befehl:
Befehl:
Dienstprogramm geladen
Makroname: Bereinig
Makro nicht gefunden
Befehl: al Unbekannter Befehl "AL"

Script:
SETVAR SDI 1
_open "C:\Test\Test.dwg" Bereinig al  N Zoom G Ende
SETVAR SDI 0 Quit J

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 19659
Registriert: 03.06.2002

System: F1
und Google

erstellt am: 07. Feb. 2020 16:00    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für WolfgangSCH 10 Unities + Antwort hilfreich

Offenbar läuft da noch etwas anderes ab beim öffnen einer Datei..
Dein Script kommt dem in die Quere.

Finde heraus was bei dir angepasst wurde und nicht richtig läuft.
Ich tippe mal darauf du warst es selbst?


Anscheinend wurde das VBA Modul installiert(?)
und ein automatischer Ladevorgang eines VBA-Makros eingerichtet (Befehl: vbaausf)

Dann kommt was auch immer wir noch nicht wissen und sendet einmal ENTER,
was wiederum den letzten Befehl (VBAAUSF) aufruft.

Näheres kann man schwer sagen von hier aus.
Schau also nach was da alles "optimiert" wurde im System.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

WolfgangSCH
Mitglied
Student


Sehen Sie sich das Profil von WolfgangSCH an!   Senden Sie eine Private Message an WolfgangSCH  Schreiben Sie einen Gästebucheintrag für WolfgangSCH

Beiträge: 139
Registriert: 01.10.2002

AutoCAD 2020
Windows 10 64-bit

erstellt am: 07. Feb. 2020 16:28    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke für Deine Tipps.
In der Tat werden nach dem AutoCAD-Start noch die Express-Tools geladen und ein selbst erstelltes VBA-Makro.
Ich werde dieses einmal deaktivieren und schauen, ob das Script dann korrekt läuft.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

WolfgangSCH
Mitglied
Student


Sehen Sie sich das Profil von WolfgangSCH an!   Senden Sie eine Private Message an WolfgangSCH  Schreiben Sie einen Gästebucheintrag für WolfgangSCH

Beiträge: 139
Registriert: 01.10.2002

AutoCAD 2020
Windows 10 64-bit

erstellt am: 07. Feb. 2020 16:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Wie Du schon vermutet hast wird nach dem Start von AutoCAD eine ACAD.LSP geladen:

(defun S::STARTUP()
(setq $cmdecho (getvar "cmdecho")) ; Variable CMDECHO wird ausgelesen
(setvar "cmdecho" 0) ; Variable CMDECHO wird 0 gesetzt -> keine Ausgabe in AutoCAD-Befehlszeile
_$ (vl-vbaload "C:/Programme/Autodesk/AutoCAD 2020/CAD-Tools/MENU.DVB") ; Läd Makro Menü.dvb
_$ (vl-vbarun "menu") ; Führt Makro Menü.dvb aus
_$ (vl-vbaload "C:/Programme/Autodesk/AutoCAD 2020/CAD-Tools/CADTOOLS.DVB") ; Läd Makro CADTools.dvb
(setvar "cmdecho" $cmdecho) ; Ursprünglicher Wert von Variable CMDECHO wird wieder gesetzt
(load "C:/Programme/Autodesk/AutoCAD 2020/Lisp-Routinen/Chgtext")

Hier wird ein Menü und VBA-Makro installiert und eine Lisp-Routine geladen.

Wenn ich die ACAD.LSP deaktiviere, läuft das Script einwandfrei durch.
Die VBA-Makros und die Lisp-Routine werden aber weiterhin benötigt.
Wie kann ich hier die Probleme mit meinem Script verhindern?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 19659
Registriert: 03.06.2002

System: F1
und Google

erstellt am: 07. Feb. 2020 16:50    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für WolfgangSCH 10 Unities + Antwort hilfreich

Da könnte ich jetzt viel zu schreiben, zu viel: Wochenende  (naja, theoretisch)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

WolfgangSCH
Mitglied
Student


Sehen Sie sich das Profil von WolfgangSCH an!   Senden Sie eine Private Message an WolfgangSCH  Schreiben Sie einen Gästebucheintrag für WolfgangSCH

Beiträge: 139
Registriert: 01.10.2002

AutoCAD 2020
Windows 10 64-bit

erstellt am: 07. Feb. 2020 18:10    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke für Deine Hilfe.
Ich habe in die ACAD.LSP an entsprechender Stelle ein (Command "") eingefügt, seitdem klappt es wie es soll.
Wünsche ein schönes und erholsames Wochenende.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

cadffm
Moderator
良い精神




Sehen Sie sich das Profil von cadffm an!   Senden Sie eine Private Message an cadffm  Schreiben Sie einen Gästebucheintrag für cadffm

Beiträge: 19659
Registriert: 03.06.2002

System: F1
und Google

erstellt am: 07. Feb. 2020 19:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für WolfgangSCH 10 Unities + Antwort hilfreich

Es liegen uns vielleicht nicht alle Infos vor, aber ganz pauschal:

Du solltest vielleicht nochmal sauber die ACAD.lsp, das S::startup und die ACADDOC.lsp nutzen,
Sauber getrennt verwenden (also acadlspasdoc deaktivieren)

Ein VBA Programm zb. lädst du doch in die Applikation und solange die Sitzung besteht lädt man diese nicht noch einmal.

Nur so ein Gedanke

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz