Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  Inventor
  bei Migration Error Servicemodule.exe

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   bei Migration Error Servicemodule.exe (249 mal gelesen)
Meierjo
Mitglied



Sehen Sie sich das Profil von Meierjo an!   Senden Sie eine Private Message an Meierjo  Schreiben Sie einen Gästebucheintrag für Meierjo

Beiträge: 75
Registriert: 20.08.2003

System: Windows 7 64 Bit
Inventor 2017 Build 256

erstellt am: 02. Jul. 2018 15:08    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


Migrationsoptionen.png


0x40000015.png


servicemodule.exeError.png

 
Hallo

In der Vorbereitung auf das Update von Inventor 2017 auf Inventor 2019 versuche ich in einer Testumgebung die CAD-Daten zu migrieren. Die Daten sind in Vault gespeichert, Update des Vault Servers auf Version 2019 und Client Installationen auf Vault 2019 / Inventor 2019 sind problemlos durchgelaufen.

Beim Migrieren der CAD-Daten kommt es immer wieder dazu, dass die "Servicemodule.exe" abstürzt, siehe dazu die angehängten Print-Screens. Folgendes habe ich schon durchprobiert:
- Daten direkt aus dem Tresor migrieren
- Daten zuerst ausschecken, und dann vom lokalen Workspace migrieren
- Nur "Päckchen" von ca 3.5 GB an einem Stück migrieren
- nur IPT-Dateien migrieren
- nur 1 Prozess in er Migration laufen lassen

Dabei kommt es immer wieder (mal bei 30%, mal bei 55%) zum dem Error der Servicemodule.exe, nur der Inhalt der Fehlermeldung ändert teilweise, manchmal bezieht sich der Fehler auf die ntdll.dll, manchmal auf die  ucrtbase.dll.

Wie kann ich die Ursache des Fehlers noch weiter eingrenzen, mir sind die Ideen ausgegangen??

Freundliche Grüsse

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

mcap
Mitglied
CAD-Supporter


Sehen Sie sich das Profil von mcap an!   Senden Sie eine Private Message an mcap  Schreiben Sie einen Gästebucheintrag für mcap

Beiträge: 48
Registriert: 13.11.2014

Dell M6700
ACAD 2017/18
IV 2017/18
WIN 7/64 und 10/64

erstellt am: 02. Jul. 2018 19:55    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Meierjo 10 Unities + Antwort hilfreich

Hallo Meierjo,

Mir hat schon geholfen, die DB vom Aufgabenplaner zurückzusetzen. Wenn die zu gross wird, gibts Probleme.
Du findest die in:
C:\Users\Public\Documents\Autodesk\Inventor 2019\Task Scheduler

Kopier dir von einer neuen Installation eine leere DB (taskscheduler.mdb / 420 KB) dahin.

Ich mach mir immer eine Leer-Kopie bevor ich mit Aufgabenplaner arbeite.

Sonst ist dein Vorgehen nicht schlecht.
So machen wir es jeweils (max Anzahl Prozesse = 1):

1. Auschecken
2. IPTs migrieren
3. IAMs und IPNs migrieren
4. IDWs migrieren
5. Einchecken

So haben wir letztes mal >220'000 Dateien von 2014 auf 2017 migriert.

------------------
Gruss Marco

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Meierjo
Mitglied



Sehen Sie sich das Profil von Meierjo an!   Senden Sie eine Private Message an Meierjo  Schreiben Sie einen Gästebucheintrag für Meierjo

Beiträge: 75
Registriert: 20.08.2003

System: Windows 7 64 Bit
Inventor 2017 Build 256

erstellt am: 02. Jul. 2018 20:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Marco

Danke für die schnelle Rückmeldung.
Aber wenn da nur 1 Prozess rattert, dauert die Migration doch ewig?? wie lange habt ihr für die 220T Dateien gebraucht?
Hast du in den Optionen beim Migrieren andere Häckchen drin, als bei mir??
Gruss

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

mcap
Mitglied
CAD-Supporter


Sehen Sie sich das Profil von mcap an!   Senden Sie eine Private Message an mcap  Schreiben Sie einen Gästebucheintrag für mcap

Beiträge: 48
Registriert: 13.11.2014

Dell M6700
ACAD 2017/18
IV 2017/18
WIN 7/64 und 10/64

erstellt am: 04. Jul. 2018 14:50    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Meierjo 10 Unities + Antwort hilfreich

Hallo Meierjo,

Einstellungen aktiviert:
Alles neu erstellen.
Migrierte Dateien überspringen.
Dateien mit unaufgelösten Referenzen überspringen.
Ältere Versionen löschen.

Wir hatten dazu eine (virtuelle) Maschine mit 32GB RAM und 16 Prozessoren und genügend HD (= virtuell = wie SSD).

Und es dauerte etwa 3.5 - 4 Tage (inkl. Vault Backup und Restore, Migrieren der Stilbibliotheken [DesignData], Templates, Normteile). Reine Datenmigration war glaub ich etwa 2.5 - 3 Tage.

Bei den IPTs kannst du versuchen, mit mehreren Prozessen zu arbeiten. Wir hatten aber Probleme und schlussendlich darauf verzichtet.

------------------
Gruss Marco

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Meierjo
Mitglied



Sehen Sie sich das Profil von Meierjo an!   Senden Sie eine Private Message an Meierjo  Schreiben Sie einen Gästebucheintrag für Meierjo

Beiträge: 75
Registriert: 20.08.2003

System: Windows 7 64 Bit
Inventor 2017 Build 256

erstellt am: 05. Jul. 2018 06:39    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Marco

Danke für die Rückmeldung. Ich habe eine leere Taskmanager.mdb genommen, und die Migrationen in Päckchen von ca 5 - 7 GB (zuerst IPT, dann IAM) durchgeführt. Nun läuft die Migration durch, mit maximal 3 Prozessen gleichzeitig.
Ich hatte versucht, 6 Prozesse gleichzeitig laufen zu lassen (auf einem PC mit 12 Cores, 64 GB Ram). Dies wahr wohl zuviel.
Restliche Migration (IDW) läuft noch, wird aber wahrscheinlich keine neuen Probleme mit sich bringen.

Herzlichen Dank und einen schönen Tag
Gruss meierjo


[Diese Nachricht wurde von Meierjo am 05. Jul. 2018 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2018 CAD.de | Impressum | Datenschutz