Hot News aus dem CAD.de-Newsletter:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  NX Programmierung
  journal automatisch starten

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   journal automatisch starten (136 mal gelesen)
stritzl
Mitglied



Sehen Sie sich das Profil von stritzl an!   Senden Sie eine Private Message an stritzl  Schreiben Sie einen Gästebucheintrag für stritzl

Beiträge: 44
Registriert: 17.10.2008

NX 7.5.5.4
TEAMCENTER 8.3.3
Windows7 Enterprise 64bit
MS Office 2010

erstellt am: 06. Okt. 2017 13:16    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Forum!

Gibt es die Möglichkeit, ein journal "automatisch" starten zu lassen? Also nicht metaphysisch mit "der Macht"  sonder nach dem Betätigen des "Speichern" Icons, aber bevor gespeichert wird. Falls das geht, was muss man tun? Oder welche Alternativen gibt es?

Gruß
Stritz

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Poseida
Mitglied
Maschinebautechniker, Konstrukteur


Sehen Sie sich das Profil von Poseida an!   Senden Sie eine Private Message an Poseida  Schreiben Sie einen Gästebucheintrag für Poseida

Beiträge: 77
Registriert: 15.12.2010

NX 8.5 + Teamcenter 8.3.3.10 + Moldex 3D R13
NX 10 TC 11

erstellt am: 06. Okt. 2017 14:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für stritzl 10 Unities + Antwort hilfreich

Poseida
Mitglied
Maschinebautechniker, Konstrukteur


Sehen Sie sich das Profil von Poseida an!   Senden Sie eine Private Message an Poseida  Schreiben Sie einen Gästebucheintrag für Poseida

Beiträge: 77
Registriert: 15.12.2010

NX 8.5 + Teamcenter 8.3.3.10 + Moldex 3D R13
NX 10 TC 11

erstellt am: 06. Okt. 2017 14:25    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für stritzl 10 Unities + Antwort hilfreich

oder eine POST PRE Action an den Befehl ranhängen

------------------
Benjamin

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

stritzl
Mitglied



Sehen Sie sich das Profil von stritzl an!   Senden Sie eine Private Message an stritzl  Schreiben Sie einen Gästebucheintrag für stritzl

Beiträge: 44
Registriert: 17.10.2008

NX 7.5.5.4
TEAMCENTER 8.3.3
Windows7 Enterprise 64bit
MS Office 2010

erstellt am: 06. Okt. 2017 15:59    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke,

aber irgendwo ist ein Wald und lauter Bäume davor.

ich habe folgende .men in ${UGS_SHR_DIR}\site\startup abgelegt:

VERSION 120
EDIT UG_FILE
MODIFY
BUTTON UG_FILE_SAVE_PART
ACTIONS/PRE ${UGS_SHR_DIR}\pattern75\Journale\Sprachattribute.vb
END_OF_MODIFY


Leider wird das Journal nicht gestartet 

Was mache ich falsch?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

mseufert
Moderator
Freiberuflicher CAD/CAM Ingenieur


Sehen Sie sich das Profil von mseufert an!   Senden Sie eine Private Message an mseufert  Schreiben Sie einen Gästebucheintrag für mseufert

Beiträge: 2232
Registriert: 18.10.2005

HP Z420
WIN XP32 / WIN7 64
UG NX6-11
SUN Ultra 60
Solaris 7
CADDS5

erstellt am: 06. Okt. 2017 17:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für stritzl 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von stritzl:
Was mache ich falsch?

Hallo stritzl,

das steht im Logfile, zum einen das Laden der .men und ggfs. auch der misslungene Startversuch. Hast Du dort schon mal nachgeschaut ?

Gruß, Michael

------------------
Ein Mensch wird laut, wenn er was will;
wenn er's erst hat, dann wird er still;
Das "Danke" ist, nach alter Sitte,
Weit seltner als das "Bitte, Bitte".

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

stritzl
Mitglied



Sehen Sie sich das Profil von stritzl an!   Senden Sie eine Private Message an stritzl  Schreiben Sie einen Gästebucheintrag für stritzl

Beiträge: 44
Registriert: 17.10.2008

NX 7.5.5.4
TEAMCENTER 8.3.3
Windows7 Enterprise 64bit
MS Office 2010

erstellt am: 09. Okt. 2017 09:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Michael,

Danke für Deine Antwort!
im logfile habe ich nichts gefunden über das Laden der .men gefunden.
Muss man NX evtl. noch irgendwo einen Hinweise auf den "\site\startup\" Pfad geben?
Es handelt sich hier um ein "share" Verzeichnis auf dem Server...

Gruß
Stritzl

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

stritzl
Mitglied



Sehen Sie sich das Profil von stritzl an!   Senden Sie eine Private Message an stritzl  Schreiben Sie einen Gästebucheintrag für stritzl

Beiträge: 44
Registriert: 17.10.2008

NX 7.5.5.4
TEAMCENTER 8.3.3
Windows7 Enterprise 64bit
MS Office 2010

erstellt am: 09. Okt. 2017 12:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Den ersten Fehler habe ich gefunden. Der Verweis auf den Ablageort der .men Datei war in der verkehrten "custom_dirs.dat" eingetragen.
Jetzt erhalte ich immerhin eine Zeile im logfile:

MB_MENU_FILE_LOAD_FAILED Startup menu file load failed for: \\svrp1\lp_konf\ugsshare\site\startup\Menu_adaption.men

kann jemand die Fehlerursache schließen?

Gruß
Stritzl

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

mseufert
Moderator
Freiberuflicher CAD/CAM Ingenieur


Sehen Sie sich das Profil von mseufert an!   Senden Sie eine Private Message an mseufert  Schreiben Sie einen Gästebucheintrag für mseufert

Beiträge: 2232
Registriert: 18.10.2005

HP Z420
WIN XP32 / WIN7 64
UG NX6-11
SUN Ultra 60
Solaris 7
CADDS5

erstellt am: 09. Okt. 2017 19:01    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für stritzl 10 Unities + Antwort hilfreich

Hallo stritzl,

ist die Pfadangabe im Logfile korrekt ? D.h. ist \\svrp1\lp_konf\ugsshare\site\startup\Menu_adaption.men der korrekte Pfad zu deiner .men ? Falls ja, kann's nur noch am Inhalt liegen, und das lässt sich ja austesten. Du kannst z.B. als PreAction probeweise eine Standardfunktion oder eine komplierte .exe bzw. .dll eintragen, NX neu starten und sehen, was dann im Logfile steht.

Gruß, Michael

------------------
Ein Mensch wird laut, wenn er was will;
wenn er's erst hat, dann wird er still;
Das "Danke" ist, nach alter Sitte,
Weit seltner als das "Bitte, Bitte".

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2017 CAD.de