Hot News:

Unser Angebot:

  Foren auf CAD.de (alle Foren)
  SQLServer
  MS SQL-Server Express nach Update nicht mehr erreichbar

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   MS SQL-Server Express nach Update nicht mehr erreichbar (1831 mal gelesen)
CAE.IT
Mitglied
Informatiker


Sehen Sie sich das Profil von CAE.IT an!   Senden Sie eine Private Message an CAE.IT  Schreiben Sie einen Gästebucheintrag für CAE.IT

Beiträge: 89
Registriert: 03.03.2011

erstellt am: 01. Sep. 2016 15:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Miteinander,

Da Eplan ab der version 2.5 nur noch in 64 bit läuft, wurde für diese Anwendung SQL-Server Express installiert.
Nach einem Update auf dem Server ist SQL seitens Eplan nicht mehr erreichbar.
Ich habe auf dem Server nachgeschaut und komme auch mit Management Studio nicht mehr an den Server ran.
Ein manueller Start der Dienste führt auch nicht zum Ziel.

Auszug aus dem Error-Log:
2016-08-30 17:37:25.70 spid24s    Starting up database 'M_PROJECTS1'.
2016-08-30 17:37:26.00 spid24s    Starting up database 'M_Projects_Test'.
2016-08-30 17:37:26.27 spid24s    Starting up database 'M_Projects_Test2'


2016-08-30 17:39:10.78 spid20s    Error: 17054, Severity: 16, State: 1.
2016-08-30 17:39:10.78 spid20s    The current event was not reported to the Windows Events log. Operating system error = (null). You may need to clear the Windows Events log if it is full.
2016-08-30 17:39:10.83 spid11s    .NET Framework runtime has been stopped.
2016-08-30 17:39:11.26 spid11s    SQL Trace was stopped due to server shutdown. Trace ID = '1'. This is an informational message only; no user action is required.
2016-08-30 17:39:11.51 spid15s    The SQL Server Network Interface library could not deregister the Service Principal Name (SPN) [ MSSQLSvc/MACKDATA.elektro-mack.com:EPLAN ] for the SQL Server service. Error: 0xffffffff, state: 63. Administrator should deregister this SPN manually to avoid client authentication errors.
2016-08-30 17:39:11.51 spid15s    The SQL Server Network Interface library could not deregister the Service Principal Name (SPN) [ MSSQLSvc/MACKDATA.elektro-mack.com:1433 ] for the SQL Server service. Error: 0xffffffff, state: 63. Administrator should deregister this SPN manually to avoid client authentication errors.

Die Dienste lassen sich auch manuell nicht starten, es kommt eine Fehlermeldung Interfaces, error 26 - Fehler beim Bestimmen des angegebenen Servers/ der angegebenen Instanz.

Bin für jeden Tipp dankbar!

------------------
sanfte Grüße !

Jürgen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

KlaK
Ehrenmitglied V.I.P. h.c.
Dipl. Ing. Vermessung, CAD- und Netz-Admin



Sehen Sie sich das Profil von KlaK an!   Senden Sie eine Private Message an KlaK  Schreiben Sie einen Gästebucheintrag für KlaK

Beiträge: 2162
Registriert: 02.05.2006

AutoCAD LandDesktop R2 bis 2004
Civil 3D 2005 - 2014
Plateia, Canalis
Visual Basic

erstellt am: 02. Sep. 2016 13:19    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CAE.IT 10 Unities + Antwort hilfreich

Hallo Jürgen,

So richtig eine Idee habe ich noch nicht. Ich gehe einmal davon aus dass Ihr auch die 64-Bit version des SQL-Server Express installiert habt? Welche Version?

Ist der SQL-Server lokal auf dem gleichen PC installiert wie EPlan oder auf einem anderen?
Was mir noch aufgefallen ist: Du (oder Eplan) benutzt den Unterstrich im DB-Namen, das sollte man tunlichst vermeiden, wie ich vor einiger Zeit vim SQL-Server 2008 feststellen mußte. Habe dann auch einige PC umbenennen dürfen da MS-SQL auch den Unterstrich im PC-Namen mißinterpretiert hatte 

Was mich auch stutzig macht ist dass die Managementconsole nicht mehr funktionieren soll. Wurde diese auch neu installiert?

Grüße
Klaus 

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CAE.IT
Mitglied
Informatiker


Sehen Sie sich das Profil von CAE.IT an!   Senden Sie eine Private Message an CAE.IT  Schreiben Sie einen Gästebucheintrag für CAE.IT

Beiträge: 89
Registriert: 03.03.2011

erstellt am: 02. Sep. 2016 14:02    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Klaus,

- der SQL-Server befindet sich auf dem Datenserver der Domäne.
- es handelt sich um SQL_EXPRESS_2014
- die managementconsole wurde nicht neu installiert
es wurden lediglich normale Windows-updates gefahren, nach dem Neustart war der SQL-Server tot.

Ich kann mit SQL-Management-Studio nicht mehr drauf zugreifen.
Im SQL Server Configuration Manager sieht alles normal aus,SQL-Server Netzwerkkonfiguration Shared Memory, named Pipes,TCP/ IP ist on.

Die Fehlermeldung Spukte ja "Administrator should deregister this SPN manually to avoid client authentication errors." aus. Sagt Dir das etwas?

------------------
sanfte Grüße !

Jürgen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CAE.IT
Mitglied
Informatiker


Sehen Sie sich das Profil von CAE.IT an!   Senden Sie eine Private Message an CAE.IT  Schreiben Sie einen Gästebucheintrag für CAE.IT

Beiträge: 89
Registriert: 03.03.2011

ePlan 5.71, ePlan P8 2.6, Ruplan (Daimler)

erstellt am: 02. Sep. 2016 15:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Ich habe jetzt festgestellt, das die im SQL-Server eingetragenen Benutzer
NT Service\MSSQL$EPLAN
NT Service\MSSQLFDLauncher$EPLAN
NT Service\ReportServer$EPLAN
NT AUTHORITY\NETWORKSERVICE
NT AUTHORITY\Localservice

in der Domäne nicht vorhanden sind.
Offenbar handelt es sich ja um ein Authorisierungsproblem...

------------------
sanfte Grüße !

Jürgen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CAE.IT
Mitglied
Informatiker


Sehen Sie sich das Profil von CAE.IT an!   Senden Sie eine Private Message an CAE.IT  Schreiben Sie einen Gästebucheintrag für CAE.IT

Beiträge: 89
Registriert: 03.03.2011

erstellt am: 02. Sep. 2016 16:38    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

ich installiere gerade MS SQL Express lokal auf einem Laptop.
Dort kommen die gleichen Namen vor:
SQL Server-Datenbankmodul NT Service\MSSQL$SQLEXPRESSEPLAN
SQL Server Reporting Services NT Service\ReportServer$SQLEXPRESSEPLAN
Startprogramm für SQL-Volltextfilterdaemon NT Service\MSSQLFDLauncher$SQLEXPRESSEPLAN
SQL Server-Browser NT AUTHORITY\LOCAL SERVICE

------------------
sanfte Grüße !

Jürgen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CAE.IT
Mitglied
Informatiker


Sehen Sie sich das Profil von CAE.IT an!   Senden Sie eine Private Message an CAE.IT  Schreiben Sie einen Gästebucheintrag für CAE.IT

Beiträge: 89
Registriert: 03.03.2011

ePlan 5.71, ePlan P8 2.6, Ruplan (Daimler)

erstellt am: 02. Sep. 2016 17:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


2016-09-02_SQL_Abbruch.png

 
habe gerade die Reperatur probiert (hätte ich wohl als erstes machen sollen...)

jedenfalls funktioniert es nicht, siehe screenshot


------------------
sanfte Grüße !

Jürgen

[Diese Nachricht wurde von CAE.IT am 02. Sep. 2016 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

CAE.IT
Mitglied
Informatiker


Sehen Sie sich das Profil von CAE.IT an!   Senden Sie eine Private Message an CAE.IT  Schreiben Sie einen Gästebucheintrag für CAE.IT

Beiträge: 89
Registriert: 03.03.2011

erstellt am: 02. Sep. 2016 18:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

!!!!TSCHAKKA!!!

Es gab zwar die eine Fehlermeldung, aber ich habe meine Datenbanken wieder!
Jetzt kanns Wochenende beginnen! 
(Freitag 18:06)

------------------
sanfte Grüße !

Jürgen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP



Projektingenieur Antriebstechnik (m/w/d)
<...
Anzeige ansehenProjektmanagement
ca18et
Mitglied



Sehen Sie sich das Profil von ca18et an!   Senden Sie eine Private Message an ca18et  Schreiben Sie einen Gästebucheintrag für ca18et

Beiträge: 52
Registriert: 29.04.2013

SQL Server 7

erstellt am: 11. Nov. 2016 11:24    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CAE.IT 10 Unities + Antwort hilfreich

Der Vollständigkeit halber:
die aufgelisteten Benutzer sind alles lokale Benutzer, keine Domänenbenutzer.

Named Pipes auch aktiv? Oder nur TCP-IP eingeschaltet?

Was man gerne auch übersieht ist die Verwendung von

<Servername>/<Instancename> anstatt
<Servername>\<Instancename>

Aber es geht ja jetzt....

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz