Hot News:

Unser Angebot:

  Foren auf CAD.de (alle Foren)
  BeckerCAD
  B-CAD4.0 DEMO: Abstürze und andere Fehler

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   B-CAD4.0 DEMO: Abstürze und andere Fehler (1421 mal gelesen)
Sigi.K
Mitglied
Elektroniker

Sehen Sie sich das Profil von Sigi.K an!   Senden Sie eine Private Message an Sigi.K  Schreiben Sie einen Gästebucheintrag für Sigi.K

Beiträge: 4
Registriert: 09.09.2005

erstellt am: 12. Sep. 2005 08:42    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen,

ich habe die 10Tage Testversion von Becker CAD 4.0 geladen und getestet.

Offensichtlich sind noch einige Fehler in der (Demo) Software. 
Besonders davon ist der Modell Explorer betroffen.
Hier waren regelmäßige Abstürze der Software beim Verschieben oder Löschen von Objekten.

Die Testversion hat die Rev. 2981.333

Ist die Kaufversion dahingehend neuer, also verbessert? 

Gibt es einen Entwickler von B-CAD im Forum der empfänglich für Bugreports ist?

Ich komme aus dem Elektronikbereich. Bisher hatte ich noch wenig mit CAD zu tun, bin aber schwer begeistert, was ich in relativ kurzer Zeit damit erreicht habe. :-)

Danke für Hinweise
Sigi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

fschultze
Moderator



Sehen Sie sich das Profil von fschultze an!   Senden Sie eine Private Message an fschultze  Schreiben Sie einen Gästebucheintrag für fschultze

Beiträge: 171
Registriert: 14.05.2002

erstellt am: 12. Sep. 2005 14:30    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Sigi.K 10 Unities + Antwort hilfreich

Hallo Sigi,
ich vermute, dass es bei den Abstürzen eher etwas mit der Grafikkarte, dem Grafiktreiber oder aber dem Betriebssystem zu tun hat.
Hierzu als Test einfach einmal die Hardwarebeschleunigung der Grafikkarte heruntersetzen (Eigenschaften von Anzeige, Einstellungen, Erweitert) und das Programm dann so starten und ausprobieren. Ist es nun wesentlich besser, liegt es an der Grafikkarte. Probleme machen im Grunde alle ATI Radeon Chipsätze. Auch ist sicherlich Windows 98 als Betriebssystem eher ungeeignet. An der Software liegt es nicht, da diese über 1 Jahr in dieser Form auf dem Markt ist und deren "Kinderkrankheiten" beseitigt sind. Auch die Demoversion hat damit nichts zu tun.
MfG
DataSolid GmbH
Frank Schultze

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Sigi.K
Mitglied
Elektroniker

Sehen Sie sich das Profil von Sigi.K an!   Senden Sie eine Private Message an Sigi.K  Schreiben Sie einen Gästebucheintrag für Sigi.K

Beiträge: 4
Registriert: 09.09.2005

erstellt am: 12. Sep. 2005 15:41    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities


B_CAD_Fail.jpg

 
Hallo Herr Schultze,

ein Problem an meinem System kann ich mir eher nicht vorstellen.
Betriebssystem ist WIN-XP Professional 2002 SP2, 2,17GHz, 1GB RAM
Grafikkarte ist nVIDIA GForce4 MX440
Andere Grafik fressende Programme laufen ohne Probleme.

Nichts desto trotz, Hardwarebeschleunigung herunter gesetzt und auch ganz abgeschaltet.
Jeweils Programm zum Absturz gebracht. Siehe Bild (ich hoffe das klappt).

Das Problem liegt offensichtlich im Modell – Explorer, Aktualisierung der Ansicht.

Ich konnte wie folgt das Programm immer zum Absturz bringen:

Wir befinden uns im 3D Fenster, Modell – Explorer wird über Menü geöffnet,
eine bereits vorher definierte Gruppe im Modell – Explorer aus der Baumstruktur angewählt.
Dieses wird mit F12 aktiviert und nun auf DEL für löschen.
Gruppe verschwindet im 3D Fenster, in der Baumstruktur bleibt die Gruppe weiterhin sichtbar.

Wenn nun der Modell – Explorer über den X-Fenster geschlossen wird, dann kommt der Absturz mit „abnormal program termination“, Visual C++ Runtime Librarry.

Diesen Fehler kann ich beliebig oft wiederholen. Auch mit Beispiel BAD.MOD.
Auswählen des Waschbeckens, DEL – X – Fehler.

Umgekehrt beim Anlegen von „Neuen Gruppen“ gibt es auch ein Problem:
Geöffneter Modell – Explorer, anlegen einer neuen Gruppe mit rechter Maus – Neu - Gruppe.
Es wird keine neue Gruppe dargestellt!
Diese wird erst in der Baumstruktur dargestellt wenn der Modell – Explorer geschlossen wird und wieder neu geöffnet wird.
Nun kann ich der neuen Gruppe einen neuen Namen geben. Wird dieser mit F2 festgelegt und mit Enter bestätigt, steht aber wieder „neue Gruppe“ darin.
Gleiches Spielchen wie vorher, schließen öffnen, erst dann richtig in Baumstruktur mit geänderten Namen dargestellt.
Erst jetzt können Objekte eingefügt werden.

Auch wenn einzelne Gruppen aktiv- inaktiv, sichtbar oder unsichtbar geschalten werden, STRG+O / STRG+P.
Die Darstellung der Baumstruktur wird erst nach schließen und erneuten öffnen richtig dargestellt.

Ich kann mir nicht vorstellen, dass dies im Sinne des Programmierers war.

Ich würde sie bitten, dies mal so nach zu vollziehen.
Vielleicht können dies auch mal andere Anwender prüfen, vielleicht ist ja wirklich noch ein Problem an meiner Hardware.

MfG
Sigi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Sigi.K
Mitglied
Elektroniker

Sehen Sie sich das Profil von Sigi.K an!   Senden Sie eine Private Message an Sigi.K  Schreiben Sie einen Gästebucheintrag für Sigi.K

Beiträge: 4
Registriert: 09.09.2005

erstellt am: 13. Sep. 2005 08:11    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo nochmals,

nachdem die 10Tage Testversion und die Kaufsoftware im Handel gleich ist, habe ich die Testversion noch auf zwei weiteren Rechnern installiert.
Einer CAD Workstation unter WIN2000 und einem neuem Laptop unter WINXP Homeedition.

An beiden Rechnern kann ich den Fehler wie vorher beschrieben reproduzieren.
Ein Problem an der Hardware möchte ich damit ausgeschlossen haben.

Noch eine andere Fehlervariante:
Wir nehmen wieder Bad.MOD, öffnen den Modell Explorer und klicken Waschbecken an.
Nach DEL ist es in der Zeichnung auch weg, im Modellbaum aber nicht.
Klickt man im Modelbaum eine andere Gruppe an und dann wieder zurück
auf die noch angezeigte Gruppe Waschbecken – Absturz!

Es spielt dabei keine Rolle, ob man im 2D oder 3D Ansicht ist.

Würde mich sehr interessieren ob ich der einzige bin der diesen Fehler hat. 

Grüße,
Sigi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

fschultze
Moderator



Sehen Sie sich das Profil von fschultze an!   Senden Sie eine Private Message an fschultze  Schreiben Sie einen Gästebucheintrag für fschultze

Beiträge: 171
Registriert: 14.05.2002

erstellt am: 13. Sep. 2005 13:05    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Sigi.K 10 Unities + Antwort hilfreich


registerBeckerCAD4.zip

 
Hallo Sigi,
in der mir vorliegenden Vollversion von BeckerCAD 4 kann ich das nicht nachvollziehen, allerdings habe ich da so eine Idee, woran es liegen könnte. Dazu habe ich in den Dateianhang eine ZIP-Datei gehängt, in der sich die Datei registerBeckerCAD4.bat befindet. Diese in das Installations\Program\Bcad-Verzeichnis kopieren und diese BAT-Datei per Doppelklick oder über Start, Ausführen starten. Hierdurch werden dringend benötigte Windowsregistrierungen vorgenommen. Sollte es hiernach immer noch nicht funktionieren, bitte ich Sie, sich per Email an mich zu wenden. Bitte geben Sie hierbei auch Ihre Tel. Nr. an.
support@datasolid.de

MfG
Datasolid GmbH
Frank Schultze

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Sigi.K
Mitglied
Elektroniker

Sehen Sie sich das Profil von Sigi.K an!   Senden Sie eine Private Message an Sigi.K  Schreiben Sie einen Gästebucheintrag für Sigi.K

Beiträge: 4
Registriert: 09.09.2005

erstellt am: 13. Sep. 2005 14:36    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Herr Schultze,

BAT-Datei ausgeführt, einige Dateien wurden (neu) registriert.
Bei einer gab es eine Fehlermeldung: Dateien DIN66025.dll konnte nicht registriert werden.

Nichts desto trotzt: Nun funktioniert alles so wie es sein sollte!

Kein Absturz mehr und die Objekt Gruppen werden im Modell Explorer jetzt richtig dargestellt.
Also verstecken, aktivieren, hinzufügen und löschen.

Bestens!

Danke für die Unterstützung.
MfG
Sigi

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

fschultze
Moderator



Sehen Sie sich das Profil von fschultze an!   Senden Sie eine Private Message an fschultze  Schreiben Sie einen Gästebucheintrag für fschultze

Beiträge: 171
Registriert: 14.05.2002

erstellt am: 13. Sep. 2005 15:26    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Sigi.K 10 Unities + Antwort hilfreich


registerBeckerCAD4.zip

 
Hallo zusammen,
hier nochmals eine leicht geänderte Registrierungsdatei (registerBeckerCAD4.bat) im ZIP-Format. Damit ist es dann möglich, die benötigten Windows Registrierungen ohne Fehlermeldung durchführen zu können.

MfG

DataSolid GmbH
Frank Schultze

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz