Hot News:

Unser Angebot:

  Foren auf CAD.de (alle Foren)
  HTML/CSS/SSI/JavaScript
  Probleme mit Umlauten

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Probleme mit Umlauten (1223 mal gelesen)
Peter2
Ehrenmitglied V.I.P. h.c.




Sehen Sie sich das Profil von Peter2 an!   Senden Sie eine Private Message an Peter2  Schreiben Sie einen Gästebucheintrag für Peter2

Beiträge: 3374
Registriert: 15.10.2003

erstellt am: 01. Feb. 2012 16:11    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

In meiner lokalen HTML habe ich ein Bild so eingebunden:

Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html lang="de">
    <head>
        <meta name="generator" content="HTML Tidy for Windows (vers 12 April 2005), see www.w3.org">
        <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
        <title>
            Tippseite
        </title>
    </head>
    <body>
                        Problem: Beim Beenden taucht immer diese Abfrage auf:
                            <br>
                            <img alt="Hier fehlt ein Bild." title=
                            "Abfrage zum endgültigen Löschen des Ordners 'Gelöschte Objekte'" src=
                            "media/Outlook_L%C3%B6schen.png">
                            <br>
                            <cite>Lösung: Extras - Optionen - Weitere - Bei Programmbeendigung Ordner "Gelöschte
                            Objekte" leeren: Haken entfernen</cite>
                       
    </body>
</html>

Den HTML-Code hatte ich mit HTML-Tidy durchgearbeitet, die Datei ist als U8-DOS (laut UltraEdit) gespeichert.

Firefox kann das Bild darstellen, IE 8 nicht: der zeigt den "ALT-Text".
Warum?

Peter

------------------
Für jedes Problem gibt es eine einfache Lösung.
Die ist aber meistens falsch. ;-)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Cadzer
Mitglied
Architekt; Dozent


Sehen Sie sich das Profil von Cadzer an!   Senden Sie eine Private Message an Cadzer  Schreiben Sie einen Gästebucheintrag für Cadzer

Beiträge: 37
Registriert: 31.01.2004

aca 2013/2019

erstellt am: 01. Feb. 2012 16:27    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Peter2 10 Unities + Antwort hilfreich

Ich würde mal auf Umlaute im Dateinamen tippen … sollte man genauso wie Sonderzeichen und Leerzeichen vermeiden. Benenn das Bild in 'Outlook_Loeschen.png' oder etwas in der Art um und änder das src-Attribut entsprechend im Quellcode, dann sollte es laufen.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Peter2
Ehrenmitglied V.I.P. h.c.




Sehen Sie sich das Profil von Peter2 an!   Senden Sie eine Private Message an Peter2  Schreiben Sie einen Gästebucheintrag für Peter2

Beiträge: 3374
Registriert: 15.10.2003

erstellt am: 01. Feb. 2012 16:35    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Zitat:
Original erstellt von Cadzer:
Ich würde mal auf Umlaute im Dateinamen tippen ...

Das ist auch meine Vermutung, aber ich bin überrascht, dass der IE zwischen Umlauten im Text und Umlauten im Dateinamen unterscheidet.

Peter

------------------
Für jedes Problem gibt es eine einfache Lösung.
Die ist aber meistens falsch. ;-)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Cadzer
Mitglied
Architekt; Dozent


Sehen Sie sich das Profil von Cadzer an!   Senden Sie eine Private Message an Cadzer  Schreiben Sie einen Gästebucheintrag für Cadzer

Beiträge: 37
Registriert: 31.01.2004

aca 2013/2019

erstellt am: 01. Feb. 2012 17:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Peter2 10 Unities + Antwort hilfreich

Wenn das die einzige Überraschung wäre, die der IE bereithält… 
Ist aber ein Unterschied, ob es um Datei- bzw. Verzeichnisnamen oder Inhalte geht. Wo du auch aus der AutoCad-Ecke kommst, vergleich es einfach damit:
- Umlaute/Sonderzeichen/Leerzeichen in Texten = kein Problem
- Umlaute/Sonderzeichen/Leerzeichen in Namen (Block, Datei, Layer etc.) = gefährlich bis unmöglich

Also immer in Namen (Dateien, Verzeichnisse, Klassen, ID etc.) diese Zeichen vermeiden, dann wirst du nie drüber stolpern … da finden sich schönere Stolperfallen. 

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Peter2
Ehrenmitglied V.I.P. h.c.




Sehen Sie sich das Profil von Peter2 an!   Senden Sie eine Private Message an Peter2  Schreiben Sie einen Gästebucheintrag für Peter2

Beiträge: 3374
Registriert: 15.10.2003

erstellt am: 01. Feb. 2012 17:32    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Zitat:
Original erstellt von Cadzer:
...Also immer in Namen (Dateien, Verzeichnisse, Klassen, ID etc.) diese Zeichen vermeiden, dann wirst du nie drüber stolpern … da finden sich schönere Stolperfallen.  

Ich meide diese Dinger schon fast überall - jetzt auch hier.

Danke

Peter

------------------
Für jedes Problem gibt es eine einfache Lösung.
Die ist aber meistens falsch. ;-)

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz