Hot News:

Unser Angebot:

  Foren auf CAD.de (alle Foren)
  Linux
  Bootproblem mit gentoo

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Bootproblem mit gentoo (1433 mal gelesen)

Ex-Mitglied



Sehen Sie sich das Profil von  an!

Beiträge: 4755
Registriert: 27.09.2000

Dell precision M4300, 4GB Arbeitsspeicher
NVidia FX360M
Windows XP professional SP3
CATIA V5 R16SP9, R17SP8, R18SP8, R19SP6
Adobe Acrobat 8
Linux: Ubuntu 8.04LTS

erstellt am: 10. Feb. 2007 07:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen,

da ich mit der Aktualität meiner SuSE-Installation nicht mehr zufrieden bin, habe ich mir gentoo installiert. Vielversprechend scheint mir  das Portsystem zu sein, das "ewige" Updatemöglichkeiten versprechen zu scheint.

Beim ersten Bootversuch kam es dann zu einem Problem: Gentoo bootete nicht. Es bleibt nach der Erkennung der Wheelmouse hängen. ES bleibt nur noch der Griff zum Netzschalter - dem auf der Rückseite des PCs.

Leider habe ich keine Einträge in /var/log/boot.msg, so daß ich völlig in der Luft hänge, wo das Problem liegen könnte.

Habt ihr einen Tipp für mich?

Viele Grüße,

CEROG

------------------
Inoffizielle CATIA-HIlfeseite
CATIA-FAQ
Inoffizielle Linux-Hilfeseite

http://www.cad-gaenssler.de

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

adamsh
Mitglied
Forschung und Entwicklung


Sehen Sie sich das Profil von adamsh an!   Senden Sie eine Private Message an adamsh  Schreiben Sie einen Gästebucheintrag für adamsh

Beiträge: 842
Registriert: 27.05.2006

Halbwegs Systemadministration und -entwurf....

erstellt am: 10. Feb. 2007 09:57    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CEROG 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von CEROG:
Hallo zusammen,

da ich mit der Aktualität meiner SuSE-Installation nicht mehr zufrieden bin, habe ich mir gentoo installiert. Vielversprechend scheint mir  das Portsystem zu sein, das "ewige" Updatemöglichkeiten versprechen zu scheint.


Wie hast Du Gentoo installiert?

Level 1 (bootstrapping) oder Level 3 (precompiled)?


BTWBy the way (So nebenbei bemerkt): Gentoo laeuft hier produktiv fuer EAGLE... hervorragend!

Zitat:

Beim ersten Bootversuch kam es dann zu einem Problem: Gentoo bootete

Wo bleibt es stehen?  In der Initialisierung des X-Servers, oder schon beim Laden und Initialisiern des Kerns (=LINUX!)?



Zitat:

nicht. Es bleibt nach der Erkennung der Wheelmouse hängen. ES bleibt nur noch der Griff zum Netzschalter - dem auf der Rückseite des PCs.


Die denkbar schlechteste Loesung!

Zitat:

Leider habe ich keine Einträge in /var/log/boot.msg, so daß ich völlig in der Luft hänge, wo das Problem liegen könnte.



Naja, dann besorgt man sie sich halt anders...

Zitat:

Habt ihr einen Tipp für mich?

Viele Grüße,

CEROG


Ja, systematisch vorzugehen:

Im folgenden immer nur bis Singeluser-Mode booten, und dann in den Multiusermode von Hand gehen. NIEMALS versuchen eine GUI automatisch starten zu lassen... (in inittab kann man VIEL auskommentieren!, und "S" als default deklarieren!!!)

1) Man besorgt sich die precompiled-Installations-CD, und bootet diese....Man stripped den Rechner solange, bis Gentoo-Installationssystem hochkommt.


2) Die macht selbststaendig Hardwererkennung....Deshalb druckt man sich die Bootnachrichten auch aus, einschliesslich aller Meldungen des Kerns.... (dmesg!)

3) Man sagt: "lspci -vv", und druckt sich diese Ergebnisse aus.

4) Man installiert sich ein Gentoo-Kernsystem, und kompiliert einen Kern so, dass alle erkannten Geraete im Kern unterstuetzt werden, ABER nur diese.

5) Man bootet diesen Kern. Kommt er hoch, wunderbar, ansonsten zurueck zu 2).

6) Soweit erforderlich, schliest man immer neue Hardware an, und bootet den jetzt aktuell gebauten Kern.

7) Kommt der aktuelle Kern, mit der ggf. noch nicht erkannten neuen Hardware hoch, wunderbar, ansonsten wird es zumindest schwierig...

8) Man baut einen Kern mit  der Unterstuetzung der neu dazugekommenen Hardware... Funktioniert dieser, wunderbar, ansonsten, Hardware heraus, als nicht tauglich deklarieren und aussortieren, und bei 6) weitermachen...

9) Irgendwann sollte man einen Kern haben, der die meiste der erkannten HArdware auch tatsaechlich unterstuetzt...

10) Jetzt geht es an den X-Server:

Nach 9) sollte der erforderliche HArdwaresupport fuer die GraKas in den Kern kompiliert worden sein (NVIDIA!!!!).

Jetzt man das das base-X-Paket....

11) Man startet X nur zur Probe:

"startx -- -probeonly"  (in aller Schoenheit...)

Kommt das ohne Fehler hoch, dann kann man die GUI starten, z.B. indem man den geiegneten Runlevel aufruft, siehe inittab.

Kommt das mit Fehlern hoch, so hat man Xerr.*.log, und macht folgendes

"startx -- -probeonly 2>&1 >> /tmp/XStartversuch.log",

dann hat man die Bildschirmausgaben...

Die musz man sich dann allerdings genauestens angucken, da kann ich Dir keine Tips geben....

12) Einen laufenden, minimalen X-Server vorausgesetzt, musz man jetzt die zusaetzliche Hardware, wie z.B. Diene Scrollmouse ggf. noch integrieren.....

See also: (;-))

man boot, man bootparam, man X, man Xerver, man lspci, man lilo, man lilo.conf, man init, man inittab

mfg HA

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied



Sehen Sie sich das Profil von  an!

Beiträge: 4755
Registriert: 27.09.2000

Dell precision M4300, 4GB Arbeitsspeicher
NVidia FX360M
Windows XP professional SP3
CATIA V5 R16SP9, R17SP8, R18SP8, R19SP6
Adobe Acrobat 8
Linux: Ubuntu 8.04LTS

erstellt am: 10. Feb. 2007 18:04    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CEROG 10 Unities + Antwort hilfreich

HAllo zusammen,

ich habe gentoo installiert, in dem ich stage3-i586-2006.0.tar.bz2 runtergeladen und ins Verzeichnis /mnt/gentoo/ ausgepackt habe. Dorthin habe ich vorher die Partition /dev/hda1 gemountet

Danach habe ich einen Kernel gebaut gemäß Anweisung in einer CHROOT-Umgebung gebaut und die gewünschte Software installiert.

Es stellt sich für mich nicht die Frage, ob ich im Textmodus hochfahre oder gleich den X-Server starte - soweit komme ich gar nicht.

Der Bootprozeß bleibt schon während der Hardwareerkennung stehen.

Da SuSe läuft, gehe ich davon aus, daß es sich nicht um ein hardware-Problem handelt


Viele Grüße,

CEROG

------------------
Inoffizielle CATIA-HIlfeseite
CATIA-FAQ
Inoffizielle Linux-Hilfeseite

http://www.cad-gaenssler.de

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

adamsh
Mitglied
Forschung und Entwicklung


Sehen Sie sich das Profil von adamsh an!   Senden Sie eine Private Message an adamsh  Schreiben Sie einen Gästebucheintrag für adamsh

Beiträge: 842
Registriert: 27.05.2006

Halbwegs Systemadministration und -entwurf....

erstellt am: 10. Feb. 2007 21:03    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CEROG 10 Unities + Antwort hilfreich

Zitat:
Original erstellt von CEROG:
HAllo zusammen,

ich habe gentoo installiert, in dem ich stage3-i586-2006.0.tar.bz2 runtergeladen und ins Verzeichnis /mnt/gentoo/ ausgepackt habe. Dorthin habe ich vorher die Partition /dev/hda1 gemountet

Danach habe ich einen Kernel gebaut gemäß Anweisung in einer CHROOT-Umgebung gebaut und die gewünschte Software installiert.

Es stellt sich für mich nicht die Frage, ob ich im Textmodus hochfahre oder gleich den X-Server starte - soweit komme ich gar nicht.

Der Bootprozeß bleibt schon während der Hardwareerkennung stehen.

Da SuSe läuft, gehe ich davon aus, daß es sich nicht um ein hardware-Problem handelt


Viele Grüße,

CEROG


O.K.

1) Du hast die precompiled-Version benutzt....Augenscheinlihc laueft der mitgelieferte Kern ja. Du hast einen Fehler beim Bauen des kerns gemacht.

2) Jetzt muszt Du Dir genau dioe Fehlermeldungen angucken,
2a) Schaue in "man bootparam" nach, mit welchen Optionen du ein Minimal-System booten kannst...

Wahrscheinlich hast Du ZUVIELE Geraetetreiber aktiviert....
Halte Dich an meine Kurzanleitung, sollte auch bei Dir klappen...

mfg HA

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied



Sehen Sie sich das Profil von  an!

Beiträge: 4755
Registriert: 27.09.2000

Dell precision M4300, 4GB Arbeitsspeicher
NVidia FX360M
Windows XP professional SP3
CATIA V5 R16SP9, R17SP8, R18SP8, R19SP6
Adobe Acrobat 8
Linux: Ubuntu 8.04LTS

erstellt am: 11. Feb. 2007 10:56    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CEROG 10 Unities + Antwort hilfreich

Hallo adamsh,

dann werde ich mal wieder ans Kernel-Backen gehen.

Viele Grüße,

CEROG

------------------
Inoffizielle CATIA-HIlfeseite
CATIA-FAQ
Inoffizielle Linux-Hilfeseite

http://www.cad-gaenssler.de

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

predy
Mitglied
Industriedesigner


Sehen Sie sich das Profil von predy an!   Senden Sie eine Private Message an predy  Schreiben Sie einen Gästebucheintrag für predy

Beiträge: 777
Registriert: 05.07.2003

Gentoo Linux 2.6.17-gentoo-r7
CAD: CATIA V5

erstellt am: 12. Feb. 2007 22:33    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CEROG 10 Unities + Antwort hilfreich

hallo zusammen,
@CEROG,

zunächst freut es mich, dass du dich nun für gentoo entschieden hast...jedoch ist es bedauerlich, dass du gleich zu anfang solche "hässliche" probleme hast.

Bei dieser art von "hängen bleiben" könnte es viele ursachen haben...ist es ein richtiger "kernel panic", oder bleibt die kiste einfach nur stehen?

Kommst du auf ner anderen konsole mit "ALT+F2 oder "Strg+ALT-F2" ? Wenn ja, dann kannst du die die logs dort anschauen.

Ich habe bisher meine gentoo immer nur mit stage 2 gebaut, und kann zu stage 3 nicht viel sagen. Aber ich denke du bist strickt nach handbuch vorgegangen...
http://www.gentoo.de/doc/de/handbook/handbook-x86.xml?full=1#book_part1_chap2

Ich würde jedoch mit der fehlersuche nicht unnötig viel zeit verlieren und das system frisch aufsetzten (unter berücksichtigung  der tipps von adamsh)

Ich hatte glaub ich damals auch ein, zwei anläufe gebraucht, bis ich die installationsprozedur so richtig verstanden habe...

Ach ja, da fällt mir noch was ein: Wie hast du den kernel kompiliert? Mit genkernel oder klassich?

Viel glück und berichte weiter 

gruss

predy

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied



Sehen Sie sich das Profil von  an!

Beiträge: 4755
Registriert: 27.09.2000

Dell precision M4300, 4GB Arbeitsspeicher
NVidia FX360M
Windows XP professional SP3
CATIA V5 R16SP9, R17SP8, R18SP8, R19SP6
Adobe Acrobat 8
Linux: Ubuntu 8.04LTS

erstellt am: 13. Feb. 2007 06:40    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CEROG 10 Unities + Antwort hilfreich

Hallo zusammen,

@predy:
Ich habe den Kernel klassisch kompiliert.
Letztes Wochenende hab ich nochmal nen Kernel kompiliert. Leider konnte ich den noch nicht testen.

Wenn das nicht klappt, versuche ich es mit genkernel. Klappt das auch nicht, so gibt es ja andere Distributionen...

Leider hab ich nicht so viel Zeit, da ich geschäftlich ziemlich viel auf Tour bin.

Viele Grüße,

CEROG

------------------
Inoffizielle CATIA-HIlfeseite
CATIA-FAQ
Inoffizielle Linux-Hilfeseite

http://www.cad-gaenssler.de

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

predy
Mitglied
Industriedesigner


Sehen Sie sich das Profil von predy an!   Senden Sie eine Private Message an predy  Schreiben Sie einen Gästebucheintrag für predy

Beiträge: 777
Registriert: 05.07.2003

Gentoo Linux 2.6.17-gentoo-r7
CAD: CATIA V5

erstellt am: 13. Feb. 2007 11:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CEROG 10 Unities + Antwort hilfreich

Hallo CEROG,

Zitat:
Original erstellt von CEROG:

Wenn das nicht klappt, versuche ich es mit genkernel. Klappt das auch nicht, so gibt es ja andere Distributionen...

[/B]



....such dir eine aus:
http://distrowatch.com/


gruss

predy

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied



Sehen Sie sich das Profil von  an!

Beiträge: 4755
Registriert: 27.09.2000

Dell precision M4300, 4GB Arbeitsspeicher
NVidia FX360M
Windows XP professional SP3
CATIA V5 R16SP9, R17SP8, R18SP8, R19SP6
Adobe Acrobat 8
Linux: Ubuntu 8.04LTS

erstellt am: 17. Feb. 2007 13:47    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CEROG 10 Unities + Antwort hilfreich

Hallo zusammen,

nach meinem Versuch mit genkernel bin ich etwas weiter gekommen - wenn ich auch nicht weiß, wo ich gelandet bin. Vermutlich im initramfs. Die bereits kompilierten Anwendungen wie VIM standen nicht zur Verfügung.

Ich bin also auf dem richtigen Weg...

Viele Grüße,

CEROG

------------------
Inoffizielle CATIA-HIlfeseite
CATIA-FAQ
Inoffizielle Linux-Hilfeseite

http://www.cad-gaenssler.de

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

predy
Mitglied
Industriedesigner


Sehen Sie sich das Profil von predy an!   Senden Sie eine Private Message an predy  Schreiben Sie einen Gästebucheintrag für predy

Beiträge: 777
Registriert: 05.07.2003

Gentoo Linux 2.6.17-gentoo-r7
CAD: CATIA V5

erstellt am: 17. Feb. 2007 22:31    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CEROG 10 Unities + Antwort hilfreich

hallo CEROG,

das hört sich doch schon mal gut an...positiv denken, und durchhalten 


gruss

predy

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

predy
Mitglied
Industriedesigner


Sehen Sie sich das Profil von predy an!   Senden Sie eine Private Message an predy  Schreiben Sie einen Gästebucheintrag für predy

Beiträge: 777
Registriert: 05.07.2003

Gentoo Linux 2.6.17-gentoo-r7
CAD: CATIA V5

erstellt am: 20. Feb. 2007 23:06    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CEROG 10 Unities + Antwort hilfreich

hallo CEROG,

es könnte aber am kernel alles in ordnung sein und es liegt am boot-eintrag in grub (ich gehe mal davon aus, du hast grub verwendet)

Wie sieht den der boot-eintrag bei dir aus ?

hier als Beispiel meiner:

Code:
# For booting GNU/Linux
title  Gentoo Linux 2.6.17-r7
root (hd0,1)
kernel (hd0,1)/kernel-genkernel-x86-2.6.17-gentoo-r7 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda5 udev vga=791 splash=silent
initrd (hd0,1)/initramfs-genkernel-x86-2.6.17-gentoo-r7

evtl. hilft dir das weiter....

gruss

predy

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP


Ex-Mitglied



Sehen Sie sich das Profil von  an!

Beiträge: 4755
Registriert: 27.09.2000

Dell precision M4300, 4GB Arbeitsspeicher
NVidia FX360M
Windows XP professional SP3
CATIA V5 R16SP9, R17SP8, R18SP8, R19SP6
Adobe Acrobat 8
Linux: Ubuntu 8.04LTS

erstellt am: 21. Feb. 2007 05:46    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CEROG 10 Unities + Antwort hilfreich

Hallo zusammen,

@predy:
Bei mir läuft lilo als Bootloader. Und solange ich damit keine Probleme habe, wird lilo weiterlaufen...

Viele Grüße,

CEROG

------------------
Inoffizielle CATIA-HIlfeseite
CATIA-FAQ
Inoffizielle Linux-Hilfeseite

http://www.cad-gaenssler.de

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

predy
Mitglied
Industriedesigner


Sehen Sie sich das Profil von predy an!   Senden Sie eine Private Message an predy  Schreiben Sie einen Gästebucheintrag für predy

Beiträge: 777
Registriert: 05.07.2003

Gentoo Linux 2.6.17-gentoo-r7
CAD: CATIA V5

erstellt am: 21. Feb. 2007 16:48    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für CEROG 10 Unities + Antwort hilfreich

ok..dann fängst du mit dem grub-eintrag nicht unbedingt was an 

war nur so ne idee...ich hatte damals probleme dass mein kernel nicht starten wollte, weil er schlichtweg nicht gefunden wurde....


gruss

predy

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz