Hot News:

Unser Angebot:

  Foren auf CAD.de (alle Foren)
  Excel
  Betriebsmittelliste erstellen

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Betriebsmittelliste erstellen (1311 mal gelesen)
HKXVZBi
Mitglied
Konstruktion Elektroplanung


Sehen Sie sich das Profil von HKXVZBi an!   Senden Sie eine Private Message an HKXVZBi  Schreiben Sie einen Gästebucheintrag für HKXVZBi

Beiträge: 1378
Registriert: 27.01.2010

erstellt am: 25. Mrz. 2013 11:28    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen ich habe folgendes Problem
in einer Bedienstellenliste befinden sich zwei Spalten

Spalte A enthält eine Nr. die immer gleich aufgebaut ist XX.XX
Spalte B enthält den Schalter Typ IPB, IL ,MBP oder PB usw.

aus diesen beiden Spalten ergibt sich das spätere BMK
hier mal ein paar Bsp.

21.16 IPB wird zu =F21.L04-SH21.16
02.20 MPB wird zu =CF02.L04-S02.20
08.35 IL  wird zu =F08.L05-H08.35


die vorderen Teil der Nummer findet man im BMK (Anlagenkennzeichen) wieder
21.16 -> =F21.L04-SH21.16
02.20 -> =CF02.L04-S02.20
08.35 -> =F08.L05-H08.35


zusätzlich wird nochmal die ganze Nummer angegeben
21.16 IPB -> =F21.L04-SH21.16
02.20 MPB -> =CF02.L04-S02.20
08.35 IL  -> =F08.L05-H08.35


die zweite Spalte legt u.a. Fest wie das Anlagenkennzeichen (also der teil hinter dem =)aufgebaut wird und hier gibt es mehrere Bedingungen

21.16 IPB -> =F21.L04-SH21.16
02.20 MPB -> =CF02.L04-S02.20
08.35 IL  -> =F08.L05-H08.35
-> wenn in der 2 Spalte MPB steht muss hinter dem "=" CF stehen sonst F


21.16 IPB -> =F21.L04-SH21.16
02.20 MPB -> =CF02.L04-S02.20
08.35 IL  -> =F08.L05-H08.35
-> wenn in der 2 Spalte IL steht muss hinter dem ersten "." L05 stehen sonst L04


21.16 IPB -> =F21.L04-SH21.16
02.20 MPB -> =CF02.bL04-S02.20
08.35 IL  -> =F08.L05-H08.35
-> zusatzlich wird der Kennbuchstabe bestimmt
bei IL - ist es H
bei IPB - ist es SH
sonst immer S

kann man so etwas ohne VBA Programmierung umsetzten allein durch Formeln?


------------------
Gruß 
Marco

---------------------------------
Es gibt Dinge im Leben die kommen und gehen, aber Ruhm und Fitness bleiben einem für immer erhalten!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Paulchen
Mitglied
Bauing./SW-Entwickler


Sehen Sie sich das Profil von Paulchen an!   Senden Sie eine Private Message an Paulchen  Schreiben Sie einen Gästebucheintrag für Paulchen

Beiträge: 1227
Registriert: 19.08.2004

Büro: Win10 Enterprise 64bit, Office Professional Plus 2013 - Privat: Linux Mint 15, LibreOffice

erstellt am: 25. Mrz. 2013 13:17    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für HKXVZBi 10 Unities + Antwort hilfreich

Hi,

ja, kann man (auf den ersten Blick jedenfalls).

Ein bisschen WENN-Schachtel, Textfunktionen wie LINKS, RECHTS und TEIL, sowie das kaufmännische "&" (und) zum Verknüpfen von Zeichenketten.

Ggf. Strings in Hilfsspalten einschlichten zum Zwischenlagern, anschließend ausblenden.

Mappe  ?

------------------
DIN1055.de  |  Lastannahmen für Anwender

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

HKXVZBi
Mitglied
Konstruktion Elektroplanung


Sehen Sie sich das Profil von HKXVZBi an!   Senden Sie eine Private Message an HKXVZBi  Schreiben Sie einen Gästebucheintrag für HKXVZBi

Beiträge: 1378
Registriert: 27.01.2010

erstellt am: 25. Mrz. 2013 15:49    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

danke für den hinwies hab mir das jetzt aufgeteilt in verschiedene spalten in denen ich die einzelnen Bereiche jeweils in eine Spalte schreibe und dies am ende zusammenfüge
ausserdem wurden die Bedienungen noch etwas geändert

Spalte O '=
Spalte P =WENN(ZÄHLENWENN(G52;"*EMERGENCY STOP*")=1;"CF";"F")
Spalte Q =(E52)
Spalte R =WENN(ZÄHLENWENN(H52;"*IL*");".L05";".L04")
Spalte S =WENN(ZÄHLENWENN(H52;"*IL*");"-H";WENN(ZÄHLENWENN(H52;"*IPB*");"-SH";"-S"))
Spalte T =N52
---------------------------
Spalte U ==O52&P52&Q52&R52&S52&T52

------------------
Gruß 
Marco

---------------------------------
Es gibt Dinge im Leben die kommen und gehen, aber Ruhm und Fitness bleiben einem für immer erhalten!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

HKXVZBi
Mitglied
Konstruktion Elektroplanung


Sehen Sie sich das Profil von HKXVZBi an!   Senden Sie eine Private Message an HKXVZBi  Schreiben Sie einen Gästebucheintrag für HKXVZBi

Beiträge: 1378
Registriert: 27.01.2010

i7-3770 3.40GHz, 8192MB RAM
Radeon Pro WX5100
3xHP Z24i
Software:
MS Win 10 64Bit
MS Office 2010
------
ePlan 5: 5.70
ePlan Electric P8
Menüumfang: ǝʇɹǝdxǝ

erstellt am: 27. Mrz. 2013 07:18    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

jetzt bin ich auf ein weiteres Problem gestoßen mit der Funktion

=WENN(ZÄHLENWENN(G66;"*EMERGENCY STOP*");"CF";WENN(ZÄHLENWENN(F66;"*EMERGENCY STOP*");"CF";"F"))


denn dies scheint nicht die einzige Bedingung zu sein, zusätzlich muss in der Spalte H das Kürzel MPB auftauchen damit CF gewählt wird
sonst halt nur F auf welche weise kann man diese Bedingung mit einfließen lassen?   


EDIT
ich glaub jetzt hab ich die Lösung

=WENN(UND(ZÄHLENWENN(G66;"*EMERGENCY STOP*");ZÄHLENWENN(H66;"*MPB*"));"CF";WENN(UND(ZÄHLENWENN(F66;"*EMERGENCY STOP*");ZÄHLENWENN(H66;"*MPB*"));"CF";"F"))


------------------
Gruß   
Marco

---------------------------------
Es gibt Dinge im Leben die kommen und gehen, aber Ruhm und Fitness bleiben einem für immer erhalten!

[Diese Nachricht wurde von HKXVZBi am 27. Mrz. 2013 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Paulchen
Mitglied
Bauing./SW-Entwickler


Sehen Sie sich das Profil von Paulchen an!   Senden Sie eine Private Message an Paulchen  Schreiben Sie einen Gästebucheintrag für Paulchen

Beiträge: 1227
Registriert: 19.08.2004

Büro: Win10 Enterprise 64bit, Office Professional Plus 2013 - Privat: Linux Mint 15, LibreOffice

erstellt am: 27. Mrz. 2013 11:04    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für HKXVZBi 10 Unities + Antwort hilfreich

Hi,
ohne mich vertieft in die Formel einzufuchsen: Ein Vergleich nach =WENN(A123="Text";DIES;DAS) wäre - auch für spätere Wartungen - übersichtlicher als das zwischengeschaltete ZÄHLENWENN? Geschmackssache.

------------------
DIN1055.de  |  Lastannahmen für Anwender

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz