Hot News:

Unser Angebot:

  Foren auf CAD.de (alle Foren)
  Excel
  wenn funktion mit gerade / ungerade werten

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   wenn funktion mit gerade / ungerade werten (4883 mal gelesen)
pepe2003
Mitglied
Dipl.-Ing. Maschinenbau (Konstruktion)


Sehen Sie sich das Profil von pepe2003 an!   Senden Sie eine Private Message an pepe2003  Schreiben Sie einen Gästebucheintrag für pepe2003

Beiträge: 315
Registriert: 11.06.2003

erstellt am: 20. Okt. 2009 07:41    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Tach,

ich such eine funktion die folgendes kann:

wenn "abfragewert" = ein UNGERDER wert ist dann rechne  "abfragewert + x"
sonst / wenn "abfragewert" = ein GERADER wert ist dann rechne "abfrgewert + y"

vielen danke vorab!

lars

------------------
Win XPProf. Vers. 2002, SP2, Solid Edge V19.00.04.06, P4 CPU 3,2GHz
2,5 GB RAM

______________________________________________
Mein Freund ist Sauerländer...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

runkelruebe
Moderator
Straßen- / Tiefbau




Sehen Sie sich das Profil von runkelruebe an!   Senden Sie eine Private Message an runkelruebe  Schreiben Sie einen Gästebucheintrag für runkelruebe

Beiträge: 8017
Registriert: 09.03.2006

MS-Office 365 ProPlus x86
WIN7(x64)

erstellt am: 20. Okt. 2009 08:09    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für pepe2003 10 Unities + Antwort hilfreich

Moin,
Du könntest die =REST() Funktion verwenden.
Beispiel:
=WENN(REST(A1;2)>0;A1+X-WERT;A1+Y-WERT)

Edit: Umstand, Dein Name ist rübe 
Excel kennt auch die Funktion =ISTGERADE() 

------------------
Gruß,
runkelruebe          Herr Kann-ich-nich wohnt in der Will-ich-nich-Straße...

System-Info | Excel -Suche | RuA-Suche | FAQ-ACAD | CAD.de-Hilfe | Sei eine Antilope

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

pepe2003
Mitglied
Dipl.-Ing. Maschinenbau (Konstruktion)


Sehen Sie sich das Profil von pepe2003 an!   Senden Sie eine Private Message an pepe2003  Schreiben Sie einen Gästebucheintrag für pepe2003

Beiträge: 315
Registriert: 11.06.2003

erstellt am: 20. Okt. 2009 09:20    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

danke runkelrübe!

damit kann ich was anfangen !!!

Gruss
lars

------------------
Win XPProf. Vers. 2002, SP2, Solid Edge V19.00.04.06, P4 CPU 3,2GHz
2,5 GB RAM

______________________________________________
Mein Freund ist Sauerländer...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Thomas Harmening
Moderator
Arbeiter ツ




Sehen Sie sich das Profil von Thomas Harmening an!   Senden Sie eine Private Message an Thomas Harmening  Schreiben Sie einen Gästebucheintrag für Thomas Harmening

Beiträge: 2896
Registriert: 06.07.2001

Das Innerste geäussert
und aufs Äusserste verinnerlicht

erstellt am: 20. Okt. 2009 12:52    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für pepe2003 10 Unities + Antwort hilfreich

und ohne =Wenn()

Code:
=SUMMENPRODUKT((NICHT(ISTGERADE(A1))*(A1+WERTX))+(ISTGERADE(A1)*(A1+WERTY)))

WERTX und WERTY sind benamste Zellen

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

pepe2003
Mitglied
Dipl.-Ing. Maschinenbau (Konstruktion)


Sehen Sie sich das Profil von pepe2003 an!   Senden Sie eine Private Message an pepe2003  Schreiben Sie einen Gästebucheintrag für pepe2003

Beiträge: 315
Registriert: 11.06.2003

erstellt am: 20. Okt. 2009 13:31    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

danke auch dir thomas!

hier werd deine formel auch noch testen!

gruss
lars

------------------
Win XPProf. Vers. 2002, SP2, Solid Edge V19.00.04.06, P4 CPU 3,2GHz
2,5 GB RAM

______________________________________________
Mein Freund ist Sauerländer...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz