Hot News:

Unser Angebot:

  Foren auf CAD.de (alle Foren)
  Excel
  Grenzwerteingabe

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   Grenzwerteingabe (1278 mal gelesen)
Stefan67
Mitglied
Maschinenbau Techniker


Sehen Sie sich das Profil von Stefan67 an!   Senden Sie eine Private Message an Stefan67  Schreiben Sie einen Gästebucheintrag für Stefan67

Beiträge: 64
Registriert: 26.11.2004

HP nw9440, 1 GB RAM,
2,16 Centino Duo T2600, nVidia FX 1500M - 256 MB
SW2007-08-09 , AutoCAD LT2000, WIN XP SP2

erstellt am: 18. Mai. 2009 10:36    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hi Leute,
da ich n totaler Anfänger in Sachen Excel bin weis ich noc nicht mal nachwas ich suchen soll.
Deshalb meine Frage:

Ich will die Eingabe in einer Zelle auf einen besimmten Zahlenbereich begrenzen und dann den Wert auf 5 runden. Geht das?
z.B  min=125;max=1000 EINGABE 723 ergibt 720/ EINGABE 1255 ergibt FEHLER

Danke schon mal Stefan

PS:Arbeite mit 2003

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

carsten-3m
Mitglied
Dipl.-Ing. Mbau (Produktmanagement, Patent- und Normwesen)


Sehen Sie sich das Profil von carsten-3m an!   Senden Sie eine Private Message an carsten-3m  Schreiben Sie einen Gästebucheintrag für carsten-3m

Beiträge: 950
Registriert: 08.05.2007

Excel 2010

erstellt am: 18. Mai. 2009 10:55    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Stefan67 10 Unities + Antwort hilfreich

Grundsätzliches:
In einer Excelzelle kann entweder ein Wert stehen (Wert nach Exceljargon: Also z. B. eine Zahl oder ein Text) oder eine Formel (Also ein Konstrukt von Befehlen, das einen oder mehrere Werte zur Hand nimmt, um daraus etwas zu berechnen. Das Ergebnis dieser Berechnung steht in der Formelzelle).

Das gesagt, wirst Du eine Eingabezelle (im Beispiel A1) und eine Berechnungszelle (z. B. B1) benötigen. In letzterer könnte z. B. stehen:

Code:
=WENN(ODER(A1<125;A1>1000)=WAHR;"Fehler";RUNDEN(A1;-1))

------------------
Seit Pro/E Version 1 dabei, auwei...

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Paulchen
Mitglied
Bauing./SW-Entwickler


Sehen Sie sich das Profil von Paulchen an!   Senden Sie eine Private Message an Paulchen  Schreiben Sie einen Gästebucheintrag für Paulchen

Beiträge: 1227
Registriert: 19.08.2004

Büro: Win10 Enterprise 64bit, Office Professional Plus 2013 - Privat: Linux Mint 15, LibreOffice

erstellt am: 18. Mai. 2009 10:57    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Stefan67 10 Unities + Antwort hilfreich

Hallo Stefan67,

das geht in zwei Schritten.

1. Eingabe
Daten-Gültigkeit (oder auch Datenüberprüfung): Benuzterdefiniert - Formel: =UND(ZELLEfürEINGABE>=125;ZELLEfürEINGABE<=1000)

2. Runden - siehe hier =RUNDEN(DEINEZAHL/5;0)*5

------------------
DIN1055.de  |  Lastannahmen für Anwender NEU: Foren zu DIN 1055

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Headcase
Mitglied
Dipl.-Ing. (FH) --> Maschinenbau


Sehen Sie sich das Profil von Headcase an!   Senden Sie eine Private Message an Headcase  Schreiben Sie einen Gästebucheintrag für Headcase

Beiträge: 141
Registriert: 14.10.2004

WinXP Prof.// SP3
Excel 2003 // SP3

erstellt am: 18. Mai. 2009 11:00    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Stefan67 10 Unities + Antwort hilfreich

Hallo,

also die Wertebegrenzung kannst du über ein benutzerdefiniertes Format regeln:
Zellen formatieren-->Reiter Zahlen-->Kategorie Benutzerdefiniert--> dort folgendes eintragen:

[<125]"Fehler";[>1000]"Fehler";Standard

Zum Runden fällt mir für die Zelle direkt nichts ein, nur über Formel in zweiter Zelle:
=VRUNDEN(A3;5)

Grüße!
René

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Stefan67
Mitglied
Maschinenbau Techniker


Sehen Sie sich das Profil von Stefan67 an!   Senden Sie eine Private Message an Stefan67  Schreiben Sie einen Gästebucheintrag für Stefan67

Beiträge: 64
Registriert: 26.11.2004

HP nw9440, 1 GB RAM,
2,16 Centino Duo T2600, nVidia FX 1500M - 256 MB
SW2007-08-09 , AutoCAD LT2000, WIN XP SP2

erstellt am: 18. Mai. 2009 12:23    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Danke Leute,
hab ne kompination aus der Lösung von heascase und Paulchen gewählt.
Funzt super

Bis den Stefan

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz