Hot News:

Mit Unterstützung durch:

  Foren auf CAD.de (alle Foren)
  NX CAM Programmierung
  Probelm bei Freiformflächen

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
  
Gut zu wissen: Hilfreiche Tipps und Tricks aus der Praxis prägnant, und auf den Punkt gebracht für NX
Autor Thema:  Probelm bei Freiformflächen (2599 mal gelesen)
Knuto
Mitglied


Sehen Sie sich das Profil von Knuto an!   Senden Sie eine Private Message an Knuto  Schreiben Sie einen Gästebucheintrag für Knuto

Beiträge: 5
Registriert: 21.03.2011

erstellt am: 22. Mrz. 2011 16:59    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo zusammen,

habe das Problem schon im Heidenhain Bereich gepostet und wurde von dort hierher verwiesen.

Ich habe ein Problem mit dem Fräsen einer Freiformfläche.
Das Programm wird mittels NX auf eine Hermle B300 mit iTNC 530 übertragen.
In der Vorschau innerhalb von NX läuft das Programm auch wunderbar ab.

Das Problem ist folgendes:
Beim 5- Achs- Fräsen von Freiformflächen fängt der Fräser an zu "tanzen".
Mitten auf dem Werkstück fährt die Maschine auf einmal nicht mehr direkt weiter, sondern dreht das Werkstück erst ein paar mal unter dem Fräser, so dass es richtig schöne Abdrücke gibt, bevor es dann wieder ganz normal weiter geht.
Die Bewegungen stehen allerdings auch so im NC- Programm, werden also nicht "spontan von der Maschine erfunden".
Sieht im Prinzip ein wenig wie Polstellenproblematik aus...
Vl. der Postprozessor (der ist allerdings genau für die Hermle)?

Ich wäre schon dankbar, wenn jemand einen Vorschlag zur Ursache des Problems hätte...

Gruß

Knuto

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Walter Hogger
Moderator
Maschinenbauingenieur


Sehen Sie sich das Profil von Walter Hogger an!   Senden Sie eine Private Message an Walter Hogger  Schreiben Sie einen Gästebucheintrag für Walter Hogger

Beiträge: 3686
Registriert: 06.10.2000

UG V2 bis V18
NX1 bis NX1953 ("NX17")
Windows (UNIX, Linux)

erstellt am: 22. Mrz. 2011 17:16    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Knuto 10 Unities + Antwort hilfreich

Hallo Knuto,

nachdem ich früher mehrere Jahre 5-Achsen-Postprozessoeren geschrieben habe würde ich sagen, das ist ein Fehler im Postprozessor.

Bei 5-Achs-Maschinen kommt manchmal noch das Problem dazu, dass praktisch jede Fräserstellung auf zwei Arten erreicht werden kann (z.B. A-Achse 0 Grad, B-Achse 45 Grad oder A-Achse 180 Grad und B-Achse -45 Grad). Manche Maschinen schalten etwas willkürlich von der einen Variante zur anderen um. Ich kann mich dumpf erinnern, dass es ein Sprachwort gab, das dieses Verhalten ausgeschaltet hat.

Aber meld mal erst den Fehler bei deinem PP-Lieferanten.

Gruß

------------------
Walter Hogger

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Knuto
Mitglied


Sehen Sie sich das Profil von Knuto an!   Senden Sie eine Private Message an Knuto  Schreiben Sie einen Gästebucheintrag für Knuto

Beiträge: 5
Registriert: 21.03.2011

erstellt am: 23. Mrz. 2011 07:58    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Also vermutlich tatsächlich der PP...

Besten Dank!

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Schrottkiste
Mitglied
CAM Programmierer, Zerspaner


Sehen Sie sich das Profil von Schrottkiste an!   Senden Sie eine Private Message an Schrottkiste  Schreiben Sie einen Gästebucheintrag für Schrottkiste

Beiträge: 138
Registriert: 08.11.2006

NX4 CAD/CAM
NX5 CAD/CAM
NX6 CAD/CAM

erstellt am: 09. Apr. 2011 08:51    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für Knuto 10 Unities + Antwort hilfreich

nimm mal die Option "Glätten" das kann schon helfen... und auch die Innen/Aussentoleranz nicht so riesig lassen.

Beim Schlichten stell ich die Toleranz gerne auf 2µ und in der Steuerung Zyklus 32 doppelt bis anderthalbfach so groß wie im CAM.

wenn du Heidenhainvektoren bei 5Achsen Simultan verwendest spielt es auch eine Rolle wieviele Nachkommastellen der PP ausgibt.
Bei mir sind es 7 Nachkommastellen... läuft absolut ohne ruckeln.

Grüße

------------------
Fehler vermeidet man indem man Erfahrung sammelt, Erfahrung sammelt man indem man Fehler macht

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2021 CAD.de | Impressum | Datenschutz