Hot News:

Unser Angebot:

  Foren auf CAD.de (alle Foren)
  UNIX
  mksysb klappt nicht

Antwort erstellen  Neues Thema erstellen
CAD.de Login | Logout | Profil | Profil bearbeiten | Registrieren | Voreinstellungen | Hilfe | Suchen

Anzeige:

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen nächster neuer Beitrag | nächster älterer Beitrag
Autor Thema:   mksysb klappt nicht (2544 mal gelesen)
TimoSchwaar
Mitglied
Kfz.-Ingenieur


Sehen Sie sich das Profil von TimoSchwaar an!   Senden Sie eine Private Message an TimoSchwaar  Schreiben Sie einen Gästebucheintrag für TimoSchwaar

Beiträge: 128
Registriert: 01.12.2000

erstellt am: 24. Apr. 2007 12:15    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Leutes,

ich versuche hier eine Systemsicherung einer 275er IBM. Leider bekomme ich das mksysb nicht so richtig zum Laufen.
Platz ist mehr als genug vorhanden (ca. 50GB).
gestartet is alles mit "smitty mkdvd", anschliessend soll die ImageDatei als Bootimage abgelegt werden.
Als Meldungen bekomme ich folgendes:
-------------
mkcd-Protokoll /var/adm/ras/mkcd.log wird initialisiert...
Befehlsparameter werden geprüft...
Datei image.data wird erstellt...
Temporäres Dateisystem /mkcd/mksysb_image wird erstellt...
mksysb-Image wird erstellt...
/usr/bin/mksysb[33]: 3877,99: 0403-057 Syntaxfehler
ls: 0653-341 Die Datei /mkcd/mksysb_image/mksysb_27802 ist nicht vorhanden.
Temporäres Dateisystem /mkcd/cd_fs wird erstellt...
create_cd_fs[25]:  CD_FS_NEW_MIN_512 = ( BACKUP_SIZE + BOOT_IMAGE_SIZE_OPT4 + EFI_PARTITION_SIZE + PADDING_128K ) / 512 : 0403-009 Die angegebene Nummer ist für diesen Befehl nicht
gültig.
----------------
Es ist aber egal, ob ich die mkcd-Verzeichnisse/Dateisysteme anlege oder nicht.

Hat jemand eine Idee?

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

KlausJ
Moderator



Sehen Sie sich das Profil von KlausJ an!   Senden Sie eine Private Message an KlausJ  Schreiben Sie einen Gästebucheintrag für KlausJ

Beiträge: 1336
Registriert: 17.03.2003

AIX 6.2
Windows XP

erstellt am: 24. Apr. 2007 13:59    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für TimoSchwaar 10 Unities + Antwort hilfreich

Hallo Timo,
so ganz verstehe ich das nicht. Du willst, so entnehme ich es dem Befehl, sofort eine DVD vom mksysb brennen. Habe ich noch nicht gemacht, aber es sieht so aus als ginge es. Wenn es so ist, dann weiß ich nicht weiter.  Du mußt natürlich dafür einen eingebauten DVD-Brenner haben.

Ist es nicht so, sondern Du möchtest nur das mksysb auf Platte ablegen, dann versuch's mal mit smitty mksysb und gibt die entsprechenden Parameter an.

------------------
Nichts ändern ist langweilig !!

Klaus
   

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

TimoSchwaar
Mitglied
Kfz.-Ingenieur


Sehen Sie sich das Profil von TimoSchwaar an!   Senden Sie eine Private Message an TimoSchwaar  Schreiben Sie einen Gästebucheintrag für TimoSchwaar

Beiträge: 128
Registriert: 01.12.2000

erstellt am: 25. Apr. 2007 08:34    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Klaus,
nein, DVD-Brennen ist ausgestellt. Leider klappt auch die Erzeugung einer Datei per mksysb nicht.(Fehlermeldung wie bei DVD: /usr/bin/mksysb[33]: 3877,99: 0403-057 Syntaxfehler
ls: 0653-341 Die Datei /mkcd/mksysb_image/mksysb_27802 ist nicht vorhanden.)

Ziel ist, ein bootbares DVD-Image zu erstellen, daher smitty mkdvd. Dieses schiebe ich dann übers Netz und brenne es mit Nero. geklappt hat dies schon mal.

gruss,
Timo

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

KlausJ
Moderator



Sehen Sie sich das Profil von KlausJ an!   Senden Sie eine Private Message an KlausJ  Schreiben Sie einen Gästebucheintrag für KlausJ

Beiträge: 1336
Registriert: 17.03.2003

AIX 6.2
Windows XP

erstellt am: 25. Apr. 2007 14:19    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für TimoSchwaar 10 Unities + Antwort hilfreich

Hallo Timo,
ich habe mal in das script /usr/bin/mksysb reingeschaut, aber nichts wie  mkcd oder mksysb_image gefunden. Dort wird nur auf Band oder als File weggeschrieben. Vielleicht schaust Du dort mal bei Dir rein und versuchst zu interpretieren, was gemacht werden soll und was fehlt.
Da wir Installationen nur über NIM machen, habe ich mit DVD keine Erfahrung. Ich fürchte, ich kann Dir so nicht weiterhelfen. 

------------------
Nichts ändern ist langweilig !!

Klaus

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

TimoSchwaar
Mitglied
Kfz.-Ingenieur


Sehen Sie sich das Profil von TimoSchwaar an!   Senden Sie eine Private Message an TimoSchwaar  Schreiben Sie einen Gästebucheintrag für TimoSchwaar

Beiträge: 128
Registriert: 01.12.2000

erstellt am: 25. Apr. 2007 15:47    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities

Hallo Klaus,
danke,
das Studium des mksysb-Scriptes hat mir leider auch keine Erleuchtung gebracht. Bei IBM habe ich eine Erklärung für den Syntaxfehler (nicht zulässige Zeichen im dateinamen, z.B. "+" )gefunden. Allerdings soll der seit AIX 5.2.x abgestellt sein (ich habe 5.3) Ausserdem finde ich da keine Files zu. (lost+found hab ich alles eliminiert)

naja, da muss ich wohl noch etwas überlegen und suchen  

gruss,
Timo


EDIT:
ich habe die Lösung auf einer Französichen Seite gefunden  :
----
Warning:
If LANG=fr_FR, when running the smit mksysb command, you may get the following error message:
/usr/bin/mksysb[33]: 2004,68: 0403-057 Erreur de syntaxe.

In such a situation, you must use the following workaround:
run the command export LANG=C before running the mksysb.
----
bei mir ist LANG=de_DE --> auf "C" kurz umgestellt und es klappt.

gruss,
Timo

[Diese Nachricht wurde von TimoSchwaar am 25. Apr. 2007 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

KlausJ
Moderator



Sehen Sie sich das Profil von KlausJ an!   Senden Sie eine Private Message an KlausJ  Schreiben Sie einen Gästebucheintrag für KlausJ

Beiträge: 1336
Registriert: 17.03.2003

AIX 6.2
Windows XP

erstellt am: 25. Apr. 2007 16:22    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für TimoSchwaar 10 Unities + Antwort hilfreich

Hallo Timo,
das ist doch eine schöne Sch***e. 
Solltest Du irgendwie Kontakt zu IBM haben, dann melde diesen Fehler. 

------------------
Nichts ändern ist langweilig !!

Klaus

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

thoschne
Mitglied


Sehen Sie sich das Profil von thoschne an!   Senden Sie eine Private Message an thoschne  Schreiben Sie einen Gästebucheintrag für thoschne

Beiträge: 1
Registriert: 29.05.2008

erstellt am: 29. Mai. 2008 11:37    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für TimoSchwaar 10 Unities + Antwort hilfreich

Habe gerade das selbe Problem gehabt.
Bei "smitty mksysb" genau der selbe Fehler.
Bei mir war LANG auf de_DE gesetzt. Allerdings auf einer AIX-Kiste
hat es aus unerfindlichen Gründen getan und auf den restlichen 5 kam der Fehler, obwohl alle Maschinen gleich installiert sind.
Nach setzen in der Shell von LANG=en_US hat der "smitty mksysb" ohne Probleme funktioniert. Ich kann mich noch an eine Aussage von einen Arbeitskollegen erinnern:
Es muss die Language unbedingt auf en_US gesetzt werden, ansonsten funktionieren im smitty einige Dinge nicht sauber.

Was mir noch einfällt: Haben vor einigen Wochen von AIX5.3 ML03 auf ML05 upgedatet.

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Stefan_I
Mitglied
Ing HTL


Sehen Sie sich das Profil von Stefan_I an!   Senden Sie eine Private Message an Stefan_I  Schreiben Sie einen Gästebucheintrag für Stefan_I

Beiträge: 865
Registriert: 04.07.2001

CATIA 422R1
VPM1.6 PTF9
CATIA V5R26SP6
CATIA V6 2014x
AIX5.3-ML06
Windows 7 + 10 64Bit

erstellt am: 30. Mai. 2008 12:59    Editieren oder löschen Sie diesen Beitrag!  <-- editieren / zitieren -->   Antwort mit Zitat in Fett Antwort mit kursivem Zitat    Unities abgeben: 1 Unity (wenig hilfreich, aber dennoch)2 Unities3 Unities4 Unities5 Unities6 Unities7 Unities8 Unities9 Unities10 Unities Nur für TimoSchwaar 10 Unities + Antwort hilfreich

Hallo zusammen,

ich habe in der Gegend auch noch einen kleinen Hinweis. Ist auf einem Rechner mit einem:
alt_disk_copy -d hdisk1
eine Disk (hdisk0) kopiert worden, so kann diese nicht mehr einfach als mksysb Master benutzt werden. Das Band ist nicht mehr installierbar. Die alt_rootvg muss nach dem Kopieren gelöscht werden.

Folgende Syntax hat bei mir funktioniert:

alt_disk_copy -d hdisk1
bootlist -m hdisk0
alt_rootvg_opt -X
(kopierte Disk hdisk1 ausbauen)
rmdev -l hdisk1 -d


------------------
Gruss
Stefan Inderbitzin

[Diese Nachricht wurde von Stefan_I am 30. Mai. 2008 editiert.]

Eine Antwort auf diesen Beitrag verfassen (mit Zitat/Zitat des Beitrags) IP

Anzeige.:

Anzeige: (Infos zum Werbeplatz >>)

Darstellung des Themas zum Ausdrucken. Bitte dann die Druckfunktion des Browsers verwenden. | Suche nach Beiträgen

nächster neuerer Beitrag | nächster älterer Beitrag
Antwort erstellen


Diesen Beitrag mit Lesezeichen versehen ... | Nach anderen Beiträgen suchen | CAD.de-Newsletter

Administrative Optionen: Beitrag schliessen | Archivieren/Bewegen | Beitrag melden!

Fragen und Anregungen: Kritik-Forum | Neues aus der Community: Community-Forum

(c)2020 CAD.de | Impressum | Datenschutz